通达信 分时资金突破 分时指标公式源码

通达信 分时资金突破 分时指标公式源码

2024-03-30 0 894
资源编号 3603 最近更新 2024-04-09
¥ 免费 K币
VIP折扣
    折扣详情
  • 问道 半年会员

    免费

  • 闻道 一年会员

    免费

  • 悟道 两年会员

    免费

  • 布道 永久会员

    免费

升级VIP
立即下载 升级会员
下载不了?请联系网站客服提交链接错误!
郑重提醒: 指标和技术只供学习使用,本站不承担由此造成的任何损失!

分时指标安装方法,请查看本站论坛-新手帮助

通达信 分时资金突破 分时指标公式源码
攻击量:=((HSL*0.50+REF(HSL,1)*0.33)+(REF(HSL,2)*0.17))*SUM(C,FROMOPEN)/FROMOPEN;

攻击量A:=SUM(IF(C>REF(C,1),攻击量*V,0),FROMOPEN),COLOR0000FF,LINETHICK0;

攻击量B:=-SUM(IF(C<REF(C,1),攻击量*V,0),FROMOPEN),COLOR00FF00,LINETHICK0;

攻击流量:=攻击量A+攻击量B,COLORSTICK;

攻击比:=攻击流量/SUM(V,FROMOPEN)*100,COLORWHITE,LINETHICK1;

资金攻击度:=IF(攻击比>=0,(攻击比+50),100-Abs((攻击比-50)));

资金流入:=SUM(IF(C>REF(C,1),V,0),FROMOPEN),STICK,COLORWHITE;

资金流出:=-SUM(IF(C<REF(C,1),V,0),FROMOPEN),STICK,COLOR00FF00;

资金出入:=资金流入+资金流出,COLORSTICK;

资金比:=资金出入/SUM(V,FROMOPEN)*100,COLOR00FFFF,LINETHICK1;

资金流量比:=IF(资金比>=0,(资金比+100)/2,100-ABS((资金比-100)/2));

DRAWTEXT_FIX(1,0.250,0.88,0,STRCAT(STRCAT(‘【资金流量比】’,CON2STR(资金流量比,2)),’%买’)),COLORGREEN;

DRAWTEXT_FIX(1,0.000,0.88,0,STRCAT(STRCAT(‘【资金攻击度】’,CON2STR(资金攻击度,2)),’ %买’)),COLORGREEN;

XG:HHV(H,480),DOTLINE,COLORWHITE;

STICKLINE(FILTER(crOSS(C,REF(XG,1)),10) AND C>REF(XG,1),C*0.99,C,8,0),COLORCYAN;

DRAWTEXT(FILTER(CROSS(C,REF(XG,1)),10) AND C>REF(XG,1),C*0.99,’突破’),COLORBLUE;

RQ:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;

JY:=BArslAST((RQ-REF(RQ,1))!=WEEKDAY-REF(WEEKDAY,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0)+1;

ma1:=REF(C,JY);

MA2:=REF(MA1,JY);

MA3:=REF(MA2,JY);

MA4:=REF(MA3,JY);

MA5:=REF(MA4,JY);

MA6:=REF(MA5,JY);

MA7:=REF(MA6,JY);

MA8:=REF(MA7,JY);

MA9:=REF(MA8,JY);

CK:REFDATE((C+MA1+MA2+MA3+MA4+MA5+MA6+MA7+MA8+MA9)/10,DATE),COLORac59FF,CIRCLEDOT;

DRAWTEXT(ISLASTBAR,CK,’ 参考线’),COLOR0000FF;

dif:=(ema(CLOSE,12)-EMA(CLOSE,26))+DYnaINFO(3);

DEA:=EMA(DIF,9);

macd1:=10*(DIF-DEA);

MACD2:=EMA(MACD1,2);

STICKLINE(MACD1>=MACD2 AND MACD1>=0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR0000B4;

STICKLINE(MACD1<MACD2 AND MACD1>0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR00B400;

STICKLINE(MACD1>=MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR5151A2;

STICKLINE(MACD1<MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR88743A;

XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));

主力:=expma(CLOSE/XX,20);大户:=EXPMA(CLOSE/XX,60);散户:=EXPMA(CLOSE/XX,120);

底:=1;1.02,NODRAW;高:=1.03;

DRAWTEXT(CROSS(主力,1.02),C*0.999,’-拉升’),COLORGREEN;

DRAWICON(CROSS(主力,1.04),C,24);

DRAWTEXT(CROSS(主力,1.04),C*0.999,’-冲涨停’),COLORMAGENTA;

A1:=(vol/CLOSE)/3;

A2:=SUM((IF(((A1>40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);

A3:=SUM((IF(((A1>40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);

A4:=SUM((IF(((A1<40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);

A5:=SUM((IF(((A1<40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);

A6:=((A2+A3)+A4)+A5;

A7:=IF((BARSTATUS=2),((100*A2)/A6),0);

A8:=((IF((BARSTATUS=2),((100*A3)/A6),0)));

A9:=((IF((BARSTATUS=2),((100*A4)/A6),0)));

A10:=((IF((BARSTATUS=2),((100*A5)/A6),0)));

机构买盘:=(A2),LINETHICK2;

机构卖盘:=(A3),LINETHICK2;

散户买盘:=(A4);

散户卖盘:=(A5);

DRAWTEXT_FIX(1,0.000,1-0.05,0,STRCAT(STRCAT(‘【机构买盘】’,CON2STR(机构买盘,2)),’万’)),COLORWHITE;

DRAWTEXT_FIX(1,0.250,1-0.05,0,STRCAT(STRCAT(‘【机构卖盘】’,CON2STR(机构卖盘,2)),’万’)),COLOR00FF00;

DRAWTEXT_FIX(1,0.500,1-0.05,0,STRCAT(STRCAT(‘【散户买盘】’,CON2STR(散户买盘,2)),’万’)),COLORWHITE;

DRAWTEXT_FIX(1,0.745,1-0.05,0,STRCAT(STRCAT(‘【散户卖盘】’,CON2STR(散户卖盘,2)),’万’)),COLOR00FF00;

H1:=MAX(DYNAINFO(3),DYNAINFO(5));

L1:=MIN(DYNAINFO(3),DYNAINFO(6));

P1:=H1-L1;

阻力1:=L1+P1*7/8,COLORCYAN;

支撑3:=L1+P1*0.5/8,COLORLIMAGENTA;

DRAWTEXT(LONGCROSS(支撑3,C,2),C,’买’),COLORBLUE;

DRAWTEXT(LONGCROSS(C,阻力1,2),C,’卖’),COLORCYAN;

量价:=(VOL/CLOSE)/3;

B2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);

B3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);

B6:=B2+B3;DD1:=1;比:=B2/B3;

BBB1:=STRCAT(STRCAT(‘买= ‘,CON2STR((100*B2)/B6,0)),’%’);

BBB2:=STRCAT(STRCAT(‘卖= ‘,CON2STR((100*B3)/B6,0)),’%’);

BBB3:=STRCAT(STRCAT(‘差= ‘,CON2STR((100*(B2-B3))/B6,0)),’%’);

DRAWTEXT_FIX(DD1=1,0,0.70,0,BBB1),COLORWHITE;

DRAWTEXT_FIX(DD1=1,0,0.75,0,BBB2),COLORCYAN;

DRAWTEXT_FIX(DD1=1,0,0.80,0,BBB3),COLOR00FFFF;

AAA:=MAX(DYNAINFO(3),DYNAINFO(5));

BBB:=MIN(DYNAINFO(3),DYNAINFO(6));

CCC:=AAA-BBB;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 超级金钻公式 通达信 分时资金突破 分时指标公式源码 https://www.694.cn/jinzuan/3603.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务