通达信 天下无双 主副图指标

2024-04-07 0 756

通达信  天下无双  主副图指标

天下无双主图

参数1: N, 最小: 10, 最大: 60, 缺省: 20

参数2: M, 最小: 20, 最大: 250, 缺省: 90

参数3: DD, 最小: 90, 最大: 6000, 缺省: 250

X_1:=COST(50)=DRAWNULL;

TESTSKIP(CODELIKE(1) OR X_1);

X_2:=AMOUNT/VOL/100;

X_3:=EMA(X_2,N);

X_4:=M;

DIF:EMA(ABS(100*CLOSE/X_3-100),X_4),NODRAW;

HH:X_3*(100+DIF)/100,DOTLINE,COLORRED,LINETHICK2;

MID:X_3,DOTLINE,COLORMAGENTA;

LL:X_3*(100-DIF)/100,DOTLINE,COLORGREEN,LINETHICK2;

HH2:IF(CURRBARSCOUNT<=DD,X_3*(100+DIF*2)/100,DRAWNULL),DOTLINE,COLORYELLOW;

LL2:IF(CURRBARSCOUNT<=DD,X_3*(100-DIF*2)/100,DRAWNULL),DOTLINE,COLORYELLOW;

NOTEXTHH3:IF(CURRBARSCOUNT<=DD,X_3*(100+DIF*3)/100,DRAWNULL),COLORFF8080;

NOTEXTLL3:IF(CURRBARSCOUNT<=DD,X_3*(100-DIF*3)/100,DRAWNULL),COLORFF8080;

STICKLINE(CURRBARSCOUNT<=DD,(HH2+NOTEXTHH3)/2,NOTEXTHH3,0.2,(-1)),COLOREE7070;

STICKLINE(CURRBARSCOUNT<=DD,(LL2+NOTEXTLL3)/2,NOTEXTLL3,0.2,(-1)),COLOREE7070;

X_5:=REF(BARSLAST(CROSS(LL,MAX(CLOSE,OPEN))),1)+1;

X_6:=X_5>=1 AND (CLOSE>OPEN AND CLOSE>REF(CLOSE,1) AND COUNT(CLOSE>REF(CLOSE,1),X_5)=1);

X_7:=REF(BARSLAST(CROSS(LL2,MAX(CLOSE,OPEN))),1)+1;

X_8:=X_7>=1 AND LOW<LL2 AND CLOSE<LL AND CLOSE>OPEN AND CLOSE>REF(CLOSE,1) AND COUNT(CLOSE>REF(CLOSE,1),X_7)=1;

X_9:=HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);

X_10:=HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);

X_11:=HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);

X_12:=HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);

X_13:=REF(HIGH,2)<HIGH AND REF(LOW,2)<LOW AND REF(HIGH,2)>REF(HIGH,1) AND REF(LOW,2)<REF(LOW,1);

X_14:=COUNT(X_9,6)>=3 AND COUNT(X_10 OR X_11,5)=0 AND LLVBARS(LOW,6)=1 AND HHVBARS(HIGH,6)>=5 AND X_12;

X_15:=COUNT(X_9,7)>=3 AND COUNT(X_10 OR X_11,6)=1 AND LLVBARS(LOW,7)=2 AND HHVBARS(HIGH,7)>=6 AND X_13;

X_16:=COUNT(X_9,7)>=3 AND COUNT(X_10 OR X_11,6)=1 AND LLVBARS(LOW,7)=1 AND HHVBARS(HIGH,7)>=6 AND X_12;

X_17:=COUNT(X_9,8)>=3 AND COUNT(X_10 OR X_11,7)<=2 AND LLVBARS(LOW,8)=2 AND HHVBARS(HIGH,8)>=7 AND X_13;

X_18:=COUNT(X_9,8)>=3 AND COUNT(X_10 OR X_11,7)<=2 AND LLVBARS(LOW,8)=1 AND HHVBARS(HIGH,8)>=7 AND X_12;

X_19:=COUNT(X_9,9)>=3 AND COUNT(X_10 OR X_11,8)<=3 AND LLVBARS(LOW,9)=2 AND HHVBARS(HIGH,9)>=8 AND X_13;

X_20:=COUNT(X_9,9)>=3 AND COUNT(X_10 OR X_11,8)<=3 AND LLVBARS(LOW,9)=1 AND HHVBARS(HIGH,9)>=8 AND X_12;

X_21:=COUNT(X_9,10)>=3 AND COUNT(X_10 OR X_11,9)<=4 AND LLVBARS(LOW,10)=2 AND HHVBARS(HIGH,10)>=9 AND X_13;

X_22:=COUNT(X_9,10)>=3 AND COUNT(X_10 OR X_11,9)<=4 AND LLVBARS(LOW,10)=1 AND HHVBARS(HIGH,10)>=9 AND X_12;

X_23:=COUNT(X_9,11)>=3 AND COUNT(X_10 OR X_11,10)<=5 AND LLVBARS(LOW,11)=2 AND HHVBARS(HIGH,11)>=10 AND X_13;

X_24:=COUNT(X_9,3)>=1 AND LLVBARS(LOW,3)=1 AND X_12;

X_25:=COUNT(X_9,4)>=1 AND LLVBARS(LOW,4)=2 AND X_13;

X_26:=COUNT(X_9,4)>=1 AND COUNT(X_10 OR X_11,4)=1 AND LLVBARS(LOW,4)=1 AND X_12;

X_27:=COUNT(X_9,5)>=1 AND COUNT(X_10 OR X_11,5)=2 AND LLVBARS(LOW,5)=2 AND X_13;

X_28:=X_14 OR X_15 OR X_16 OR X_17 OR X_18 OR X_19 OR X_20 OR X_21 OR X_22 OR X_23 OR X_24 OR X_25 OR X_26 OR X_27;

X_29:=X_7>=1 AND X_28 AND COUNT(X_28,X_7)=1;

DRAWICON(X_6 AND NOT(X_8),LOW,1);

DRAWICON(X_8 AND NOT(X_29),LOW,9);

DRAWICON(X_29,LOW,25);

X_30:=REF(BARSLAST(CROSS(MIN(OPEN,CLOSE),HH)),1)+1;

X_31:=CLOSE<OPEN OR CLOSE<REF(CLOSE,1) AND COUNT(CLOSE<HH,X_30)=1;

DRAWICON(X_31,HIGH*1.02,2);

X_32:=REF(BARSLAST(CROSS(MIN(OPEN,CLOSE),NOTEXTHH3) OR CROSS(MIN(OPEN,CLOSE),HH2)),1)+1;

X_33:=CLOSE<OPEN OR CLOSE<REF(CLOSE,1) AND COUNT(CLOSE<NOTEXTHH3,X_32)=1;

X_34:=CLOSE<REF((CLOSE+OPEN)/2,1) AND REF(CLOSE,1)>HH2;

DRAWICON(X_33 OR X_34,HIGH*1.02,15);

 

天下无双抄底副图1

参数1: SZ1, 最小: 1, 最大: 9999, 缺省: 30

参数2: SZ2, 最小: 1, 最大: 9999, 缺省: 500

参数3: N, 最小: 10, 最大: 90, 缺省: 20

参数4: M, 最小: 60, 最大: 250, 缺省: 90

X_1:=NAMELIKE(42)=0 AND NAMELIKE(43)=0 AND NAMELIKE(44)=0 AND NAMELIKE(45)=0 AND NAMELIKE(46)=0;

X_2:=CODELIKE(47)=0;

X_3:=CODELIKE(1)=0;

X_4:=BETWEEN(FINANCE(40),SZ1*100000000,SZ2*100000000);

X_5:=X_1 AND X_2 AND X_3 AND X_4 AND TOTALBARSCOUNT>=120;

X_6:=AMOUNT/VOL/100;

X_7:=EMA(X_6,N);

X_8:=M;

X_9:=EMA(ABS(100*CLOSE/X_7-100),X_8);

X_10:=X_7*(100+X_9)/100;

X_11:=X_7;

X_12:=X_7*(100-X_9)/100;

X_13:=X_7*(100+X_9*2)/100;

X_14:=X_7*(100-X_9*2)/100;

X_15:=X_7*(100+X_9*3)/100;

X_16:=X_7*(100-X_9*3)/100;

X_17:=REF(BARSLAST(CROSS(X_12,MAX(CLOSE,OPEN))),1)+1;

X_18:=X_17>=1 AND (CLOSE>OPEN AND CLOSE>REF(CLOSE,1) AND COUNT(CLOSE>REF(CLOSE,1),X_17)=1);

X_19:=REF(BARSLAST(CROSS(X_14,MAX(CLOSE,OPEN))),1)+1;

X_20:=X_19>=1 AND LOW<X_14 AND CLOSE<X_12 AND CLOSE>OPEN AND CLOSE>REF(CLOSE,1) AND COUNT(CLOSE>REF(CLOSE,1),X_19)=1;

X_21:=HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);

X_22:=HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);

X_23:=HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);

X_24:=HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);

X_25:=REF(HIGH,2)<HIGH AND REF(LOW,2)<LOW AND REF(HIGH,2)>REF(HIGH,1) AND REF(LOW,2)<REF(LOW,1);

X_26:=COUNT(X_21,6)>=3 AND COUNT(X_22 OR X_23,5)=0 AND LLVBARS(LOW,6)=1 AND HHVBARS(HIGH,6)>=5 AND X_24;

X_27:=COUNT(X_21,7)>=3 AND COUNT(X_22 OR X_23,6)=1 AND LLVBARS(LOW,7)=2 AND HHVBARS(HIGH,7)>=6 AND X_25;

X_28:=COUNT(X_21,7)>=3 AND COUNT(X_22 OR X_23,6)=1 AND LLVBARS(LOW,7)=1 AND HHVBARS(HIGH,7)>=6 AND X_24;

X_29:=COUNT(X_21,8)>=3 AND COUNT(X_22 OR X_23,7)<=2 AND LLVBARS(LOW,8)=2 AND HHVBARS(HIGH,8)>=7 AND X_25;

X_30:=COUNT(X_21,8)>=3 AND COUNT(X_22 OR X_23,7)<=2 AND LLVBARS(LOW,8)=1 AND HHVBARS(HIGH,8)>=7 AND X_24;

X_31:=COUNT(X_21,9)>=3 AND COUNT(X_22 OR X_23,8)<=3 AND LLVBARS(LOW,9)=2 AND HHVBARS(HIGH,9)>=8 AND X_25;

X_32:=COUNT(X_21,9)>=3 AND COUNT(X_22 OR X_23,8)<=3 AND LLVBARS(LOW,9)=1 AND HHVBARS(HIGH,9)>=8 AND X_24;

X_33:=COUNT(X_21,10)>=3 AND COUNT(X_22 OR X_23,9)<=4 AND LLVBARS(LOW,10)=2 AND HHVBARS(HIGH,10)>=9 AND X_25;

X_34:=COUNT(X_21,10)>=3 AND COUNT(X_22 OR X_23,9)<=4 AND LLVBARS(LOW,10)=1 AND HHVBARS(HIGH,10)>=9 AND X_24;

X_35:=COUNT(X_21,11)>=3 AND COUNT(X_22 OR X_23,10)<=5 AND LLVBARS(LOW,11)=2 AND HHVBARS(HIGH,11)>=10 AND X_25;

X_36:=COUNT(X_21,3)>=1 AND LLVBARS(LOW,3)=1 AND X_24;

X_37:=COUNT(X_21,4)>=1 AND LLVBARS(LOW,4)=2 AND X_25;

X_38:=COUNT(X_21,4)>=1 AND COUNT(X_22 OR X_23,4)=1 AND LLVBARS(LOW,4)=1 AND X_24;

X_39:=COUNT(X_21,5)>=1 AND COUNT(X_22 OR X_23,5)=2 AND LLVBARS(LOW,5)=2 AND X_25;

X_40:=X_26 OR X_27 OR X_28 OR X_29 OR X_30 OR X_31 OR X_32 OR X_33 OR X_34 OR X_35 OR X_36 OR X_37 OR X_38 OR X_39;

X_41:=X_19>=1 AND X_40 AND COUNT(X_40,X_19)=1;

RET:X_41;

 

无双MACD副图

通达信  天下无双  主副图指标

DRAWGBK(C>0, RGB(180,100,100),RGB(10,50,150),0,”,0);

 

DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),NODRAW;

DEA:EMA(DIF,MID),NODRAW;

 

DRAWBAND(DIF,RGB(150,10,150),0,RGB(10,150,150));

 

MACD:(DIF-DEA)*2,NODRAW;

 

高线:MA(REF(HHV(MACD,周期),1),2),COLORWHITE,DOTLINE;

 

STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,1.5,0),COLORRED;

STICKLINE(MACD>=0 AND MACD<REF(MACD,1),0,MACD,1.5,0),COLOR000050;

STICKLINE(MACD>高线,MAX(高线,0),MACD,1.5,0),COLORYELLOW;

 

STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,1.5,0),COLOR00AA00;

STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1.5,0),COLOR006000;

 

修复:DEA,COLORBLACK,LINETHICK2;

 

DRAWICON(CROSS(DIF,DEA),DEA,1);

DRAWICON(CROSS(DEA,DIF),DIF,2);

 

无双跟庄看盘副图

通达信  天下无双  主副图指标

 

主:=EMA(C,起初);

前N:=0;B1:=1;B2:=主差+1;B3:=主差*2+1;B4:=主差*3+1;B5:=主差*4+1;B6:=主差*5+1;B7:=主差*6+1;

B8:=主差*7+1;B9:=主差*8+1;B10:=主差*9+1;B11:=主差*10+1;B12:=主差*11+1;B13:=主差*12+1;

B14:=主差*13+1;B15:=主差*14+1;B16:=主差*15+1;B17:=主差*16+1;B18:=主差*17+1;B19:=主差*18+1;

B20:=主差*19+1;

S1:=EMA(B1,主线);S2:=EMA(B2,主线);S3:=EMA(B3,主线);S4:=EMA(B4,主线);S5:=EMA(B5,主线);

S6:=EMA(B6,主线);S7:=EMA(B7,主线);S8:=EMA(B8,主线);S9:=EMA(B9,主线);S10:=EMA(B10,主线);

S11:=EMA(B11,主线);S12:=EMA(B12,主线);S13:=EMA(B13,主线);S14:=EMA(B14,主线);

S15:=EMA(B15,主线);S16:=EMA(B16,主线);S17:=EMA(B17,主线);S18:=EMA(B18,主线);

S19:=EMA(B19,主线);S20:=EMA(B20,主线);

 

NOTETEXT1:REF(HHV(主,S1),前N),COLORGREEN;NOTETEXT2:REF(HHV(主,S2),前N),COLORGREEN;

NOTETEXT3:REF(HHV(主,S3),前N),COLORGREEN;NOTETEXT4:REF(HHV(主,S4),前N),COLORGREEN;

NOTETEXT5:REF(HHV(主,S5),前N),COLORGREEN;NOTETEXT6:REF(HHV(主,S6),前N),COLORGREEN;

NOTETEXT7:REF(HHV(主,S7),前N),COLORGREEN;NOTETEXT8:REF(HHV(主,S8),前N),COLORGREEN;

NOTETEXT9:REF(HHV(主,S9),前N),COLORGREEN;NOTETEXT10:REF(HHV(主,S10),前N),COLORGREEN;

NOTETEXT11:REF(HHV(主,S11),前N),COLORGREEN;NOTETEXT12:REF(HHV(主,S12),前N),COLORGREEN;

NOTETEXT13:REF(HHV(主,S13),前N),COLORGREEN;NOTETEXT14:REF(HHV(主,S14),前N),COLORGREEN;

NOTETEXT15:REF(HHV(主,S15),前N),COLORGREEN;NOTETEXT16:REF(HHV(主,S16),前N),COLORGREEN;

NOTETEXT17:REF(HHV(主,S17),前N),COLORGREEN;NOTETEXT18:REF(HHV(主,S18),前N),COLORGREEN;

NOTETEXT19:REF(HHV(主,S19),前N),COLORGREEN;NOTETEXT20:REF(HHV(主,S20),前N),COLORGREEN;

NOTETEXF1:REF(LLV(主,S1),前N),COLORRED;NOTETEXF2:REF(LLV(主,S2),前N),COLORRED;

NOTETEXF3:REF(LLV(主,S3),前N),COLORRED;NOTETEXF4:REF(LLV(主,S4),前N),COLORRED;

NOTETEXF5:REF(LLV(主,S5),前N),COLORRED;NOTETEXF6:REF(LLV(主,S6),前N),COLORRED;

NOTETEXF7:REF(LLV(主,S7),前N),COLORRED;NOTETEXF8:REF(LLV(主,S8),前N),COLORRED;

NOTETEXF9:REF(LLV(主,S9),前N),COLORRED;NOTETEXF10:REF(LLV(主,S10),前N),COLORRED;

NOTETEXF11:REF(LLV(主,S11),前N),COLORRED;NOTETEXF12:REF(LLV(主,S12),前N),COLORRED;

NOTETEXF13:REF(LLV(主,S13),前N),COLORRED;NOTETEXF14:REF(LLV(主,S14),前N),COLORRED;

NOTETEXF15:REF(LLV(主,S15),前N),COLORRED;NOTETEXF16:REF(LLV(主,S16),前N),COLORRED;

NOTETEXF17:REF(LLV(主,S17),前N),COLORRED;NOTETEXF18:REF(LLV(主,S18),前N),COLORRED;

NOTETEXF19:REF(LLV(主,S19),前N),COLORRED;NOTETEXF20:REF(LLV(主,S20),前N),COLORRED;

 

天值:MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(NOTETEXT1,NOTETEXT2),NOTETEXT3),NOTETEXT4),NOTETEXT5),NOTETEXT6),NOTETEXT7),NOTETEXT8),NOTETEXT9),NOTETEXT10),NOTETEXT11),NOTETEXT12),NOTETEXT13),NOTETEXT14),NOTETEXT15),NOTETEXT16),NOTETEXT17),NOTETEXT18),NOTETEXT19),NOTETEXT20),COLORYELLOW,LINETHICK3;

地值:MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(NOTETEXF1,NOTETEXF2),NOTETEXF3),NOTETEXF4),NOTETEXF5),NOTETEXF6),NOTETEXF7),NOTETEXF8),NOTETEXF9),NOTETEXF10),NOTETEXF11),NOTETEXF12),NOTETEXF13),NOTETEXF14),NOTETEXF15),NOTETEXF16),NOTETEXF17),NOTETEXF18),NOTETEXF19),NOTETEXF20),COLORGREEN,LINETHICK3;

价格:C,COLORRED,LINETHICK2;

DRAWICON(FILTER(NOTETEXT1=NOTETEXT20,25),NOTETEXT1+0.3,23),COLORYELLOW;{25红钻,23红十字};

参数较多请认真填全

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 套装公式 通达信 天下无双 主副图指标 https://www.694.cn/ziliaoxiazai/tongdaxin/3872.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务