通达信 九方筹码变道主图,情绪周期,筹码交错,MACD井底喷射等多副图指标

2024-04-07 0 878

通达信 九方筹码变道主图,情绪周期,筹码交错,MACD井底喷射等多副图指标

主图

筹码集中度:=(COST(90+(100-90)/2)-COST((100-90)/2))/(COST(90+(100-90)/2)+COST((100-90)/2))+C;

超短筹:MA(EXPMA(筹码集中度,10),3);

短筹:MA(EXPMA(筹码集中度,20),3),COLORBLUE;

中筹:MA(EXPMA(筹码集中度,60),3);

长筹:MA(EXPMA(筹码集中度,120),3);

DRAWBAND(中筹,RGB(0,100,0),长筹,RGB(0,100,0));

DRAWBAND(短筹,RGB(100,0,100),中筹,RGB(100,0,100));

DRAWBAND(超短筹,RGB(0,0,100),短筹,RGB(0,0,100));

DRAWKLINE(H,O,L,C);

{涨停变黄颜色}

STICKLINE(C>1.09*REF(C,1) AND C=H,C,O,2.5,0),COLORYELLOW;

{跌停变绿颜色}

STICKLINE(C<0.905*REF(C,1) AND C=L,C,O,2.5,0),COLORGREEN;

{炸板}

C22:=REF(C,1);

炸板:=IF((H-C22)*100/C22>=(10-0.01*100/C22),1,0);

涨停10:=IF((C-C22)*100/C22>=(10-0.01*100/C22),1,0);

IF(炸板 AND NOT(涨停10),H*1,DRAWNULL),CIRCLEDOT,COLORFF00FF,LINETHICK1;

高价天数:TOPRANGE(C),COLORLIRED,NODRAW;

IF(高价天数>60,C*1,DRAWNULL),CIRCLEDOT,COLORGREEN,LINETHICK1;

 

九方筹码交错副图

 

HSL:=EMA(V/CAPITAL,3);

ZDL:=HHV(HSL,240);

ZXL:=LLV(HSL,240);

XS:=MA(C,33);

HL10:=WINNER(C/1.1)*100,STICK,COLORRED;

STICKLINE(((C/1.1)*100),HL10,0,2.7,0),COLOR000055;

STICKLINE(((C/1.1)*100),HL10,0,1.7,0),COLOR000077;

STICKLINE(((C/1.1)*100),HL10,0,0.7,0),COLOR0000BB;

STICKLINE(((C/1.1)*100),HL10,0,0.2,0),COLOR0000FF;

HL20:=WINNER(C/1.2)*100,STICK,COLORYELLOW;

STICKLINE(((C/1.2)*100),HL20,0,2.7,0)COLOR009999;

STICKLINE(((C/1.2)*100),HL20,0,1.7,0)COLOR00BBBB;

STICKLINE(((C/1.2)*100),HL20,0,0.7,0)COLOR00DDDD;

STICKLINE(((C/1.2)*100),HL20,0,0.2,0)COLOR00FFFF;

HL30:=WINNER(C/1.3)*100,STICK,COLORFF00FF;

STICKLINE(((C/1.3)*100),HL30,0,2.7,0),COLORFF1100;

STICKLINE(((C/1.3)*100),HL30,0,1.7,0),COLORFF5500;

STICKLINE(((C/1.3)*100),HL30,0,0.7,0),COLORFF9900;

STICKLINE(((C/1.3)*100),HL30,0,0.2,0),COLORFFDD00;

BB:=100,POINTDOT,LINETHICK2,COLORRED;

AA:=15,COLORYELLOW;

DD:=70,COLORYELLOW;

CC:=300,POINTDOT,LINETHICK2,COLORGREEN;

X4:=EMA(C,20);

二十日斜率:(X4-REF(X4,1))/REF(X4,1)*100,LINETHICK0;

十日换手率:SUM(VOL,10)/CAPITAL*100,LINETHICK1;

锁定筹码:EMA((HSL-ZXL)/ZXL*XS,13),LINETHICK2;

浮动筹码:EMA((ZDL-HSL)/HSL*XS,13),LINETHICK2;

力量对比:锁定筹码-浮动筹码,COLORSTICK;

筹码交错:CROSS(锁定筹码,浮动筹码);

DRAWICON(筹码交错,L,15);

 

九方情绪周期副图

 

ZJ:=MA(“KDJ.J#WEEK”(9,3,3) ,5);

AAA:=ZJ<0 AND ZJ<REF(ZJ,1);

BB:=ZJ<0 AND ZJ>=REF(ZJ,1);

DD:=ZJ>=0 AND ZJ>=REF(ZJ,1);

EE:= ZJ>85;

FF:=ZJ<REF(ZJ,1) AND ZJ>0;

TT:=IF(ISLASTBAR,240/FROMOPEN,1);

NN:=120;

HH:=HHV(V*TT,NN);

LL:=LLV(V,NN);

最高:=CONST(HH);

最低:=CONST(LL);

最高2:=CONST(HHV(H,NN));

最低2:=CONST(LLV(L,NN));

PP:=IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,20)),0.9,IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,50)),0.7,0.6)),NODRAW;

RCC1:=最高2*0.9-(最高2-最低2)*PP;

最低3:=MIN(RCC1,最低2);

AA:=最低3;

STICKLINE(AAA,AA-0.000*AA,AA-0.040*AA,2.5,0),COLOR3EA6FF;

STICKLINE(BB,AA-0.000*AA,AA-0.040*AA,2.5,0),COLORFF00FF;

STICKLINE(DD,AA-0.000*AA,AA-0.040*AA,2.5,0),COLOR0000FF;

STICKLINE(EE,AA-0.000*AA,AA-0.040*AA,2.5,1),COLOR00FFFF;

STICKLINE(FF,AA-0.000*AA,AA-0.040*AA,2.5,1),COLORFFFF00;

DRAWTEXT_FIX(1,0.2,0.86,0,’★★ 橘红色–周J<0–底部警示★★粉色–周J拐头–买入★★红色–周J向上–加仓★★黄色–周J>85–风险提示★★青色–周J下跌–持币★★’),COLOR00FFFF;

 

 

九方MACD九方小牛副图

 

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:EMA(DIFF,9);

MACD:(DIFF-DEA)*2,COLORSTICK;

X_1:=MACD<0 AND MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);

STICKLINE(X_1,0,MACD,0.3,0),COLORMAGENTA;

X_2:=MACD>0 AND MACD<REF(MACD,1) AND REF(MACD,1)>REF(MACD,2) AND REF(MACD,2)>REF(MACD,3) AND REF(MACD,3)>REF(MACD,4);

X_3:=DEA-DIFF;

X_4:=IF(MACD<0,SUM(MACD,BARSLAST(X_3<0)),0);

X_5:=LLV(LOW,BARSLAST(X_3<0));

X_6:=HHV(HIGH,BARSLAST(X_3>0));

X_7:=IF(MACD<0,BARSLAST(CROSS(DIFF,DEA)),0);

X_8:=REF(X_4,X_7+1);

X_9:=REF(X_5,X_7+1);

X_10:=IF(X_4<0 AND ABS(X_4)<ABS(X_8),1,0);

X_11:=MACD<0 AND REF(MACD,1)<0 AND CLOSE<X_9 AND ABS(X_4)<ABS(X_8) AND ABS(MACD)<ABS(REF(MACD,1));

X_12:=IF(CROSS(DIFF,DEA),REF(X_10,1),0);

X_13:=IF(DIFF>REF(DIFF,1),REF(X_10,1),0) AND DIFF<0 AND DEA<0;

X_14:=BARSLAST(REF(CROSS(DIFF,DEA),1))*1;

X_15:=REF(CLOSE,X_14+1)>CLOSE AND DIFF>REF(DIFF,X_14+1) AND CROSS(DIFF,DEA)*1;

X_16:=FILTER(X_13,10);

X_17:=FILTER(X_13,10);

X_18:=X_16 AND X_17;

STICKLINE(X_18,(-0.08),DIFF,2,0),COLORLIMAGENTA;

STICKLINE(X_16,0,MACD,0.1,0),COLORYELLOW;

DRAWTEXT(X_16,0+0.01,’九方小牛’),COLORYELLOW;

 

九方井底喷射副图

X_1:=FILTER(REF(CLOSE/MA(CLOSE,40)<0.74 AND (HIGH-LOW)/REF(CLOSE,1)>0.05 AND COUNT((HIGH-LOW)/REF(CLOSE,1)>0.05,5)>1,1) AND (CROSS(POW(ABS(EMA(CLOSE,5)-EMA(EMA(CLOSE,5),5)),1)*POW((EMA(CLOSE,5)-REF(EMA(CLOSE,5),1)+EMA(EMA(CLOSE,5),5)-REF(EMA(EMA(CLOSE,5),5),1))/2,3)/HHV(ABS(POW(ABS(EMA(CLOSE,5)-EMA(EMA(CLOSE,5),5)),1)*POW((EMA(CLOSE,5)-REF(EMA(CLOSE,5),1)+EMA(EMA(CLOSE,5),5)-REF(EMA(EMA(CLOSE,5),5),1))/2,3)),5*3),(-0.9)) OR CLOSE>REF(CLOSE,1)) AND MACD.MACD>(-1.5),10);

井底喷射:COUNT(X_1,13)>=1 AND FILTER(FILTER(REF(SMA(MAX(CLOSE-REF(CLOSE,1),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100,1)<20 AND SMA(MAX(CLOSE-REF(CLOSE,1),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100>REF(SMA(MAX(CLOSE-REF(CLOSE,1),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100,1),5) AND (MA(CLOSE,30)-LOW)/MA(CLOSE,60)*200>20 OR CLOSE>REF(CLOSE,1) AND REF(CLOSE/MA(CLOSE,40)<0.74 AND (HIGH-LOW)/REF(CLOSE,1)>0.05 AND COUNT((HIGH-LOW)/REF(CLOSE,1)>0.05,5)>1,1),10),COLORRED,LINETHICK2;

DRAWICON(X_1>0.1,0.8,38),COLORRED;

STICKLINE(X_1>0.1,0,0.19,8.8,0),COLORMAGENTA;

STICKLINE(X_1>0.1,0,0.19,7.8,0),COLOR238E68;

STICKLINE(X_1>0.1,0,0.56,5,0),COLORYELLOW;

STICKLINE(X_1>0.1,0.16,0.3,3,1),COLORLIMAGENTA;

STICKLINE(X_1>0.1,0,0.1,9,0),COLORBLUE;

STICKLINE(X_1>0.1,0,0.05,9,0),COLORRED;

STICKLINE(X_1>0.1,0.6,0.985,0.1,0);

STICKLINE(X_1>0.1,0.985,0.989,0,0);

DRAWTEXT(X_1>0.1,0.8,’冲天’),COLORYELLOW;

DRAWICON(X_1>0.1,0.56,34),COLORRED;

DRAWICON(X_1>0.1,0.41,31),COLORRED;

DRAWTEXT(X_1>0.1,0.38,’发射’),COLORRED;

DRAWTEXT(X_1>0.1,0.18,’底座’),COLORLIMAGENTA;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 通达信 通达信 九方筹码变道主图,情绪周期,筹码交错,MACD井底喷射等多副图指标 https://www.694.cn/ziliaoxiazai/tongdaxin/3877.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务