通达信 决战牛熊做T神器深V反转 一主图三副图通达信分时指标

2024-04-07 0 389

通达信 决战牛熊做T神器深V反转 一主图三副图通达信分时指标

做T神器分时主图

XG:HHV(H,480),DOTLINE,COLORCYAN;

RQ:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;

JY:=BARSLAST((RQ-REF(RQ,1))!=WEEKDAY-REF(WEEKDAY,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0)+1;

MA1:=REF(C,JY);

MA2:=REF(MA1,JY);

MA3:=REF(MA2,JY);

MA4:=REF(MA3,JY);

MA5:=REF(MA4,JY);

MA6:=REF(MA5,JY);

MA7:=REF(MA6,JY);

MA8:=REF(MA7,JY);

MA9:=REF(MA8,JY);

H1:=MAX(DYNAINFO(3),DYNAINFO(5));

L1:=MIN(DYNAINFO(3),DYNAINFO(6));

P1:=H1-L1;

阻力:L1+P1*8/9,COLORLIRED,DOTLINE;

支撑:L1+P1*0.5/9,COLORGREEN,DOTLINE;

均线:IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0))),COLORYELLOW,DOTLINE;

DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))+DYNAINFO(3);

DEA:=EMA(DIF,9);

MACD1:=10*(DIF-DEA);

MACD2:=EMA(MACD1,2);

STICKLINE(MACD1>=MACD2 AND MACD1>=0,DYNAINFO(3),MACD1+DYNAINFO(3),0,-1),COLORLIGRAY;

STICKLINE(MACD1<MACD2 AND MACD1>0,DYNAINFO(3),MACD1+DYNAINFO(3),0,-1),COLORLICYAN;

STICKLINE(MACD1>=MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,-1),COLORLIGRAY;

STICKLINE(MACD1<MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,-1),COLORLIGREEN;

XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));

主力:=EXPMA(CLOSE/XX,20);大户:=EXPMA(CLOSE/XX,60);散户:=EXPMA(CLOSE/XX,120);

底:=1;1.022,NODRAW;高:=1.033;

DRAWTEXT(CROSS(主力,1.02),C*0.999,’ 拉’),COLORMAGENTA;

DRAWICON(CROSS(主力,1.04),C,45);

DRAWTEXT(CROSS(主力,1.04),C*0.999,’ 冲’),COLORRED;

A1:=(VOL/CLOSE)/3;

A2:=SUM((IF(((A1>40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);

A3:=SUM((IF(((A1>40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);

A4:=SUM((IF(((A1<40) AND (CLOSE>(REF(CLOSE,1)))),A1,0)),0);

A5:=SUM((IF(((A1<40) AND (CLOSE<(REF(CLOSE,1)))),A1,0)),0);

A6:=((A2+A3)+A4)+A5;

A7:=IF((BARSTATUS=2),((100*A2)/A6),0);

A8:=((IF((BARSTATUS=2),((100*A3)/A6),0)));

A9:=((IF((BARSTATUS=2),((100*A4)/A6),0)));

A10:=((IF((BARSTATUS=2),((100*A5)/A6),0)));

DRAWTEXT(LONGCROSS(支撑,C,2),C-0.01,’ 买入’),COLOR0000FF;

DRAWICON(LONGCROSS(支撑,C,2),C-0.01,1);

STICKLINE(LONGCROSS(支撑,C,2),C,阻力,0,-1),COLORCYAN;

DRAWTEXT(LONGCROSS(C,阻力,2),C+0.01,’ 卖出’),COLORGREEN;

DRAWICON(LONGCROSS(C,阻力,2),C+0.01,45);

STICKLINE(LONGCROSS(C,阻力,2),C,支撑,0,-1),COLORRED;

量价:=(VOL/CLOSE)/3;

B2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);

B3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);

B6:=B2+B3;DD1:=1;比:=B2/B3;

D1:=YEAR AND MONTH AND DAY;

BA1:=STRCAT(CON2STR(YEAR,0),’年’);

BA2:=STRCAT(CON2STR(MONTH,0),’月’);

BA3:=STRCAT(CON2STR(DAY,0),’日’);

BA4:=STRCAT(‘星期’,IF(WEEKDAY=1,’一’,IF(WEEKDAY=2,’二’,IF(WEEKDAY=3,’三’,IF(WEEKDAY=4,’四’,IF(WEEKDAY=5,’五’,IF(WEEKDAY=6,’六’,’日’)))))));

AA:=STRCAT(STRCAT(STRCAT(BA1,BA2),STRCAT(BA3,BA4)),”);

DRAWTEXT_FIX(D1,0.905,0,0,AA),COLORGRAY;

WA1:=V*C/100;

WA2:=SUM((IF(((WA1/8>20) AND (CLOSE>(REF(CLOSE,1)))),WA1,0)),0);

WA3:=SUM((IF(((WA1/8>20) AND (CLOSE<(REF(CLOSE,1)))),WA1,0)),0);

WA4:=SUM((IF(((WA1/8<20) AND (CLOSE>(REF(CLOSE,1)))),WA1,0)),0);

WA5:=SUM((IF(((WA1/8<20) AND (CLOSE<(REF(CLOSE,1)))),WA1,0)),0);

WA6:=((A2+A3)+A4)+A5;

WA7:=IF((ISLASTBAR),((100*WA2)/WA6),0);

WA8:=IF((ISLASTBAR),((100*WA3)/WA6),0);

WA9:=IF((ISLASTBAR),((100*WA4)/WA6),0);

WA10:=IF((ISLASTBAR),((100*WA5)/WA6),0);

机构买盘:=(WA2);

机构卖盘:=(WA3);

散户买盘:=(WA4);

散户卖盘:=(WA5);

DRAWTEXT_FIX(1,0.752,1-0.088,0,STRCAT(STRCAT(‘【机构买盘】’,CON2STR(机构买盘,2)),’ 万’)),COLORRED;

DRAWTEXT_FIX(1,0.752,1-0.001,0,STRCAT(STRCAT(‘【机构卖盘】’,CON2STR(机构卖盘,2)),’ 万’)),COLORGREEN;

DRAWTEXT_FIX(1,0.883,1-0.088,0,STRCAT(STRCAT(‘【散户买盘】’,CON2STR(散户买盘,2)),’ 万’)),COLORMAGENTA;

DRAWTEXT_FIX(1,0.883,1-0.001,0,STRCAT(STRCAT(‘【散户卖盘】’,CON2STR(散户卖盘,2)),’ 万’)),COLORCYAN;

 

决战牛熊副图1

大单买:SUM(IF(C>REF(C,1) AND V>4000,V/1000,0),0),COLORRED,LINETHICK3;

大单卖:SUM(IF(C<REF(C,1) AND V>4000,V/1000,0),0),COLORGREEN,LINETHICK3;

买单总:=SUM(IF(C>REF(C,1),V/1000,0),0);

卖单总:=SUM(IF(C<REF(C,1),V/1000,0),0);

小单买:买单总-大单买,COLORLIRED;

小单卖:卖单总-大单卖,COLORLIBLUE;

0,COLORGRAY,LINETHICK3;

 

牛熊强弱分时副图

MA30:=EMA(CLOSE,30);

强弱:EMA(CLOSE,900);

STICKLINE((MA30>强弱),MA30,强弱,1,0),COLOR0000FF;

STICKLINE((MA30<强弱),MA30,强弱,1,0),COLOR00FF00;

H1:=MAX(DYNAINFO(3),DYNAINFO(5));

L1:=MIN(DYNAINFO(3),DYNAINFO(6));

P1:=H1-L1;

阻力:L1+P1*7/8,COLOR00DD00;

支撑:L1+P1*0.5/8,COLOR00DD00;

现价:CLOSE,COLORWHITE,LINETHICK1;

STICKLINE(CROSS(支撑,现价),支撑,阻力,1,0),COLORYELLOW;

DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,’B’),COLORYELLOW;{吸}

DRAWTEXT(LONGCROSS(现价,阻力,2),现价,”),COLORRED;{抛};

 

深V反转分时副图3

X_1:=LLV(LOW,50);

X_2:=HHV(HIGH,50);

X_3:=EMA((CLOSE-X_1)/(X_2-X_1)*100,3);

X_4:=EMA(X_3,8);

X_5:=MA(X_4,8);

X_6:=EMA(CLOSE,20)-EMA(CLOSE,120);

X_7:=EMA(X_6,13);

X_8:=(X_6-X_7)*2;

X_9:=X_8>0 AND CROSS(X_6,X_7) AND X_6<0;

X_10:=CROSS(X_4,X_5) AND X_4<=20;

X_11:=EXIST(X_10,15) AND X_4<=50;

X_12:=X_4>X_5;

分时深V:FILTER(X_9 AND X_11 AND X_12,15);

DRAWTEXT(分时深V,40,’深V’),COLORYELLOW;

STICKLINE(分时深V,50,38,3,0),COLORYELLOW;

STICKLINE(分时深V,38,12,3,0),COLORRED;

STICKLINE(分时深V,12,0,3,0),COLORYELLOW;

DRAWTEXT(分时深V,10,’反转’),COLORYELLOW;

 

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 套装公式 通达信 决战牛熊做T神器深V反转 一主图三副图通达信分时指标 https://www.694.cn/ziliaoxiazai/tongdaxin/3880.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务