通达信 核心主图副图,抓妖关键公式

2024-04-28 0 793

通达信 核心主图副图,抓妖关键公式

主图指标

DRAWGBK(CLOSE>0,RGB(150,50,175),RGB(0,25,100),0,2,0);

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.5,0,0,1),COLORCYAN;

赚钱轨道:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORRED,LINETHICK2;

X_1:=MA(CLOSE,20);

DRAWBAND(赚钱轨道,RGB(155,50,50),X_1,RGB(0,100,50));

IF(赚钱轨道<X_1 OR CLOSE<赚钱轨道,赚钱轨道,DRAWNULL),COLORBLUE,LINETHICK2;

拉升线:IF(赚钱轨道>X_1,X_1,DRAWNULL),COLORMAGENTA,LINETHICK3;

下跌线:IF(赚钱轨道<=X_1,X_1,DRAWNULL),COLORLIBLUE,LINETHICK2;

X_2:=(CLOSE+HIGH+LOW+OPEN)/4;

X_3:=MA((CLOSE*2+HIGH)/3,5);

X_4:=MA((OPEN*2+HIGH)/3,5);

X_5:=MA((CLOSE+LOW*2)/3,5);

X_6:=MA((OPEN+LOW*2)/3,5);

X_7:=OPEN+(CLOSE-OPEN)/2;

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

STICKLINE(DMI.PDI>DMI.MDI,CLOSE,OPEN,2.9,0),COLOR000099;

STICKLINE(DMI.PDI>DMI.MDI,CLOSE,OPEN,1.5,0),COLOR0000CC;

STICKLINE(DMI.PDI>DMI.MDI,CLOSE,OPEN,0.1,0),COLOR9966FF;

STICKLINE(X_3>=X_4,CLOSE,OPEN,2.9,0),COLOR000099;

STICKLINE(X_3>=X_4,CLOSE,OPEN,1.5,0),COLOR0000CC;

STICKLINE(X_3>=X_4,CLOSE,OPEN,0.1,0),COLOR9966FF;

STICKLINE(X_3<X_4 AND DMI.PDI<DMI.MDI,CLOSE,OPEN,2.9,0),COLOR999900;

STICKLINE(X_3<X_4 AND DMI.PDI<DMI.MDI,CLOSE,OPEN,1.5,0),COLORCCCC00;

STICKLINE(X_3<X_4 AND DMI.PDI<DMI.MDI,CLOSE,OPEN,0.1,0),COLORFFFF66;

STICKLINE(X_3>=X_4 AND CLOSE<X_4,X_7,MAX(OPEN,CLOSE),2.8,0),COLORMAGENTA;

STICKLINE(CROSS(X_3,X_4),CLOSE,OPEN,2.8,0),COLORYELLOW;

STICKLINE(X_3<X_4 AND (CROSS(CLOSE,X_6) OR CROSS(X_2,X_6)),X_7,MIN(CLOSE,OPEN),2.8,0),COLORWHITE;

STICKLINE(CROSS(X_4,X_3) AND CLOSE<OPEN AND DMI.PDI<DMI.MDI,CLOSE,OPEN,2.8,0),COLORFF3300;

X_8:=REF(OPEN,1);

X_9:=SMA(MAX(OPEN-X_8,0),6,1)/SMA(ABS(OPEN-X_8),6,1)*100;

X_10:=REF(CLOSE,1);

X_11:=SMA(MAX(CLOSE-X_10,0),6,1)/SMA(ABS(CLOSE-X_10),6,1)*100;

X_12:=REF(HIGH,1);

X_13:=SMA(MAX(HIGH-X_12,0),6,1)/SMA(ABS(HIGH-X_12),6,1)*100;

X_14:=REF(LOW,1);

X_15:=SMA(MAX(LOW-X_14,0),6,1)/SMA(ABS(LOW-X_14),6,1)*100;

X_16:=(MIN(OPEN,CLOSE)-LOW)/LOW*100>VOL/CAPITAL*0.001;

X_17:=(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,13))*100;

X_18:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

X_19:=EMA(X_18,8)*10<(-26);

X_20:=IF(X_16 AND MA(X_17,5)<50 AND X_19,30,0);

X_21:=X_9;

X_22:=X_11;

X_23:=X_13;

X_24:=X_15;

X_25:=MIN(MIN(MIN(X_21,X_22),X_23),X_24);

X_26:=MAX(MAX(MAX(X_21,X_22),X_23),X_24);

DRAWICON(LLV(X_25,5)<=20 OR LLV(X_26,5)<=30 AND CROSS(X_3,X_4),HIGH,9);

X_27:=VOL>REF(VOL,1)*2 AND (CLOSE>=OPEN OR CLOSE>REF(CLOSE,1));

STICKLINE(X_27,CLOSE,OPEN,0.5,0),COLOR0088FF;

DRAWTEXT(CROSS(X_4,X_3) AND CLOSE<赚钱轨道,HIGH,5),COLORCYAN;

X_28:=(CLOSE+LOW+HIGH)/3;

X_29:=ATAN(EMA(X_28,13)-REF(EMA(X_28,13),1))*3.1416*10;

X_30:=EMA(CLOSE,8);

DRAWTEXT(FILTER(X_29>1 AND EMA(X_28,13)>REF(EMA(X_28,8),1),10),X_30,3),COLORWHITE;

X_31:=REF(CLOSE,1);

X_32:=SMA(MAX(CLOSE-X_31,0),3,1)/SMA(ABS(CLOSE-X_31),3,1)*100;

X_33:=EMA(CLOSE,3);

X_34:=EMA(CLOSE,21);

DRAWTEXT(CROSS(X_33,X_34),LOW*0.99,4),COLORA6E500;

DRAWTEXT_FIX(1,0,0,0,GNBLOCK),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0,0.06,0,FGBLOCK),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,ZSBLOCK),COLORYELLOW;

X_35:=INDEXADV;

X_36:=INDEXDEC;

X_37:=X_35/(X_35+X_36)*100;

X_38:=IF(X_37>=70,X_37,DRAWNULL);

X_39:=IF(X_37<70,X_37,DRAWNULL);

DRAWTEXT_FIX(1,0,0.18,0,6);

DRAWNUMBER_FIX(1,0.07,0.18,0,CONST(X_38)),COLORYELLOW;

DRAWNUMBER_FIX(1,0.07,0.18,0,CONST(X_39)),COLORGREEN;

DRAWTEXT_FIX(1,0.11,0.18,0,7);

X_40:=HY_INDEXADV;

X_41:=HY_INDEXDEC;

X_42:=X_40/(X_40+X_41)*100;

X_43:=IF(X_42>=70,X_42,DRAWNULL);

X_44:=IF(X_42<70,X_42,DRAWNULL);

DRAWTEXT_FIX(1,0.13,0.18,0,8);

DRAWNUMBER_FIX(1,0.2,0.18,0,CONST(X_43)),COLORYELLOW;

DRAWNUMBER_FIX(1,0.2,0.18,0,CONST(X_44)),COLORGREEN;

DRAWTEXT_FIX(1,0.24,0.18,0,7);

X_45:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;

X_46:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;

X_47:=FINANCE(23)/FINANCE(10)*3.3;

X_48:=FINANCE(19)/FINANCE(15)*0.6;

X_49:=FINANCE(20)/FINANCE(15)*0.999;

X_50:=X_45+X_46+X_47+X_48+X_49;

DRAWTEXT_FIX(X_50<1.2,0.9,0,0,9),COLORYELLOW;

DRAWTEXT_FIX(BETWEEN(X_50,1.2,2.6),0.9,0,0,10),COLOR0099FF;

DRAWTEXT_FIX(X_50>2.6,0.9,0,0,11),COLORLIBLUE;

副图

X_1:=CROSS(KDJ.K#WEEK,KDJ.D#WEEK);

X_2:=KD.K#WEEK(9,3,3);

X_3:=KD.D#WEEK(9,3,3);

X_4:=FILTER(CROSS(X_2,X_3) AND REF(X_3,1)<30,13);

X_5:=FILTER(CROSS(X_2,X_3) AND REF(X_3,1)>30,13);

X_6:=X_4;

X_7:=MACD.DIF#WEEK(12,26,9);

X_8:=MACD.DEA#WEEK(12,26,9);

X_9:=10;

X_10:=5;

X_11:=FILTER(CROSS(X_7,X_8) AND REF(X_8,1)<0,13);

X_12:=X_11;

X_13:=(HHV(HIGH,X_9)-CLOSE)/(HHV(HIGH,X_9)-LLV(LOW,X_9))*200-125;

X_14:=SMA(X_13,X_10,1)+15;

X_15:=(CLOSE-LLV(LOW,X_9))/(HHV(HIGH,X_9)-LLV(LOW,X_9))*200-105;

X_16:=SMA(X_15,X_10,1)+15;

X_17:=CROSS(X_16,X_14);

X_18:=X_12 AND X_11 AND X_1;

STICKLINE(X_18,1,0,3,0),COLORRED;

STICKLINE(X_18,2,1,2,0),COLORGREEN;

STICKLINE(X_18,3,2,1,0),COLORMAGENTA;

DRAWTEXT(X_18,2.5,6),COLORYELLOW;

选股

X_1:=CROSS(KDJ.K#WEEK,KDJ.D#WEEK);

X_2:=KD.K#WEEK(9,3,3);

X_3:=KD.D#WEEK(9,3,3);

X_4:=FILTER(CROSS(X_2,X_3) AND REF(X_3,1)<30,13);

X_5:=FILTER(CROSS(X_2,X_3) AND REF(X_3,1)>30,13);

X_6:=X_4;

X_7:=MACD.DIF#WEEK(12,26,9);

X_8:=MACD.DEA#WEEK(12,26,9);

X_9:=10;

X_10:=5;

X_11:=FILTER(CROSS(X_7,X_8) AND REF(X_8,1)<0,13);

X_12:=X_11;

X_13:=(HHV(HIGH,X_9)-CLOSE)/(HHV(HIGH,X_9)-LLV(LOW,X_9))*200-125;

X_14:=SMA(X_13,X_10,1)+15;

X_15:=(CLOSE-LLV(LOW,X_9))/(HHV(HIGH,X_9)-LLV(LOW,X_9))*200-105;

X_16:=SMA(X_15,X_10,1)+15;

X_17:=CROSS(X_16,X_14);

选股:X_12 AND X_11 AND X_1;

 

通达信黑马出生副图指标公式源码

LC:=EMA(CLOSE,3);

A:=((SMA(MAX((CLOSE – LC),0),6,1) / SMA(ABS((CLOSE – LC)),6,1)) * 100);

B:=MA(A,10);

QVAR2:=IF(((HIGH + LOW) <= (REF(HIGH,1) + REF(LOW,1))),0,MAX(ABS((HIGH – REF(HIGH,1))),ABS((LOW – REF(LOW,1)))));

QVAR3:=IF(((HIGH + LOW) >= (REF(HIGH,1) + REF(LOW,1))),0,MAX(ABS((HIGH – REF(HIGH,1))),ABS((LOW – REF(LOW,1)))));

QVAR4:=(SUM(QVAR2,13) / (SUM(QVAR2,13) + SUM(QVAR3,13)));

QVAR5:=(SUM(QVAR3,13) / (SUM(QVAR3,13) + SUM(QVAR2,13)));

QVAR9:=((100 – (3 * SMA((((CLOSE – LLV(LOW,75)) / (HHV(HIGH,75) – LLV(LOW,75))) * 100),20,1))) + (2 * SMA(SMA((((CLOSE – LLV(LOW,75)) / (HHV(HIGH,75) – LLV(LOW,75))) * 100),20,1),15,1)));

QVARA:=((100 – (3 * SMA((((OPEN – LLV(LOW,75)) / (HHV(HIGH,75) – LLV(LOW,75))) * 100),20,1))) + (2 * SMA(SMA((((OPEN – LLV(LOW,75)) / (HHV(HIGH,75) – LLV(LOW,75))) * 100),20,1),15,1)));

QVARB:=(((QVAR9 < REF(QVARA,1)) AND (VOL > REF(VOL,1))) AND (CLOSE > REF(CLOSE,1)));

QVAR1A:=((((HHV(HIGH,21) – CLOSE) / (HHV(HIGH,21) – LLV(LOW,21))) * 100) – 10);

QVAR1B:=(((CLOSE – LLV(LOW,21)) / (HHV(HIGH,21) – LLV(LOW,21))) * 100);

QVAR1C:=SMA(QVAR1B,13,8);

QVAR1D:=SMA(QVAR1A,21,8);

杀机乍现:=SMA(QVAR1C,21,8);

见礼台:((A < 15) AND ((杀机乍现 – QVAR1D) < (0 – 65)));

关注3:(IF((见礼台 > 0),40,0) * O),LINETHICK3;

A1:=COST(95);

A2:=COST(5);

天眼通:=(((A1 – A2) * 100) / (A1 + A2));

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 套装公式 通达信 核心主图副图,抓妖关键公式 https://www.694.cn/ziliaoxiazai/tongdaxin/5556.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务