通达信 军师预言神助(指标 副图 通达信 贴图)

2024-04-28 0 897

副图选股:
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=AMOUNT/IF(HIGH=LOW,4,HIGH-LOW);
买1:=QJ0*(MIN(OPEN,CLOSE)-LOW);
买2:=QJ0*(JJ-MIN(CLOSE,OPEN));
卖1:=QJ0*(MAX(CLOSE,OPEN)-JJ);
卖2:=QJ0*(HIGH-MAX(OPEN,CLOSE));
DT:=((买1+买2)-(卖1+卖2))/10000;
主力持仓:=SUM(DT,66);
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上:=(1+7/100)*DD;
下:=(1-7/100)*DD;
中:=(上+下)/2;
军师加仓:DT>0 AND REF(DT>0,1)
AND OPEN<中
AND CLOSE>中
AND VOL>REF(VOL,1)
AND VOL/REF(VOL,1)<2
AND COUNT(REF(C,1)<中,4)=2
AND REF(C/O,1)>1
AND HSL>2;
短线皇帝通达信公式主图源码

DRAWGBK(C>O,RGB(8,28,47),RGB(0,0,0),0,’1′,0);
DRAWKLINE(H,O,L,C);
长期循环线:EMA(C,68)COLORLICYAN,LINETHICK1,CIRCLEDOT;
IF(长期循环线>REF(长期循环线,1),长期循环线,DRAWNULL),COLORRED,LINETHICK1,CIRCLEDOT;
IF(长期循环线<REF(长期循环线,1),长期循环线,DRAWNULL),COLORLICYAN,LINETHICK1,CIRCLEDOT;
操作线:EMA(C,12),COLORLICYAN,LINETHICK2;
IF(操作线>REF(操作线,1),操作线,DRAWNULL),COLORYELLOW,LINETHICK2;
IF(操作线<REF(操作线,1),操作线,DRAWNULL),COLORLICYAN,LINETHICK2;
MA8:EMA(C,23),COLORRED,POINTDOT;
IF(MA8<REF(MA8,1),MA8,DRAWNULL),COLORGREEN,POINTDOT;
MA9:EMA(C,25),COLORRED,POINTDOT;
IF(MA9<REF(MA9,1),MA9,DRAWNULL),COLORGREEN,POINTDOT;
短循环线:EMA(C,24),COLORRED,DOTLINE;
IF(短循环线>REF(短循环线,1),短循环线,DRAWNULL),COLORRED,DOTLINE;
IF(短循环线<REF(短循环线,1),短循环线,DRAWNULL),COLORGREEN,DOTLINE;
{基本面}
总股本:=STRCAT(STRCAT(‘总股本: ‘,CON2STR(TOTALCAPITAL/1000000,2)),’亿’);
流通盘:=STRCAT(STRCAT(‘ 流通盘: ‘,CON2STR(CAPITAL/1000000,2)),’亿’);
市值:=STRCAT(STRCAT(‘ 流通市值: ‘,CON2STR((CAPITAL/1000000)*C,2)),’亿’);
上市日期:=STRCAT(‘ 上市天数: ‘,CON2STR(FINANCE(42),0));
股本市值:=STRCAT(‘股本市值: ‘,STRCAT(STRCAT(STRCAT(总股本,流通盘),市值),上市日期));
DRAWTEXT_FIX(ISLASTBAR,0.02,0.06,0,股本市值),COLORGRAY;
DRAWTEXT_FIX(ISLASTBAR=1 ,0.295,0.01,1,’【 操作原则 】: 小三线顺上短线做多;五线顺上中线做多 ‘),COLORLIGRAY;
{所属板块、概念}
DRAWTEXT_FIX(1,0.02,0.115,0,’行业地域:’),COLORGRAY;
DRAWTEXT_FIX(1,0.07,0.115,0,HYBLOCK),COLORGRAY;{所属行业}
DRAWTEXT_FIX(1,0.12,0.115,0,GNBLOCK),COLORGRAY;{所属概念};
AAA:=(3*C+H+L+O)/6;
VAR1AA:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)
+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
波段线:VAR1AA,COLORRED,LINETHICK1;
{<<波段绝品>>}
SHORT:=12;LONG:=26;MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
空头:STICKLINE((REF(MACD,1)>MACD ) AND (C<波段线 OR (C>波段线 AND 波段线<REF(波段线,1))),C,O,3,0),COLOR808000;
STICKLINE((REF(MACD,1)> MACD AND C<波段线),H,L,0,0),COLOR808000;
头:STICKLINE(C<波段线,C,O,3,0),COLOR808000;
STICKLINE(( C<波段线),H,L,0,0),COLOR808000;
STICKLINE(空头,C,O,2.8,0),COLOR555500;
STICKLINE(空头,C,O,2,0),COLOR888800;
STICKLINE(空头,C,O,1.5,0),COLORAAAA00;
STICKLINE(空头,C,O,1,0),COLORCCCC00;
STICKLINE(空头,C,O,0.5,0),COLOREEEE00;
STICKLINE(头,C,O,2.8,0),COLOR555500;
STICKLINE(头,C,O,2,0),COLOR888800;
STICKLINE(头,C,O,1.5,0),COLORAAAA00;
STICKLINE(头,C,O,1,0),COLORCCCC00;
STICKLINE(头,C,O,0.5,0),COLOREEEE00;
{涨停}{跌停}
AAK:=CLOSE/REF(C,1)>=1.097 AND C=H AND C>EMA(C,68);
STICKLINE(AAK,C,O,1.5,0),COLORYELLOW;
STICKLINE(AAK,O,C,0.2,0),COLOR0000FF;
{共振涨板三色花}
超短:=100*(C-LLV(L,3))/(HHV(C,3)-LLV(L,3));
短期:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
中期:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
中长:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
长期:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
T2X:=MA(C,20)>REF(MA(C,20),1);
T3X:= V>MA(V,5) AND V>MA(V,63);
T4:=MACD.DIF>REF(MACD.DIF,1) AND MACD.DIF>MACD.DEA;
T5:= KDJ.K>REF(KDJ.K,1) AND KDJ.K>50;
T6:=短期>=99 AND 中期>=99 AND 中长>=99 AND 长期>=99;
T7:=H>=REF(C,1)*1.099 AND C>REF(C,1);
TTS:=T2X AND T3X AND T4 AND T5 AND T6,NODRAW;
涨停1:=C>=REF(C,1)*1.0990 AND C=H AND C>EMA(C,24);
STICKLINE(涨停1 AND TTS,O,C,2,0),COLOR0000FF;
STICKLINE(涨停1 AND TTS,O,O+(C-O)*2/3,2,0),COLORYELLOW;
STICKLINE(涨停1 AND TTS,O,O+(C-O)*1/2.5,2,0),COLORFF80FF;
{攻击点}
箱底:=TROUGH(C,10,1)*1.02;
箱底1:=TROUGH(C,10,1)*1.02;
价低箱底:=COUNT(L<箱底,3);
底箱:=TROUGH(C,10,1)*1.05,COLOR008888,LINETHICK1,DOTLINE;
白银:=(EMA(C,24)<EMA(C,68) AND C>EMA(C,24) AND C<EMA(C,68))
OR (EMA(C,24)>EMA(C,68) AND C<EMA(C,24) AND C>EMA(C,68)) AND 价低箱底>=1 AND 箱底<EMA(C,24)
AND C>波段线 AND EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),COLOR00AAAA,NODRAW;
DRAWTEXT((EMA(C,24)<EMA(C,68) AND C>EMA(C,24) AND C<EMA(C,68))
OR (EMA(C,24)>EMA(C,68) AND C<EMA(C,24) AND C>EMA(C,68)) AND 价低箱底>=1 AND 箱底<EMA(C,24)
AND C>波段线 AND EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),L*0.98,’通达信  军师预言神助(指标 副图 通达信 贴图)白银’),COLORA8A8A8;
STICKLINE(白银,OPEN,CLOSE,3.5,0),COLOR5F5F5F;
STICKLINE(白银,OPEN,CLOSE,3.0,0),COLOR6E6E6E;
STICKLINE(白银,OPEN,CLOSE,2.5,0),COLOR747474;
STICKLINE(白银,OPEN,CLOSE,2.0,0),COLOR919191;
STICKLINE(白银,OPEN,CLOSE,1.5,0),COLORA8A8A8;
STICKLINE(白银,OPEN,CLOSE,1.0,0),COLORCDCDCD;
STICKLINE(白银,OPEN,CLOSE,0.5,0),COLOREBEBEB;
STICKLINE(白银,OPEN,CLOSE,0.1,0),COLORWHITE;
杂银:=C<EMA(C,24) AND C<EMA(C,68) AND 价低箱底>=1 AND 箱底<EMA(C,24)
AND C>波段线 AND EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),COLOR00AAAA,NODRAW;
DRAWTEXT(C<EMA(C,24) AND C<EMA(C,68) AND 价低箱底>=1 AND 箱底<EMA(C,24)
AND C>波段线 AND EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),L*0.98,’通达信  军师预言神助(指标 副图 通达信 贴图)杂银’),COLORA8A8A8;
BG1:=(C-O);
STICKLINE(杂银,OPEN,C,3.5,0),COLOR5F5F5F;
STICKLINE(杂银,OPEN,C,1,0),COLORB3F5F9;
STICKLINE(杂银,OPEN,O+BG1/2,3.5,0),COLOR5F5F5F;
STICKLINE(杂银,OPEN,O+BG1/2,3.0,0),COLOR6E6E6E;
STICKLINE(杂银,OPEN,O+BG1/2,2.5,0),COLOR747474;
STICKLINE(杂银,OPEN,O+BG1/2,2.0,0),COLOR919191;
STICKLINE(杂银,OPEN,O+BG1/2,1.5,0),COLORA8A8A8;
STICKLINE(杂银,OPEN,O+BG1/2,1.0,0),COLORCDCDCD;
STICKLINE(杂银,OPEN,O+BG1/2,0.5,0),COLOREBEBEB;
STICKLINE(杂银,OPEN,O+BG1/2,0.1,0),COLORWHITE;
白金:C>EMA(C,24) AND C>EMA(C,68) AND EMA(C,24)>EMA(C,68) AND (EMA(C,24)>REF(EMA(C,24),1)
AND EMA(C,68)>REF(EMA(C,68),1)) AND 价低箱底>=1 AND 箱底<EMA(C,24) AND C>波段线 AND
EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),COLOR00AAAA,NODRAW;
DRAWTEXT(C>EMA(C,24) AND C>EMA(C,68) AND EMA(C,24)>EMA(C,68) AND (EMA(C,24)>REF(EMA(C,24),1)
AND EMA(C,68)>REF(EMA(C,68),1)) AND 价低箱底>=1 AND 箱底<EMA(C,24) AND C>波段线 AND
EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),L*0.98,’通达信  军师预言神助(指标 副图 通达信 贴图)白金’),COLOR00CCCC;
STICKLINE(白金,OPEN,CLOSE,3.5,0),COLOR008888;
STICKLINE(白金,OPEN,CLOSE,1.6,0),COLOR00AAAA;
STICKLINE(白金,OPEN,CLOSE,0.8,0),COLOR00CCCC;
STICKLINE(白金,OPEN,CLOSE,0.2,0),COLOR00FFFF;
黄金:C>EMA(C,24) AND C>EMA(C,68) AND EMA(C,24)<EMA(C,68)
AND 价低箱底>=1 AND 箱底<EMA(C,24) AND C>波段线 AND
EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),COLOR00AAAA,NODRAW;
DRAWTEXT(C>EMA(C,24) AND C>EMA(C,68) AND EMA(C,24)<EMA(C,68)
AND 价低箱底>=1 AND 箱底<EMA(C,24) AND C>波段线 AND
EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),L*0.98,’通达信  军师预言神助(指标 副图 通达信 贴图)黄金’),COLOR00CCCC;
BG:=(C-O);
STICKLINE(黄金,OPEN,C,3.5,0),COLOR008888;
STICKLINE(黄金,OPEN,C,1,0),COLORWHITE;
STICKLINE(黄金,OPEN,O+BG/2,3.5,0),COLOR008888;
STICKLINE(黄金,OPEN,O+BG/2,1.6,0),COLOR00AAAA;
STICKLINE(黄金,OPEN,O+BG/2,0.8,0),COLOR00CCCC;
STICKLINE(黄金,OPEN,O+BG/2,0.2,0),COLOR00FFFF;
IF(波段线<REF(波段线,1),波段线,DRAWNULL),COLORGREEN,LINETHICK1;
攻击线:MA(C,3),COLORGRAY,LINETHICK1,DOTLINE;
IF(攻击线>REF(攻击线,1),攻击线,DRAWNULL),COLORWHITE,LINETHICK1,DOTLINE;
IF(攻击线<REF(攻击线,1),攻击线,DRAWNULL),{COLOR045324}COLORGRAY,LINETHICK1,DOTLINE;
低点转折:=DRAWICON(CROSS(ZIG(3,6),REF(ZIG(3,6),1)),L*0.98,9) ;
DRAWTEXT((低点转折=1),L*0.99,’买’),COLOR1665F8;
高点转折:=DRAWICON(CROSS(REF(ZIG(3,4),1),ZIG(3,4)),H*1.015,15);
DRAWTEXT((高点转折=1),H*1.01,’卖’),COLOR77EE3E;
{KD\MACD金叉、死叉显示}
金叉:=CROSS(KDJ.J,KDJ.D);
死叉:=CROSS(KDJ.D,KDJ.J);
CO1:=(C-O);
STICKLINE(金叉,O,C,0,0),COLORYELLOW;
STICKLINE(金叉,O,O+CO1/2,0.01,0),COLORYELLOW;
STICKLINE(金叉,O,O+CO1/2,0,0),COLORRED;
STICKLINE(金叉,O,O+CO1/5,3.4,0),COLOR335555;
STICKLINE(金叉,O,O+CO1/5,2,0),COLOR338888;
STICKLINE(金叉,O,O+CO1/5,1.5,0),COLOR33AAAA;
STICKLINE(金叉,O,O+CO1/5,1,0),COLOR33CCCC;
STICKLINE(金叉,O,O+CO1/5,0,0),COLOR33EEEE;
金:=CROSS(MACD.DIF,MACD.DEA);
CO11:=(C-O);
STICKLINE(金,O,C,0,0),COLORYELLOW;
STICKLINE(金,O,O+CO11/2,0.3,0),COLORYELLOW;
STICKLINE(金,O,O+CO11/2,0,0),COLORRED;
STICKLINE(金,O,O+CO11/5,3.4,0),COLOR000055;
STICKLINE(金,O,O+CO11/5,2,0),COLOR000088;
STICKLINE(金,O,O+CO11/5,1.5,0),COLOR0000AA;
STICKLINE(金,O,O+CO11/5,1,0),COLOR0000CC;
STICKLINE(金,O,O+CO11/5,0,0),COLOR0000EE;
STICKLINE(死叉,O,O+CO1/5,1.4,0),COLOR4BFE59;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 套装公式 通达信 军师预言神助(指标 副图 通达信 贴图) https://www.694.cn/ziliaoxiazai/tongdaxin/5565.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务