大智慧预测股价(预测最低价最高价等等) 选股指标公式源码

2024-04-24 0 912

{预测股价公式}

{预测当天最低价公式}
A1:=REF(O,1){XG51};
A2:=Abs((REF(C,1)-A1)/A1){XG51};
A3:=ABS((REF(H,1)-A1)/A1){XG51};
A4:=ABS((REF(L,1)-A1)/A1){XG51};
B1:=ABS((A2+A3+A4)/3){XG51};
B2:=O*B1{XG51};
预测低一:O-B2,linethick0{XG51};
最低价:low,coloryellow,linethick0{XG51};
预测高一:=O+B2;

{预测当天股价公式}
开盘价1:=open{XG51};
开盘价2:=REF(open,1){XG51};
最高价1:=high{XG51};
最高价2:=REF(high,1){XG51};
最低价1:=low{XG51};
最低价2:=REF(low,1){XG51};
收盘价1:=CLOSE{XG51};
收盘价2:=REF(CLOSE,1){XG51};
AA:=最高价2{XG51};
BB:=最低价2{XG51};
CC:=开盘价2{XG51};
DD:=收盘价2{XG51};
EE:=(AA+BB+CC+2*DD)/5{XG51};
AAA:=EE+(AA-BB){XG51};
BBB:=2*EE-BB{XG51};
CCC:=2*EE-AA{XG51};
DDD:=EE-(AA-BB){XG51};
上升突破价:=AAA{XG51};
上升阻力价:=BBB{XG51};
下跌支撑价:=CCC{XG51};
下跌反转价:=DDD{XG51};
EEE:=(EE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5{XG51};
心理价:=EEE{XG51};
FFF:=(EEE+开盘价1)/2{XG51};
GGG:=(预测低一+FFF)/2{XG51};
预测低二:GGG,colorffffff,LINETHICK0{XG51};
最高价:high,colorred,linethick0{XG51};
{预测今日最高价公式}
预测高二:=ma(REF(HIGH,1)/REF(CLOSE,2),N)*REF(CLOSE,1){XG51};
开盘价:open,colorffffff,linethick0{XG51};
收盘价:close,coloryellow,linethick0{XG51};
差额一:预测低一-low,colorffffff,LINETHICK0{XG51};
差额二:预测低二-low,colorffffff,LINETHICK0{XG51};
差比一:(差额一/low)*100,colorffffff,LINETHICK0{XG51};
差比二:(差额二/low)*100,colorffffff,LINETHICK0{XG51};
DRAWTEXTREL(10,60,’ ★ 今日最低价:’+NUMTOSTRN(low,2)+’元’),coloryellow,linethick1{XG51};
DRAWTEXTREL(10,200,’ 预测 预测低一: ‘+NUMTOSTRN(ref(预测低一,0),2)+’元’+’ 预测低二: ‘+NUMTOSTRN(ref(ggg,0),2)+’元’),colorffffff,linethick1{XG51};
DRAWTEXTREL(10,350,’目前差价 ‘+NUMTOSTRN(ref(差额一,0),2)+’元 ‘+ NUMTOSTRN(ref(差额二,0),2)+’元’),coloryellow,linethick1{XG51};
DRAWTEXTREL(10,470,’目前差比 ‘+NUMTOSTRN(ref(差比一,0),2)+’% ‘+ NUMTOSTRN(ref(差比二,0),2)+’%’),coloryellow,linethick1;

DRAWTEXTREL(320,150,’ ● 今日最高价:’+NUMTOSTRN(high,2)+’元’),coloryellow,linethick1{XG51};
DRAWTEXTREL(350,350,’ 预测高一: ‘+NUMTOSTRN(ref(预测高一,0),2)+’元’),colorffffff,linethick1{XG51};
DRAWTEXTREL(350,470,’ 预测高二: ‘+NUMTOSTRN(ref(预测高二,0),2)+’元’),colorffffff,linethick1{XG51};
{T + 0 操作数据}
pp:=0.0115;{可调整}
成本价:=预测低二*1.006;{也是买回价}
卖出价:=成本价*(1+pp){XG51};
高低差一:=预测高一-预测低二{XG51};
高低差二:=预测高二-预测低二{XG51};
差价比一:=卖出价/预测高一*100{XG51};
差价比二:=卖出价/预测高二*100{XG51};
昨日高低比:=(最高价2-最低价2)/最高价2*100{XG51};
目前高低比:=(最高价1-最低价1)/最高价1*100{XG51};
ssu1:=卖出价<预测高一 and 卖出价<预测高二{XG51};
ssu2:=卖出价>预测高一 or 卖出价>预测高二 or 差价比一 >98% or 差价比二 >98%;

DRAWTEXTREL(500,60,’ ★ T + 0 操作数据 目前纯利设定为:’+NUMTOSTRN(ref(pp*100,0),2)+’%’),coloryellow,linethick1{XG51};
DRAWTEXTREL(530,200,’ 成本价: ‘+NUMTOSTRN(ref(成本价,0),2)+’元’+’ 卖出价: ‘+NUMTOSTRN(ref(卖出价,0),2)+’元’),colorffffff,linethick1{XG51};
DRAWTEXTREL(530,350,’ 高低差一: ‘+NUMTOSTRN(ref(高低差一,0),2)+’元’+ ‘ 差价比一: ‘+NUMTOSTRN(ref(差价比一,0),2)+’%’),coloryellow,linethick1{XG51};
DRAWTEXTREL(530,470,’ 高低差二: ‘+NUMTOSTRN(ref(高低差二,0),2)+’元’+ ‘ 差价比二: ‘+NUMTOSTRN(ref(差价比二,0),2)+’%’),coloryellow,linethick1{XG51};
DRAWTEXTREL(750,200,’ 买回价: ‘+NUMTOSTRN(ref(ggg,0),2)+’元’),colorffffff,linethick1{XG51};
DRAWTEXTREL(750,470,’ 昨日高低比: ‘+NUMTOSTRN(ref(昨日高低比,0),2)+’%’),colorffffff,linethick1{XG51};
DRAWTEXTREL(750,350,’ 目前高低比: ‘+NUMTOSTRN(ref(目前高低比,0),2)+’%’),colorffffff,linethick1{XG51};
IF BARSTATUS=2 AND ssu1 THEN BEGIN
DRAWTEXTREL(530,610,’ ★ 设定成功’),COLORWHITE,linethick1{XG51};
END
ELSE
IF BARSTATUS=2 AND ssu2 THEN BEGIN
DRAWTEXTREL(530,610,’ ● 设定失败’),COLORgreen,linethick1{XG51};
END
su1:=预测低二>low and 卖出价<high{XG51};
su2:=预测低二<low or 卖出价>high;

IF BARSTATUS=2 AND su1 THEN BEGIN
DRAWTEXTREL(650,610,’★ 操作成功’),COLORWHITE,linethick1{XG51};
END
ELSE
IF BARSTATUS=2 AND su2 THEN BEGIN
DRAWTEXTREL(650,610,’● 操作失败’),COLORgreen,linethick1{XG51};
END

顶线:=80{XG51};
顶线:=80{XG51};
{黄金点:=-20;}
预测一:=-35{XG51};
预测二:=-50{XG51};
失败:=-65{XG51};
底线:=-75{XG51};
DRAWTEXT(DISPSTATUS=2,顶线,’ 80′),COLORred,ALIGN0{XG51};
{DRAWTEXT(DISPSTATUS=2,黄金点,’ 黄金买点‘),COLORffffff,ALIGN0;}
DRAWTEXT(DISPSTATUS=2,预测一,’ 预测一’),COLORred,ALIGN0{XG51};
DRAWTEXT(DISPSTATUS=2,预测二,’ 预测二’),COLORyellow,ALIGN0{XG51};
DRAWTEXT(DISPSTATUS=2,失败,’ 未到位’),COLORgreen,ALIGN0{XG51};
DRAWTEXT(DISPSTATUS=2,底线,’ -75′),COLORgreen,ALIGN0{XG51};
{DRAWTEXT(low<hjmd,-20,’☆’),COLORffffff,ALIGN1;}
{DRAWTEXT(low>hjmd,-20,’●’),COLORgreen,ALIGN1;}
DRAWTEXT(low<预测低一,-35,’☆’),COLORred,ALIGN1{XG51};
DRAWTEXT(low<预测低二,-50,’☆’),COLORyellow,ALIGN1{XG51};
DRAWTEXT(low>预测低二,-65,’●’),COLORgreen,ALIGN1;

{说明:红树林园 这一段源码做出来的效果是买点到位闪烁交替显示[风险]和[注意]}
Amod:=MOD(CURRENTTIME,2){XG51};
DRAWTEXT(DISPSTATUS=2 and Amod=0,50,’预测警示’),colorffffff{XG51};
DRAWTEXT(DISPSTATUS=2 and low<预测低一 and Amod=0,30,’预测一 ☆’),colorred{XG51};
DRAWTEXT(DISPSTATUS=2 and low<预测低一 and Amod=1,30,’预测一 ☆’),coloryellow{XG51};
DRAWTEXT(DISPSTATUS=2 and low<预测低二 and Amod=0,10,’预测二 ☆’),colorred{XG51};
DRAWTEXT(DISPSTATUS=2 and low<预测低二 and Amod=1,10,’预测二 ☆’),coloryellow{XG51};
{DRAWTEXT(DISPSTATUS=2 and low<hjmd and Amod=0,20,’黄金买点 ☆’),colorred;}
{DRAWTEXT(DISPSTATUS=2 and low<hjmd and Amod=1,20,’黄金买点 ☆’),coloryellow;}

DRAWTEXT(DISPSTATUS=2 and low>预测低一 and Amod=0,30,’预测一 ●’),colorgreen{XG51};
DRAWTEXT(DISPSTATUS=2 and low>预测低一 and Amod=1,30,’预测一 ●’),colorffffff{XG51};
DRAWTEXT(DISPSTATUS=2 and low>预测低二 and Amod=0,10,’预测二 ●’),colorgreen{XG51};
DRAWTEXT(DISPSTATUS=2 and low>预测低二 and Amod=1,10,’预测二 ●’),colorffffff{XG51};
{DRAWTEXT(DISPSTATUS=2 and low>hjmd and Amod=0,20,’黄金买点 ●’),colorgreen;}
{DRAWTEXT(DISPSTATUS=2 and low>hjmd and Amod=1,20,’黄金买点 ●’),colorffffff;}{XG51};

{.W~W*W-X_G-5~1_C_N_{^}

大智慧预测股价(预测最低价最高价等等) 选股指标公式源码

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 股票公式 大智慧预测股价(预测最低价最高价等等) 选股指标公式源码 https://www.694.cn/ziliaoxiazai/5379.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务