{转载}实用帝式主图+财务分析

2024-04-30 0 485

以下是{转载}实用帝式主图+财务分析

主图里的财务指标公式可以单独提取出来做个分时主图用

{INPUT:N(2013,1993,2034);
input:K(1,1,3);}
{财务主图}

年报:= PFFININ(1001,N-1,1231 );
去年增长率:= PFFININ(1604,N-1,1231 );
去年收益率:=PFFININ(1002 ,N-1 ,1231 );
三季收益率:= PFFININ(1002,N,0930 );
二季收益率:= PFFININ(1002,N,0630 );
一季收益率:= PFFININ(1002,N,0331 );

三季增长率:= PFFININ(1604,N,0930 );
二季增长率:= PFFININ(1604,N,0630 );
一季增长率:= PFFININ(1604,N,0331 );

DRAWTEXTREL(5,20,\’去年增长率:\’+去年增长率),LINETHICK1,Culoryellow;
DRAWTEXTREL(5,80,\’一季增长率:\’+一季增长率),LINETHICK1,Culoryellow;
DRAWTEXTREL(180,20,\’去年收益率:\’+去年收益率),LINETHICK1,Culoryellow;
DRAWTEXTREL(180,80,\’一季收益率:\’+一季收益率),LINETHICK1,Culoryellow;
DRAWTEXTREL(5,140,\’二季增长率:\’+二季增长率),LINETHICK1,Culoryellow;
DRAWTEXTREL(180,140,\’二季收益率:\’+二季收益率),LINETHICK1,Culoryellow;
DRAWTEXTREL(5,200,\’三季增长率:\’+三季增长率),LINETHICK1,Culoryellow;
DRAWTEXTREL(180,200,\’三季收益率:\’+三季收益率),LINETHICK1,Culoryellow;
DRAWTEXTREL(5,260,\’主题投资:\’+SELFSTRING(\’主题投资\’)),COLORred;
{帝式主图}

T := BARSLAST(DISPSTATUS=1)+1;
A := DISPSTATUS=2;
HH := HHV(H, T);
LL := LLV(L, T);
HL := HH-LL;
wH := HHVBARS(H, T);
wL := LLVBARS(L, T);
KK := wH-wL;
mHL := HH-HL*0.5;
if K=1 then begin
HL191 := (HH-LL)*0.191;
HL382 := (HH-LL)*0.382;
HL618 := (HH-LL)*0.618;
HL809 := (HH-LL)*0.809;
if KK<0 then begin
a1 := HH-HL191;
a2 := HH-HL382;
a3 := HH-HL618;
a4 := HH-HL809;
end else begin
a1 := LL+HL191;
a2 := LL+HL382;
a3 := LL+HL618;
a4 := LL+HL809;
end
end
if k=1 then begin
HL125 := (HH-LL)*0.125;
HL250 := (HH-LL)*0.25;
HL375 := (HH-LL)*0.375;
HL625 := (HH-LL)*0.625;
HL750 := (HH-LL)*0.75;
HL875 := (HH-LL)*0.875;
if kk<0 then begin
b1 := HH-HL125;
b2 := HH-HL250;
b3 := HH-HL375;
b4 := HH-HL625;
b5 := HH-HL750;
b6 := HH-HL875;
end else begin
b1 := LL+HL125;
b2 := LL+HL250;
b3 := LL+HL375;
b4 := LL+HL625;
b5 := LL+HL750;
b6 := LL+HL875;
end
end
DRAWTEXT(A and K3,HH, \’ 最高价:\’+HH),ALIGN2,colorgreen;
DRAWTEXT(A and K3,LL, \’ 最低价:\’+ll),ALIGN2,VALIGN2,colorgreen;
DRAWTEXT(A and K3,mHL,\’ 50%:\’+mHL),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, a1, \’ 0.191:\’+NUMTOSTRN(a1,2)),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, a2, \’ 0.382:\’+NUMTOSTRN(a2,2)),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, a3, \’ 0.618:\’+NUMTOSTRN(a3,2)),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, a4, \’ 0.809:\’+NUMTOSTRN(a4,2)),ALIGN2,color00ffff;
DRAWTEXT(A and K=1, b1, \’ 1/8:\’+NUMTOSTRN(b1,2)),ALIGN2,colorgreen;
DRAWTEXT(A and K=1, b2, \’ 1/4:\’+NUMTOSTRN(b2,2)),ALIGN2,colorgreen;
DRAWTEXT(A and K=1, b3, \’ 3/8:\’+NUMTOSTRN(b3,2)),ALIGN0,colorgreen;
DRAWTEXT(A and K=1, b4, \’ 5/8:\’+NUMTOSTRN(b4,2)),ALIGN0,colorgreen;
DRAWTEXT(A and K=1, b5, \’ 3/4:\’+NUMTOSTRN(b5,2)),ALIGN2,colorgreen;
DRAWTEXT(A and K=1, b6, \’ 7/8:\’+NUMTOSTRN(b6,2)),ALIGN2,colorgreen;
DRAWTEXT(A and K3,HH, \’ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄\’),ALIGN2,colorred,linethick7;
DRAWTEXT(A and K3,LL, \’ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄\’),ALIGN2,colorred,linethick7;
DRAWTEXT(A and K3,mHL,\’ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄\’),ALIGN2,colorff0000,linethick7;
DRAWTEXT(A and K=1, a1, \’﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ \’),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, a2, \’﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ \’),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, a3, \’﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ \’),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, a4, \’﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ \’),ALIGN2,color208FFF,linethick0;
DRAWTEXT(A and K=1, b1, \’﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉\’),ALIGN2,color00FF00;
DRAWTEXT(A and K=1, b2, \’﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉\’),ALIGN2,color00ff00;
DRAWTEXT(A and K=1, b3, \’﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉\’),ALIGN2,color00ff00;
DRAWTEXT(A and K=1, b4, \’﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉\’),ALIGN2,color00ff00;
DRAWTEXT(A and K=1, b5, \’﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉\’),ALIGN2,color00ff00;
DRAWTEXT(A and K=1, b6, \’﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉\’),ALIGN2,color00FF00;

G:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
X:=ZIG(3,5)=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
ED:=barslast(G);
EF:=barslast(X);
买入到卖出天数:ED,LINETHICK0,CulorFFFFFF;
卖出到买入天数:EF,LINETHICK0,CulorFFFFFF;
换手: VOL/CAPITAL*100,LINETHICK0,colorwhite;
DRAWTEXTREL(0,910,\’ 买入到到当前周期:\’+NUMTOSTR(ED) +\’天\’+\’ 卖出到当前周期:\’+NUMTOSTR(EF) +\’天\’+\’ 换手率:\’+NUMTOSTRN(换手,2) +\’%\’ ),colorFfff00;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 大智慧 {转载}实用帝式主图+财务分析 https://www.694.cn/ziliaoxiazai/dazhihui/6070.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务