通达信 中枢画图 主图指标公式

2024-04-27 0 345

通达信 中枢画图 主图指标公式

 

X_1:=stRCAT(5388,STRCAT(STRCAT(STRCAT(5389,HYBLOCK),STRCAT(5390,DYBLOCK)),STRCAT(5391,GNBLOCK)));DRAWTEXT_FIX(ISLASTBAR,0.005,0.02,0,X_1),COLORmaGENTA;

X_2:=REF(CLOSE,1);

X_3:=REF(CLOSE,1)*1.097;

X_4:=CLOSE>=X_3 AND CLOSE=HIGH;

STICKLINE(X_4,OPEN,CLOSE,2.5,0),COLORYELLOW;

X_5:=IF(DTPRICE(REF(CLOSE,1),0.1)=CLOSE,2,0);

STICKLINE(X_5,OPEN,CLOSE,2.5,0),COLORGREEN;

X_6:=LOW<REF(LOW,1) AND HIGH<REF(HIGH,1);

X_7:=LOW>REF(LOW,1) AND HIGH>REF(HIGH,1);

X_8:=LOW<REF(LOW,1) AND HIGH>=REF(HIGH,1) AND REF(LOW,1)>=REF(LOW,2) AND REF(HIGH,1)<=REF(HIGH,2) AND HIGH<REF(HIGH,2) AND COUNT(X_6,BArslAST(X_7))=0;

X_9:=HIGH>REF(HIGH,1) AND LOW<=REF(LOW,1) AND REF(HIGH,1)<=REF(HIGH,2) AND REF(LOW,1)>=REF(LOW,2) AND LOW>REF(LOW,2) AND COUNT(X_7,BARSLAST(X_6))=0;

X_10:=HIGH<REF(HIGH,1) AND REF(LOW,1)<=REF(LOW,2) AND REF(HIGH,1)>=REF(HIGH,2) AND LOW<REF(LOW,2) AND COUNT(X_6,BARSLAST(X_7))=0;X_11:=LOW>REF(LOW,1) AND REF(HIGH,1)>=REF(HIGH,2) AND REF(LOW,1)<=REF(LOW,2) AND HIGH>REF(HIGH,2) AND COUNT(X_7,BARSLAST(X_6))=0;X_12:=X_6 OR X_8 OR X_10;X_13:=X_7 OR X_9 OR X_11;X_14:=X_13 AND COUNT(X_13,BARSLAST(X_12))=1;X_15:=X_12 AND COUNT(X_12,BARSLAST(X_13))=1;X_16:=IF(X_14,LLV(LOW,1+BARSLAST(X_15)),0);X_17:=IF(X_16,X_16,REF(X_16,BARSLAST(X_16)));X_18:=IF(X_15,HHV(HIGH,1+BARSLAST(X_14)),0);X_19:=IF(X_18,X_18,REF(X_18,BARSLAST(X_18)));X_20:=HIGH>=REF(HIGH,1) AND LOW<=REF(LOW,1);X_21:=HIGH<=REF(HIGH,1) AND LOW>=REF(LOW,1);X_22:=X_20 OR X_21;X_23:=HIGH>=REF(HIGH,1) AND LOW<=REF(LOW,1) AND REF(LOW,1)>=REF(HIGH,2) AND REF(HIGH,1)<=REF(HIGH,2) AND HIGH>=REF(HIGH,2);X_24:=HIGH<=REF(HIGH,1) AND LOW>=REF(LOW,1) AND REF(HIGH,1)>=REF(HIGH,2) AND REF(LOW,1)<=REF(LOW,2) AND LOW<=REF(LOW,2);X_25:=X_23 OR X_24 AND (COUNT(X_15,BARSLAST(X_14))=0 OR X_15);X_26:=HIGH>=REF(HIGH,1) AND LOW<=REF(LOW,1) AND REF(HIGH,1)<=REF(HIGH,2) AND REF(LOW,1)>=REF(LOW,2) AND LOW>=REF(LOW,2);X_27:=HIGH<=REF(HIGH,1) AND LOW>=REF(LOW,2) AND REF(LOW,1)<=REF(LOW,2) AND REF(HIGH,1)>=REF(HIGH,2) AND HIGH>=REF(HIGH,2);X_28:=X_26 OR X_27 AND (COUNT(X_14,BARSLAST(X_15))=0 OR X_14);X_29:=X_25 OR X_28;X_30:=BARSLAST(X_17!=REF(X_17,1))-COUNT(X_22,BARSLAST(X_17!=REF(X_17,1)))+COUNT(X_29,BARSLAST(X_17!=REF(X_17,1)))>2 AND HIGH=HHV(HIGH,1+BARSLAST(X_17!=REF(X_17,1))) AND COUNT(LOW<REF(X_17,BARSLAST(X_17!=REF(X_17,1))),BARSLAST(X_17!=REF(X_17,1)))=0 AND BARSLAST(X_17!=REF(X_17,1))>0;X_31:=SUMBARS(X_17!=REF(X_17,1),2)-COUNT(X_22,SUMBARS(X_17!=REF(X_17,1),2))+COUNT(X_29,SUMBARS(X_17!=REF(X_17,1),2))>3 AND HIGH=HHV(HIGH,SUMBARS(X_17!=REF(X_17,1),2)) AND REF(X_17,SUMBARS(X_17!=REF(X_17,1),2)-1)<=LLV(LOW,SUMBARS(X_17!=REF(X_17,1),2));X_32:=SUMBARS(X_17!=REF(X_17,1),3)-COUNT(X_22,SUMBARS(X_17!=REF(X_17,1),3))+COUNT(X_29,SUMBARS(X_17!=REF(X_17,1),3))>3 AND HIGH=HHV(HIGH,SUMBARS(X_17!=REF(X_17,1),3)) AND REF(X_17,SUMBARS(X_17!=REF(X_17,1),3)-1)<=LLV(LOW,SUMBARS(X_17!=REF(X_17,1),3));X_33:=SUMBARS(X_17!=REF(X_17,1),4)-COUNT(X_22,SUMBARS(X_17!=REF(X_17,1),4))+COUNT(X_29,SUMBARS(X_17!=REF(X_17,1),4))>3 AND HIGH=HHV(HIGH,SUMBARS(X_17!=REF(X_17,1),4)) AND REF(X_17,SUMBARS(X_17!=REF(X_17,1),4)-1)<=LLV(LOW,SUMBARS(X_17!=REF(X_17,1),4));X_34:=SUMBARS(X_17!=REF(X_17,1),5)-COUNT(X_22,SUMBARS(X_17!=REF(X_17,1),5))+COUNT(X_29,SUMBARS(X_17!=REF(X_17,1),5))>3 AND HIGH=HHV(HIGH,SUMBARS(X_17!=REF(X_17,1),5)) AND REF(X_17,SUMBARS(X_17!=REF(X_17,1),5)-1)<=LLV(LOW,SUMBARS(X_17!=REF(X_17,1),5));X_35:=SUMBARS(X_17!=REF(X_17,1),6)-COUNT(X_22,SUMBARS(X_17!=REF(X_17,1),6))+COUNT(X_29,SUMBARS(X_17!=REF(X_17,1),6))>3 AND HIGH=HHV(HIGH,SUMBARS(X_17!=REF(X_17,1),6)) AND REF(X_17,SUMBARS(X_17!=REF(X_17,1),6)-1)<=LLV(LOW,SUMBARS(X_17!=REF(X_17,1),6));X_36:=BARSLAST(X_19!=REF(X_19,1))-COUNT(X_22,BARSLAST(X_19!=REF(X_19,1)))+COUNT(X_29,BARSLAST(X_19!=REF(X_19,1)))>2 AND COUNT(HIGH>REF(X_19,BARSLAST(X_19!=REF(X_19,1))),BARSLAST(X_19!=REF(X_19,1)))=0 AND LOW=LLV(LOW,BARSLAST(X_19!=REF(X_19,1))) AND BARSLAST(X_19!=REF(X_19,1))>0;X_37:=SUMBARS(X_19!=REF(X_19,1),2)-COUNT(X_22,SUMBARS(X_19!=REF(X_19,1),2))+COUNT(X_29,SUMBARS(X_19!=REF(X_19,1),2))>3 AND LOW=LLV(LOW,SUMBARS(X_19!=REF(X_19,1),2)) AND REF(X_19,SUMBARS(X_19!=REF(X_19,1),2)-1)>=HHV(HIGH,SUMBARS(X_19!=REF(X_19,1),2));X_38:=SUMBARS(X_19!=REF(X_19,1),3)-COUNT(X_22,SUMBARS(X_19!=REF(X_19,1),3))+COUNT(X_29,SUMBARS(X_19!=REF(X_19,1),3))>3 AND LOW=LLV(LOW,SUMBARS(X_19!=REF(X_19,1),3)) AND REF(X_19,SUMBARS(X_19!=REF(X_19,1),3)-1)>=HHV(HIGH,SUMBARS(X_19!=REF(X_19,1),3));X_39:=SUMBARS(X_19!=REF(X_19,1),4)-COUNT(X_22,SUMBARS(X_19!=REF(X_19,1),4))+COUNT(X_29,SUMBARS(X_19!=REF(X_19,1),4))>3 AND LOW=LLV(LOW,SUMBARS(X_19!=REF(X_19,1),4)) AND REF(X_19,SUMBARS(X_19!=REF(X_19,1),4)-1)>=HHV(HIGH,SUMBARS(X_19!=REF(X_19,1),4));X_40:=SUMBARS(X_19!=REF(X_19,1),5)-COUNT(X_22,SUMBARS(X_19!=REF(X_19,1),5))+COUNT(X_29,SUMBARS(X_19!=REF(X_19,1),5))>3 AND LOW=LLV(LOW,SUMBARS(X_19!=REF(X_19,1),5)) AND REF(X_19,SUMBARS(X_19!=REF(X_19,1),5)-1)>=HHV(HIGH,SUMBARS(X_19!=REF(X_19,1),5));X_41:=SUMBARS(X_19!=REF(X_19,1),6)-COUNT(X_22,SUMBARS(X_19!=REF(X_19,1),6))+COUNT(X_29,SUMBARS(X_19!=REF(X_19,1),6))>3 AND LOW=LLV(LOW,SUMBARS(X_19!=REF(X_19,1),6)) AND REF(X_19,SUMBARS(X_19!=REF(X_19,1),6)-1)>=HHV(HIGH,SUMBARS(X_19!=REF(X_19,1),6));X_42:=X_30 OR X_31 OR X_32 OR X_33 OR X_34 OR X_35;X_43:=X_36 OR X_37 OR X_38 OR X_39 OR X_40 OR X_41;X_44:=X_42 AND COUNT(X_42,1+BARSLAST(X_43))=1;X_45:=X_43 AND COUNT(X_43,1+BARSLAST(X_42))=1;X_46:=IF(X_44,LLV(LOW,1+BARSLAST(X_45)),0);X_47:=IF(X_46,X_46,REF(X_46,BARSLAST(X_46)));X_48:=IF(X_45,HHV(HIGH,1+BARSLAST(X_44)),0);X_49:=IF(X_48,X_48,REF(X_48,BARSLAST(X_48)));X_50:=HHV(HIGH,1+BARSLAST(X_46))=HIGH;X_51:=LLV(LOW,1+BARSLAST(X_48))=LOW;X_52:=FILTERX(X_50,BARSLAST(X_51));X_53:=FILTERX(X_51,BARSLAST(X_50));X_54:=IF(X_53,LOW,0);X_55:=IF(X_52,HIGH,0);X_56:=IF(X_54>0,X_54,REF(X_54,BARSLAST(X_54>0)));X_57:=IF(X_55>0,X_55,REF(X_55,BARSLAST(X_55>0)));X_58:=BARSLAST(X_53)-COUNT(X_22,BARSLAST(X_53))+COUNT(X_29,BARSLAST(X_53))>3 AND COUNT(LOW<REF(X_56,BARSLAST(X_53)),BARSLAST(X_53))=0 AND HIGH=HHV(HIGH,1+BARSLAST(X_53)) AND BARSLAST(X_53)>0;X_59:=BARSLAST(X_52)-COUNT(X_22,BARSLAST(X_52))+COUNT(X_29,BARSLAST(X_52))>3 AND COUNT(HIGH>REF(X_57,BARSLAST(X_52)),BARSLAST(X_52))=0 AND LOW=LLV(LOW,BARSLAST(X_52)) AND BARSLAST(X_52)>0;X_60:=FILTERX(X_58,BARSLAST(X_59));X_61:=FILTERX(X_59,BARSLAST(X_58));X_62:=IF(X_61,LOW,0);X_63:=IF(X_60,HIGH,0);X_64:=IF(X_62>0,X_62,REF(X_62,BARSLAST(X_62>0)));X_65:=IF(X_63>0,X_63,REF(X_63,BARSLAST(X_63>0)));X_66:=LLV(LOW,1+BARSLAST(X_64!=REF(X_64,1) OR (X_62>0 AND X_64=REF(X_64,1))))=LOW AND COUNT(X_65!=REF(X_65,1),BARSLAST(X_64!=REF(X_64,1) OR (X_62>0 AND X_64=REF(X_64,1))))=0;X_67:=HHV(HIGH,1+BARSLAST(X_65!=REF(X_65,1) OR (X_63>0 AND X_65=REF(X_65,1))))=HIGH AND COUNT(X_64!=REF(X_64,1),BARSLAST(X_65!=REF(X_65,1) OR (X_63>0 AND X_65=REF(X_65,1))))=0;X_68:=FILTERX(X_67,BARSLAST(X_66));X_69:=FILTERX(X_66,BARSLAST(X_67));X_70:=IF(X_69,LOW,0);X_71:=IF(X_68,HIGH,0);X_72:=IF(X_70>0,X_70,REF(X_70,BARSLAST(X_70>0)));X_73:=IF(X_71>0,X_71,REF(X_71,BARSLAST(X_71>0)));X_74:=IF(X_72>REF(X_72,1),X_73,REF(X_73,BARSLAST(X_72>REF(X_72,1))));X_75:=IF(X_73<REF(X_73,1),X_72,REF(X_72,BARSLAST(X_73<REF(X_73,1))));X_76:=HIGH>X_74 AND COUNT(HIGH>X_74,BARSLAST(LOW<X_75))=1 AND BARSLAST(X_72>REF(X_72,1))<BARSLAST(X_73>REF(X_73,1));X_77:=LOW<X_75 AND COUNT(LOW<X_75,BARSLAST(HIGH>X_74))=1 AND BARSLAST(X_72<REF(X_72,1))>BARSLAST(X_73<REF(X_73,1));X_78:=IF(X_76,LLV(LOW,1+BARSLAST(X_77)),0);X_79:=IF(X_78,X_78,REF(X_78,BARSLAST(X_78)));X_80:=IF(X_77,HHV(HIGH,1+BARSLAST(X_76)),0);X_81:=IF(X_80,X_80,REF(X_80,BARSLAST(X_80)));X_82:=HHV(HIGH,1+BARSLAST(X_78))=HIGH;X_83:=LLV(LOW,1+BARSLAST(X_80))=LOW;X_84:=FILTERX(X_82,BARSLAST(X_83));X_85:=FILTERX(X_83,BARSLAST(X_82));X_86:=IF(X_85,LOW,0);X_87:=IF(X_84,HIGH,0);X_88:=IF(X_86>0,X_86,REF(X_86,BARSLAST(X_86>0)));X_89:=IF(X_87>0,X_87,REF(X_87,BARSLAST(X_87>0)));X_90:=IF(X_88>REF(X_88,1),X_89,REF(X_89,BARSLAST(X_88>REF(X_88,1))));X_91:=IF(X_89<REF(X_89,1),X_88,REF(X_88,BARSLAST(X_89<REF(X_89,1))));X_92:=HIGH>X_90 AND COUNT(HIGH>X_90,BARSLAST(LOW<X_91))=1;X_93:=LOW<X_91 AND COUNT(LOW<X_91,BARSLAST(HIGH>X_90))=1;X_94:=IF(X_92,LLV(LOW,1+BARSLAST(X_93)),0);X_95:=IF(X_94,X_94,REF(X_94,BARSLAST(X_94)));X_96:=IF(X_93,HHV(HIGH,1+BARSLAST(X_92)),0);X_97:=IF(X_96,X_96,REF(X_96,BARSLAST(X_96)));X_98:=HHV(HIGH,1+BARSLAST(X_94))=HIGH;X_99:=LLV(LOW,1+BARSLAST(X_96))=LOW;X_100:=FILTERX(X_98,BARSLAST(X_99));X_101:=FILTERX(X_99,BARSLAST(X_98));X_102:=IF(X_101,LOW,0);X_103:=IF(X_100,HIGH,0);X_104:=IF(X_102>0,X_102,REF(X_102,BARSLAST(X_102>0)));X_105:=IF(X_103>0,X_103,REF(X_103,BARSLAST(X_103>0)));X_106:=IF(X_104>REF(X_104,1),X_105,REF(X_105,BARSLAST(X_104>REF(X_104,1))));X_107:=IF(X_105<REF(X_105,1),X_104,REF(X_104,BARSLAST(X_105<REF(X_105,1))));X_108:=HIGH>X_106 AND COUNT(HIGH>X_106,BARSLAST(LOW<X_107))=1;X_109:=LOW<X_107 AND COUNT(LOW<X_107,BARSLAST(HIGH>X_106))=1;X_110:=IF(X_108,LLV(LOW,1+BARSLAST(X_109)),0);X_111:=IF(X_110,X_110,REF(X_110,BARSLAST(X_110)));X_112:=IF(X_109,HHV(HIGH,1+BARSLAST(X_108)),0);X_113:=IF(X_112,X_112,REF(X_112,BARSLAST(X_112)));X_114:=HHV(HIGH,1+BARSLAST(X_110))=HIGH;X_115:=LLV(LOW,1+BARSLAST(X_112))=LOW;X_116:=FILTERX(X_114,BARSLAST(X_115));X_117:=FILTERX(X_115,BARSLAST(X_114));X_118:=IF(X_117,LOW,0);X_119:=IF(X_116,HIGH,0);X_120:=IF(X_118>0,X_118,REF(X_118,BARSLAST(X_118>0)));X_121:=IF(X_119>0,X_119,REF(X_119,BARSLAST(X_119>0)));X_122:=X_72!=REF(X_72,1) AND X_72<=REF(X_73,1+BARSLAST(X_73!=REF(X_73,1)));X_123:=MIN(REF(X_73,1+BARSLAST(X_73!=REF(X_73,1))),REF(X_73,BARSLAST(X_73!=REF(X_73,1))));X_124:=MAX(REF(X_72,1+BARSLAST(X_72!=REF(X_72,1))),REF(X_72,BARSLAST(X_72!=REF(X_72,1))));X_125:=IF(X_122,X_123,REF(X_123,BARSLAST(X_122)));X_126:=IF(X_122,X_124,REF(X_124,BARSLAST(X_122)));X_127:=X_73!=REF(X_73,1) AND X_73>=REF(X_72,1+BARSLAST(X_72!=REF(X_72,1)));X_128:=MIN(REF(X_73,1+BARSLAST(X_73!=REF(X_73,1))),REF(X_73,BARSLAST(X_73!=REF(X_73,1))));X_129:=MAX(REF(X_72,1+BARSLAST(X_72!=REF(X_72,1))),REF(X_72,BARSLAST(X_72!=REF(X_72,1))));X_130:=IF(X_127,X_128,REF(X_128,BARSLAST(X_127)));X_131:=IF(X_127,X_129,REF(X_129,BARSLAST(X_127)));X_132:=X_72>REF(X_72,1) AND X_72>LLV(X_73,BARSLAST(X_86>0)) AND COUNT(X_72>REF(X_72,1) AND X_72>LLV(X_73,BARSLAST(X_86>0)),BARSLAST(X_86>0))=1;X_133:=X_122 AND COUNT(X_122,BARSLAST(X_132))=1;X_134:=X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_133)) AND COUNT(X_73<X_126,BARSLAST(X_133))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_133)),BARSLAST(X_133))=1;X_135:=X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_133)) AND COUNT(X_72>X_125,BARSLAST(X_133))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_133)),BARSLAST(X_133))=1;X_136:=X_122 AND COUNT(X_122,BARSLAST(X_134))=1 AND BARSLAST(X_134)>0;X_137:=X_127 AND COUNT(X_127,BARSLAST(X_135))=1 AND BARSLAST(X_135)>0;X_138:=X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_136)) AND COUNT(X_73<X_126,BARSLAST(X_136))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_136)),BARSLAST(X_136))=1;X_139:=X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_136)) AND COUNT(X_72>X_125,BARSLAST(X_136))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_136)),BARSLAST(X_136))=1;X_140:=X_122 AND COUNT(X_122,BARSLAST(X_138))=1 AND BARSLAST(X_138)>0;X_141:=X_127 AND COUNT(X_127,BARSLAST(X_139))=1 AND BARSLAST(X_139)>0;X_142:=X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_140)) AND COUNT(X_73<X_126,BARSLAST(X_140))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_140)),BARSLAST(X_140))=1;X_143:=X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_140)) AND COUNT(X_72>X_125,BARSLAST(X_140))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_140)),BARSLAST(X_140))=1;X_144:=X_122 AND COUNT(X_122,BARSLAST(X_142))=1 AND BARSLAST(X_142)>0;X_145:=X_127 AND COUNT(X_127,BARSLAST(X_143))=1 AND BARSLAST(X_143)>0;X_146:=X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_144)) AND COUNT(X_73<X_126,BARSLAST(X_144))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_144)),BARSLAST(X_144))=1;X_147:=X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_144)) AND COUNT(X_72>X_125,BARSLAST(X_144))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_144)),BARSLAST(X_144))=1;X_148:=X_122 AND COUNT(X_122,BARSLAST(X_146))=1 AND BARSLAST(X_146)>0;X_149:=X_127 AND COUNT(X_127,BARSLAST(X_147))=1 AND BARSLAST(X_147)>0;X_150:=X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_148)) AND COUNT(X_73<X_126,BARSLAST(X_148))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_148)),BARSLAST(X_148))=1;X_151:=X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_148)) AND COUNT(X_72>X_125,BARSLAST(X_148))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_148)),BARSLAST(X_148))=1;X_152:=X_122 AND COUNT(X_122,BARSLAST(X_150))=1 AND BARSLAST(X_150)>0;X_153:=X_127 AND COUNT(X_127,BARSLAST(X_151))=1 AND BARSLAST(X_151)>0;X_154:=X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_152)) AND COUNT(X_73<X_126,BARSLAST(X_152))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_152)),BARSLAST(X_152))=1;X_155:=X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_152)) AND COUNT(X_72>X_125,BARSLAST(X_152))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_152)),BARSLAST(X_152))=1;X_156:=X_122 AND COUNT(X_122,BARSLAST(X_154))=1 AND BARSLAST(X_154)>0;X_157:=X_127 AND COUNT(X_127,BARSLAST(X_155))=1 AND BARSLAST(X_155)>0;X_158:=X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_156)) AND COUNT(X_73<X_126,BARSLAST(X_156))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_125,BARSLAST(X_156)),BARSLAST(X_156))=1;X_159:=X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_156)) AND COUNT(X_72>X_125,BARSLAST(X_156))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_126,BARSLAST(X_156)),BARSLAST(X_156))=1;X_160:=X_122 AND COUNT(X_122,BARSLAST(X_158))=1 AND BARSLAST(X_158)>0;X_161:=X_127 AND COUNT(X_127,BARSLAST(X_159))=1 AND BARSLAST(X_159)>0;X_162:=X_73<REF(X_73,1) AND X_73<HHV(X_72,BARSLAST(X_87>0)) AND COUNT(X_73<REF(X_73,1) AND X_73<HHV(X_72,BARSLAST(X_87>0)),BARSLAST(X_87>0))=1;X_163:=X_127 AND COUNT(X_127,BARSLAST(X_162))=1;X_164:=X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_163)) AND COUNT(X_73<X_131,BARSLAST(X_163))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_163)),BARSLAST(X_163))=1;X_165:=X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_163)) AND COUNT(X_72>X_130,BARSLAST(X_163))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_163)),BARSLAST(X_163))=1;X_166:=X_122 AND COUNT(X_122,BARSLAST(X_164))=1 AND BARSLAST(X_164)>0;X_167:=X_127 AND COUNT(X_127,BARSLAST(X_165))=1 AND BARSLAST(X_165)>0;X_168:=X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_167)) AND COUNT(X_73<X_131,BARSLAST(X_167))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_167)),BARSLAST(X_167))=1;X_169:=X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_167)) AND COUNT(X_72>X_130,BARSLAST(X_167))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_167)),BARSLAST(X_167))=1;X_170:=X_122 AND COUNT(X_122,BARSLAST(X_168))=1 AND BARSLAST(X_168)>0;X_171:=X_127 AND COUNT(X_127,BARSLAST(X_169))=1 AND BARSLAST(X_169)>0;X_172:=X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_171)) AND COUNT(X_73<X_131,BARSLAST(X_171))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_171)),BARSLAST(X_171))=1;X_173:=X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_171)) AND COUNT(X_72>X_130,BARSLAST(X_171))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_171)),BARSLAST(X_171))=1;X_174:=X_122 AND COUNT(X_122,BARSLAST(X_172))=1 AND BARSLAST(X_172)>0;X_175:=X_127 AND COUNT(X_127,BARSLAST(X_173))=1 AND BARSLAST(X_173)>0;X_176:=X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_175)) AND COUNT(X_73<X_131,BARSLAST(X_175))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_175)),BARSLAST(X_175))=1;X_177:=X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_175)) AND COUNT(X_72>X_130,BARSLAST(X_175))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_175)),BARSLAST(X_175))=1;X_178:=X_122 AND COUNT(X_122,BARSLAST(X_176))=1 AND BARSLAST(X_176)>0;X_179:=X_127 AND COUNT(X_127,BARSLAST(X_177))=1 AND BARSLAST(X_177)>0;X_180:=X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_179)) AND COUNT(X_73<X_131,BARSLAST(X_179))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_179)),BARSLAST(X_179))=1;X_181:=X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_179)) AND COUNT(X_72>X_130,BARSLAST(X_179))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_179)),BARSLAST(X_179))=1;X_182:=X_122 AND COUNT(X_122,BARSLAST(X_180))=1 AND BARSLAST(X_180)>0;X_183:=X_127 AND COUNT(X_127,BARSLAST(X_181))=1 AND BARSLAST(X_181)>0;X_184:=X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_183)) AND COUNT(X_73<X_131,BARSLAST(X_183))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_183)),BARSLAST(X_183))=1;X_185:=X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_183)) AND COUNT(X_72>X_130,BARSLAST(X_183))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_183)),BARSLAST(X_183))=1;X_186:=X_122 AND COUNT(X_122,BARSLAST(X_184))=1 AND BARSLAST(X_184)>0;X_187:=X_127 AND COUNT(X_127,BARSLAST(X_185))=1 AND BARSLAST(X_185)>0;X_188:=X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_187)) AND COUNT(X_73<X_131,BARSLAST(X_187))=0 AND COUNT(X_72>REF(X_72,1) AND X_72>REF(X_130,BARSLAST(X_187)),BARSLAST(X_187))=1;X_189:=X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_187)) AND COUNT(X_72>X_130,BARSLAST(X_187))=0 AND COUNT(X_73<REF(X_73,1) AND X_73<REF(X_131,BARSLAST(X_187)),BARSLAST(X_187))=1;X_190:=X_122 AND COUNT(X_122,BARSLAST(X_188))=1 AND BARSLAST(X_188)>0;

X_191:=X_127 AND COUNT(X_127,BARSLAST(X_189))=1 AND BARSLAST(X_189)>0;

X_192:=X_133 OR X_136 OR X_140 OR X_144 OR X_148 OR X_152 OR X_156 OR X_160 OR X_166 OR X_170 OR X_174 OR X_178 OR X_182 OR X_186 OR X_190;

笂2:IF(X_192>0,X_123,REF(X_123,BARSLAST(X_192>0))),DOTLINE,COLORLIRED;

笅2:IF(X_192>0,X_124,REF(X_124,BARSLAST(X_192>0))),DOTLINE,COLORLIRED;

X_193:=(1-笅2)/2+笅2;

X_194:=BARSLAST(X_192);X_195:=BacKSET(X_194=0,SUMBARS(X_71>0,2)-1);

DRAWLINE(crOSS(X_195,0.5),REFX(X_125,BARSNEXT(X_192)),X_192,X_125,0),COLORRED,LINETHICK2;

DRAWLINE(CROSS(X_195,0.5),REFX(X_126,BARSNEXT(X_192)),X_192,X_126,0),COLORRED,LINETHICK2;

DRAWLINE(CROSS(X_195,0.5),(REFX(X_125,BARSNEXT(X_192))-REFX(X_126,BARSNEXT(X_192)))/2+REFX(X_126,BARSNEXT(X_192)),X_192,(REFX(X_125,BARSNEXT(X_192))-REFX(X_126,BARSNEXT(X_192)))/2+REFX(X_126,BARSNEXT(X_192)),0),COLORRED,LINETHICK2;STICKLINE(CROSS(X_195,0.5),REFX(X_125,BARSNEXT(X_192)),REFX(X_126,BARSNEXT(X_192)),0,0),COLORRED,LINETHICK2;STICKLINE(X_192,X_125,X_126,0,0),COLORRED,LINETHICK2;

X_196:=X_137 OR X_137 OR X_141 OR X_145 OR X_149 OR X_153 OR X_157 OR X_161 OR X_163 OR X_167 OR X_171 OR X_175 OR X_179 OR X_183 OR X_187 OR X_191;

笂1:IF(X_196,X_128,REF(X_128,BARSLAST(X_196))),DOTLINE,COLORLIBLUE;

笅1:IF(X_196,X_129,REF(X_129,BARSLAST(X_196))),DOTLINE,COLORLIBLUE;

X_197:=(笂1-笅1)/2+笅1;

X_198:=BARSLAST(X_196);

X_199:=BACKSET(X_198=0,SUMBARS(X_70>0,2)-1);

DRAWLINE(CROSS(X_199,0.5),REFX(X_130,BARSNEXT(X_196)),X_196,X_130,0),COLORLIGREEN,LINETHICK2;

DRAWLINE(CROSS(X_199,0.5),REFX(X_131,BARSNEXT(X_196)),X_196,X_131,0),COLORLIGREEN,LINETHICK2;

DRAWLINE(CROSS(X_199,0.5),(REFX(X_130,BARSNEXT(X_196))-REFX(X_131,BARSNEXT(X_196)))/2+REFX(X_131,BARSNEXT(X_196)),X_196,(REFX(X_130,BARSNEXT(X_196))-REFX(X_131,BARSNEXT(X_196)))/2+REFX(X_131,BARSNEXT(X_196)),0),COLORLIGREEN,LINETHICK2;

STICKLINE(CROSS(X_199,0.5),REFX(X_130,BARSNEXT(X_196)),REFX(X_131,BARSNEXT(X_196)),0,0),COLORLIGREEN,LINETHICK2;STICKLINE(X_196,X_130,X_131,0,0),COLORLIGREEN,LINETHICK2;

X_200:=HHV(HIGH,1+BARSLAST(X_16))=HIGH;

X_201:=LLV(LOW,1+BARSLAST(X_18))=LOW;

X_202:=FILTERX(X_200,BARSLAST(X_201));

X_203:=FILTERX(X_201,BARSLAST(X_200));

X_204:=IF(X_203,LOW,0);X_205:=IF(X_202,HIGH,0);

X_206:=IF(X_204>0,X_204,REF(X_204,BARSLAST(X_204>0)));

X_207:=IF(X_205>0,X_205,REF(X_205,BARSLAST(X_205>0)));

DRAWLINE(X_71,HIGH,X_70,LOW,0),COLORGREEN,LINETHICK2;

DRAWLINE(X_70,LOW,X_71,HIGH,0),COLORRED,LINETHICK2;

X_208:=X_132 OR X_134 OR X_138 OR X_142 OR X_146 OR X_150 OR X_154 OR X_158 OR X_164 OR X_168 OR X_172 OR X_176 OR X_180 OR X_184 OR X_188;

X_209:=X_135 OR X_139 OR X_143 OR X_147 OR X_151 OR X_155 OR X_159 OR X_162 OR X_165 OR X_169 OR X_173 OR X_177 OR X_181 OR X_185 OR X_189;

X_210:=X_208 AND COUNT(X_208,BARSLAST(X_209))=1;

X_211:=X_209 AND COUNT(X_209,BARSLAST(X_208))=1;

X_212:=IF(X_210,LLV(X_72,1+BARSLAST(X_211)),0);

X_213:=IF(X_212,X_212,REF(X_212,BARSLAST(X_212)));

X_214:=IF(X_211,HHV(X_73,1+BARSLAST(X_210)),0);

X_215:=IF(X_214,X_214,REF(X_214,BARSLAST(X_214)));

DRAWICON(X_208,LOW,1);

DRAWICON(X_209,HIGH,2);

X_216:=1+COUNT(X_206<REF(X_206,1),1+BARSLAST(X_206>REF(X_206,1)));

X_217:=1+COUNT(X_207>REF(X_207,1),1+BARSLAST(X_207<REF(X_207,1)));

DRAWNUMBER(X_206<REF(X_206,1),LOW,X_216),NODRAW,COLORGREEN;

DRAWNUMBER(X_206>REF(X_206,1),LOW,1),NODRAW,COLORGREEN;

DRAWNUMBER(X_207>REF(X_207,1),HIGH+(SUM(HIGH-LOW,5)-HHV(HIGH-LOW,5))/8,X_217),NODRAW,COLORRED;

DRAWNUMBER(X_207<REF(X_207,1),HIGH+(SUM(HIGH-LOW,5)-HHV(HIGH-LOW,5))/8,1),NODRAW,COLORRED;

DRAWTEXT(CROSS(zig(3,8),REF(ZIG(3,8),1)),LOW*0.978,’波段底‘),LINETHICK2,COLORLIGRAY;

DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,’波段顶‘),LINETHICK2,COLORLIGRAY;

趋势线:EMA(EMA(EMA(EMA(EMA(CLOSE,55),2),2),2),2),LINETHICK1,COLORFF00FF;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 通达信 通达信 中枢画图 主图指标公式 https://www.694.cn/ziliaoxiazai/tongdaxin/5444.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务