通达信 指标MACD序列副图

2024-04-28 0 618

SHORT:=12;
LONG:=26;
MID:=9;
DIF1:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA1:=EMA(DIF1,MID);
MACD1:=(DIF1-DEA1)*2;
MH:=MACD1;
HHM:=CONST(HHV(MACD1,240));
MM:=0.3*HHM;
DIF:DIF1,COLORGREEN,LINETHICK2;
DEA:DEA1,COLORWHITE,LINETHICK2;
DIF升:IF(DIF>=REF(DIF,1),DIF,DRAWNULL),COLORMAGENTA,LINETHICK2;
DEA升:IF(DEA>=REF(DEA,1),DEA,DRAWNULL),COLORLIRED,LINETHICK2;
MACD:MACD1,COLORSTICK,COLORYELLOW,LINETHICK2;
金叉:=CROSS(DIF,DEA);
轴上金叉:=金叉 AND DEA>0;
轴上周期:=BARSLAST(CROSS(0,DEA));
轴上金叉数:=COUNT(轴上金叉,轴上周期);
二次金叉:=轴上金叉 AND 轴上金叉数=2;
TDXSTEP288:DRAWICON(二次金叉,0.8*DEA,1);
TDXSTEP289:DRAWICON(二次金叉,0.7*DEA,1);
A1:=BARSLAST(REF(CROSS(DIF,DEA) AND DIF<0,1));
HC:=HHV(CLOSE,6);
B1:=REF(HC,A1+1)>HC AND REF(DIF,A1+1)<DIF AND CROSS(DIF,DEA) AND DIF<0 AND A1>=12;
K:=KDJ.K(9,3,3);
D:=KDJ.D(9,3,3);
R1:=RSI.RSI1(6,12,24);
R2:=RSI.RSI2(6,12,24);
A2:=BARSLAST(REF(CROSS(K,D),1));
B2:=REF(CLOSE,A2+1)>CLOSE AND REF(K,A2+1)<K AND CROSS(K,D) AND A2>=9;
A3:=BARSLAST(REF(CROSS(R1,R2),1));
B3:=REF(CLOSE,A3+1)>CLOSE AND REF(R1,A3+1)<R1 AND CROSS(R1,R2) AND A3>=6;
C1:=BARSLAST(REF(CROSS(DEA,DIF) AND DIF>0,1));
LC:=LLV(CLOSE,6);
D1:=REF(LC,C1+1)<LC AND REF(DIF,C1+1)>DIF AND CROSS(DEA,DIF) AND DIF>0 AND C1>=12;
C2:=BARSLAST(REF(CROSS(D,K),1));
D2:=REF(CLOSE,C2+1)<CLOSE AND REF(K,C2+1)>K AND CROSS(D,K) AND C2>=9;
C3:=BARSLAST(REF(CROSS(R2,R1),1));
D3:=REF(CLOSE,C3+1)<CLOSE AND REF(R1,C3+1)>R1 AND CROSS(R2,R1) AND C3>=6;
M底背:IF(B1>0,1,0),NODRAW,COLORRED;
K底背:IF(B2>0,1,0),NODRAW,COLORMAGENTA;
R底背:IF(B3>0,1,0),NODRAW,COLORYELLOW;
M顶背:IF(D1>0,1,0),NODRAW,COLORRED;
K顶背:IF(D2>0,1,0),NODRAW,COLORMAGENTA;
R顶背:IF(D3>0,1,0),NODRAW,COLORYELLOW;
TDXSTEP290:STICKLINE(M底背,-MM,0,3,0),COLORRED;
TDXSTEP291:STICKLINE(K底背,-MM,0,3,0),COLORMAGENTA;
TDXSTEP292:STICKLINE(R底背,-MM,0,3,0),COLORYELLOW;
TDXSTEP293:STICKLINE(M顶背,MM,0,3,0),COLORRED;
TDXSTEP294:STICKLINE(K顶背,MM,0,3,0),COLORMAGENTA;
TDXSTEP295:STICKLINE(R顶背,MM,0,3,0),COLORYELLOW;
TDXSTEP296:STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,1,0),COLOR00CCFF,LINETHICK2;
TDXSTEP297:STICKLINE(MACD>=REF(MACD,1) AND MACD>0,0,MACD,1,0),COLORRED,LINETHICK2;
TDXSTEP298:STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1,0),COLORFF5599,LINETHICK2;
TDXSTEP299:STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1,0),COLORFFFF55,LINETHICK2;
{DRAWTEXT(M底背,0.12,’ M底背’),COLORRED;
DRAWTEXT(K底背,0.12,’ K底背’),COLORMAGENTA;
DRAWTEXT(R底背,0.12,’ R底背’),COLORYELLOW;
DRAWTEXT(M顶背,0.12,’ M顶背’),COLORRED;
DRAWTEXT(K顶背,0.12,’ K顶背’),COLORMAGENTA;
DRAWTEXT(R顶背,0.12,’ R顶背’),COLORYELLOW;}
J:KDJ.J,NODRAW;
RSI:R1,NODRAW,COLORMAGENTA,LINETHICK2;
CCI:CCI,NODRAW;
TJ:=MACD>0;T:=MACD<0;
A:=LLV(MACD,50)=MACD;
DRAWICON(A AND FILTERX(A,20), MACD,1);
{MACD缩小再放大
TA:=MACD.MACD;
TB:=REF(TA,2)>MAX(0 ,REF(TA,1));
TC:=REF(TA,1)>-0.005 AND TA>MAX(0,REF(TA,1));
DRAWICON(TB AND TC,MACD,7);}
{时间序列}
DRAWTEXT(BARSLAST(TJ)=1,MACD,’1′),COLORGREEN;
DRAWTEXT(BARSLAST(TJ)=2,MACD,’2′),COLORGREEN;
DRAWTEXT(BARSLAST(TJ)=3,MACD,’3′),COLORGREEN;
DRAWTEXT(BARSLAST(TJ)=5,MACD,’5′),COLORGREEN;
DRAWTEXT(BARSLAST(TJ)=8,MACD,’8′),COLORGREEN;
DRAWTEXT(BARSLAST(TJ)=13,MACD,’13’),COLORGREEN;
DRAWTEXT(BARSLAST(TJ)=21,MACD,’21’),COLORGREEN;
DRAWTEXT(BARSLAST(TJ)=34,MACD,’34’),COLORGREEN;
DRAWTEXT(BARSLAST(TJ)=55,MACD,’55’),COLORGREEN;
DRAWTEXT(BARSLAST(T)=1,MACD,’1′),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=2,MACD,’2′),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=3,MACD,’3′),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=5,MACD,’5′),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=8,MACD,’8′),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=13,MACD,’13’),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=21,MACD,’21’),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=34,MACD,’34’),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=55,MACD,’55’),COLORYELLOW;

通达信 指标MACD序列副图

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 通达信 通达信 指标MACD序列副图 https://www.694.cn/ziliaoxiazai/tongdaxin/5550.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务