同花顺顺势操作副图源码

2024-05-22 0 585

以下是同花顺顺势操作副图源码

《软件炒股高手绝技》指标,欢迎大家试用看看。

n:=5;
n1:=10;
n2:=20;
n3:=30;
A74:=MA(CLOSE,20);
A75:=(CLOSE > MA(CLOSE,5));
A76:=(MA(CLOSE,5) > MA(CLOSE,10));
A77:=(CLOSE > MA(CLOSE,10));
A78:=(MA(CLOSE,5) > MA(CLOSE,20));
A79:=(CLOSE > MA(CLOSE,20));
A710:=REF(A74,1);
A711:=(A74 > A710);
AVX:=(((((IF(A75,10,(0 – 10)) + IF(A76,10,(0 – 10))) + IF(A77,10,(0 – 10))) + IF(A78,10,(0 – 10))) + IF(A79,10,(0 – 10))) + IF(A711,10,(0 – 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
//{趋势}
AA10:MA(CLOSE,8),color0000FF;
AA12:MA(CLOSE,12),color0000FF;
BB10:=((ATAN((AA10 – REF(AA10,1))) * 3.1416) * 10);
BB12:=((ATAN((AA12 – REF(AA12,1))) * 3.1416) * 10);
MA13:=MA(CLOSE,13);
FILLRGN(AA10,AA12,(((AA12 = 1)) AND (BB10 >= 1)),Culor0098FF);
FILLRGN(AA10,AA12,(((AA12 >= AA10) AND (BB10 <= 1)) AND (BB10 <= 1)),color00FF00);
//{45度异动}
x1:=(C+L+H)/3;
bb13:=ATAN(EMA(x1,13)-REF(EMA(x1,13),1))*3.1416*10;
ema8:=EMA(C,8);
DRAWTEXT(FILTER(bb13>1 AND EMA(x1,13)>REF(EMA(x1,8),1),10),
ema8,\’∠45上升\’),colorblack;
//{压力支撑}
压力:MA(REF(HHV(C,30),1),2),Culor9D00FF;
支撑:MA(REF(LLV(C,30),1),2),CulorABdd46;
//{老鼠仓}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(ff1,(LOW* 0.99),\’老鼠仓\’),Culor4080FF;
//{黑马线}
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:=EMA(A51,5);
A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,(HIGH* 0.97),\’▲大黑马\’),COLOR0055ff;
//{顶底背离}
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE – LC),0),3,1) / SMA(ABS((CLOSE – LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),\’B\’),CulorFF00FF;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),\’S\’),CulorA6E500;
//{短线}
VAR2:=LLV(LOW,27);
VAR3:=HHV(HIGH,34);
VAR4:=EMA((CLOSE-Var2)/(Var3-Var2)*4,4)*25;
注意买:=IF((Var4<10),80,100);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
超跌:=IF(J<0,10,0);
BDDD:=LLV(J,2)=LLV(J,8);
买入:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND J<20,30,0);
DRAWTEXT(买入 AND 注意买=100 AND 超跌=0,LOW,\’短线\’),Culor8000FF;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买3:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER(买3=1,5),LOW-0.03,\’拉升\’),CulorFFDE00;
//{K线}
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLORff7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORff9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORffbb00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORffcc00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORffdd00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORffee00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORffFF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000bb;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000dd;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000ff;
var9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
STICKLINE(var9Q,C,(O+C)/2,7,0),color000055;
STICKLINE(var9Q,C,(O+C)/2,6,0),color000066;
STICKLINE(var9Q,C,(O+C)/2,5,0),color000077;
STICKLINE(var9Q,C,(O+C)/2,4,0),color000099;
STICKLINE(var9Q,C,(O+C)/2,3,0),color0000bb;
STICKLINE(var9Q,C,(O+C)/2,2,0),color0000dd;
STICKLINE(var9Q,C,(O+C)/2,1,0),color0000ff;
varaQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
STICKLINE(varaQ,C,(O+C)/2,7,0),colorff11ff;
STICKLINE(varaQ,C,(O+C)/2,6,0),colorff33ff;
STICKLINE(varaQ,C,(O+C)/2,5,0),colorff55ff;
STICKLINE(varaQ,C,(O+C)/2,4,0),colorff77ff;
STICKLINE(varaQ,C,(O+C)/2,3,0),colorff99ff;
STICKLINE(varaQ,C,(O+C)/2,2,0),colorffbbff;
STICKLINE(varaQ,C,(O+C)/2,1,0),colorffddff;
varbQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
STICKLINE(varbQ,C,(O+C)/2,7,0),color333333;
STICKLINE(varbQ,C,(O+C)/2,6,0),color555555;
STICKLINE(varbQ,C,(O+C)/2,5,0),color777777;
STICKLINE(varbQ,C,(O+C)/2,4,0),color999999;
STICKLINE(varbQ,C,(O+C)/2,3,0),colorbbbbbb;
STICKLINE(varbQ,C,(O+C)/2,2,0),colordddddd;
STICKLINE(varbQ,C,(O+C)/2,1,0),color00ffff;
varcQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)=REF(C,1);
STICKLINE(varcQ,O,(O+C)/2,7,0),color003300;
STICKLINE(varcQ,O,(O+C)/2,6,0),color005500;
STICKLINE(varcQ,O,(O+C)/2,5,0),color007700;
STICKLINE(varcQ,O,(O+C)/2,4,0),color009900;
STICKLINE(varcQ,O,(O+C)/2,3,0),color00bb00;
STICKLINE(varcQ,O,(O+C)/2,2,0),color00dd00;
STICKLINE(varcQ,O,(O+C)/2,1,0),color00ff00;
vardQ:=REF(C,1)=HHV(C,4) AND CREF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
STICKLINE(vardQ,O,(O+C)/2,7,0),colorff1100;
STICKLINE(vardQ,O,(O+C)/2,6,0),colorff3300;
STICKLINE(vardQ,O,(O+C)/2,5,0),colorff5500;
STICKLINE(vardQ,O,(O+C)/2,4,0),colorff7700;
STICKLINE(vardQ,O,(O+C)/2,3,0),colorff9900;
STICKLINE(vardQ,O,(O+C)/2,2,0),colorffbb00;
STICKLINE(vardQ,O,(O+C)/2,1,0),colorffdd00;

 

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 同花顺 同花顺顺势操作副图源码 https://www.694.cn/ziliaoxiazai/tonghuashun/10089.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务