同花顺MAKD公式

2024-04-29 0 173

以下是同花顺MAKD公式

同花顺MAKD公式

该指标由民间高手精心编写而成,将传统的macd和KDJ两个指标融合成一个指标,当两指标同时发出买入或卖出信号,即指标曲线出现“金叉共振”为加强型买入信号,后势上涨概率较大。反之,两指标同时发出卖出信号为加强型卖出信号。

在原来的基础上,增加了MACD顶底背离和KDJ顶底背离,提供的结果仅供参考,不作为依据。

源码:

//macd

DIF:(EMA(CLOSE,12)-EMA(CLOSE,26))*100,colorwhite;

DEA:EMA(DIF,9),coloryellow,LINETHICK1;

MACD:(DIF-DEA)*2,COLORSTICK;

STICKLINE(MACD>0,0,MACD,2,0),colorred;

STICKLINE(MACD<0,0,MACD,2,0),colorgreen;

STICKLINE(MACD>REF(MACD,1) AND MACD<0 ,0,MACD,2,0),colorff00ff;

STICKLINE(MACD0,0,MACD,2,0),colorliblue;

上翘:IF(DIF>REF(DIF,1),DIF,DRAWNULL),colorred,LINETHICK1;

下拐:IF(DIF<REF(DIF,1),DIF,DRAWNULL),colorliblue,LINETHICK1;

//DRAWICON(CROSS(DIF,DEA),DIF,1);

//DRAWICON(CROSS(DEA,DIF),DEA,2);

DRAWICON(CROSS(DIF,DEA),DEA,\’buy\’);

DRAWICON(CROSS(DEA,DIF),DEA,\’sell\’);

//macd背离

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

STICKLINE(底背离,DEA*1.09,DEA*0.86,6,0),Culor00FF00;

DRAWLINE(A1=0,DEA,底背离,DEA,0),colorred,linethick1;

DRAWTEXT(底背离,DEA*1.09,\’ 底背离\’),colorwhite;

B1:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,B1+1)DIF AND CROSS(DEA,DIF);

DRAWLINE(B1=0,DEA,顶背离,DEA,0),colorgreen,linethick1;

DRAWTEXT(顶背离,DEA*1.2,\’ 顶背离\’),Culor00FF00;

//KDJ

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:SMA(RSV,9,3),colorwhite;

D:SMA(K,9,3),colorcyan;

J:3*K-2*D,colormagenta;

A2:=BARSLAST(REF(CROSS(K,D),1));

B2:=REF(C,A2+1)>C AND REF(K,A2+1)<K AND CROSS(K,D);

A3:=BARSLAST(REF(CROSS(D,K),1));

B3:=REF(C,A2+1)K AND CROSS(D,K);

A22:=IF(ABS(D)<ABS(0.6*DEA),0.6*D*ABS(DEA/D),0.95*D);

DRAWTEXT(B2,A22,\’KDJ底背\’),colorwhite;

DRAWTEXT(B3,A22,\’KDJ顶背\’),colorwhite;

DRAWICON(B2,D,\’buy\’);

DRAWICON(B3,D,\’sell\’);

B4:=CROSS(DIF,DEA) AND CROSS(K,D);

DRAWTEXT(B4,dea*1.2,\’★金叉共振\’),COLOR0099FF;

B5:=CROSS(DEA,DIF) AND CROSS(D,K);

DRAWTEXT(B5,DEA*1.2,\’★死叉共振\’),COLOR0099FF;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 同花顺 同花顺MAKD公式 https://www.694.cn/ziliaoxiazai/tonghuashun/5699.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务