通达信 OBV量柱 顶底背离指标

2024-04-14 0 547

指标说明:

副图指标,obv指标的基础上改的顶底背离。

指标例图:
通达信 OBV量柱 顶底背离指标

指标源码:

 

MOBV:=OBV-MA(OBV,30);
STICKLINE(MOBV>0,0,MOBV,1,0),COLORRED;
STICKLINE(MOBV<0,0,MOBV,1,0),COLORCYAN;
OBV高:=REF(OBV,BARSLAST(FILTER(BACKSET(FILTER(REF(OBV,5)=HHV(OBV,2*5+1),5),5+1),5)));
C高:=REF(C,BARSLAST(FILTER(BACKSET(FILTER(REF(C,5)=HHV(C,2*5+1),5),5+1),5))),NODRAW;
量入为主:CROSS(OBV,OBV高) AND H<C高,NODRAW;
STICKLINE(量入为主,0,MOBV,1,0),COLORYELLOW;
DRAWTEXT(量入为主,3*MOBV,’量’),COLORWHITE;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV30:MA(OBV,30);
OBV2:=OBV-OBV30;
STICKLINE(OBV2>0,OBV,OBV30,1,0),COLORRED;
STICKLINE(OBV2<0,OBV,OBV30,1,0),COLOR00FF00;
DRAWICON(CROSS(OBV,OBV30),OBV30,1);
DRAWICON(CROSS(OBV30,OBV),OBV30,2);
STICKLINE(OBV<REF(OBV,1),OBV30,OBV,1,0),COLORFFFF00;
STICKLINE(OBV>REF(OBV,1),OBV30,OBV,1,0),COLORFF00FF;
OBV创新高是牛股:PLOYLINE(1,CONST(OBV)),COLOR008888,LINETHICK1;
A1A:=BARSLAST(REF(CROSS(OBV,OBV30),1));
底背离:=REF(CLOSE,A1A+1)>CLOSE AND OBV>REF(OBV,A1A+1) AND CROSS(OBV,OBV30);
STICKLINE(底背离,0,OBV,3,0),COLOR00FF00;
底背:DRAWLINE(A1A=0,OBV30,底背离,OBV30,0),COLORYELLOW,LINETHICK4;
DRAWTEXT(底背离,OBV30,’ 底背离’),COLORWHITE;
STICKLINE(底背离,OBV,OBV创新高是牛股,3,0),COLORRED;
A2A1:=BARSLAST(REF(CROSS(OBV30,OBV),1));
顶背离:=REF(CLOSE,A2A1+1)<CLOSE AND REF(OBV,A2A1+1)>OBV AND CROSS(OBV30,OBV);
顶背:DRAWLINE(A2A1=0,OBV30,顶背离,OBV30,0),COLORBLUE,LINETHICK4;
DRAWTEXT(顶背离,OBV30,’ 顶背离’),COLORWHITE;
上榜资金:IF(FINANCE(3)==0,SCJYVALUE(16,1,0)-SCJYVALUE(16,2,0),GPJYVALUE(2,1,0)-GPJYVALUE(2,2,0)),NODRAW,COLORRED;
STICKLINE(上榜资金>0,0,588,2,0),COLORRED;
STICKLINE(上榜资金<0,0,588,2,0),COLORCYAN;
CJJ:=GPJYVALUE(5,1,0);
CJJ2:=IF(CJJ>0,CJJ,C);
减持:IF(FINANCE(3)==0,(SCJYVALUE(10,1,0)-SCJYVALUE(10,2,0)),(CJJ2*GPJYVALUE(5,2,0))/10000),NODRAW;
NOTEXT1:MA(减持,10)*2;
STICKLINE(减持>0,0,OBV,2,0),COLORRED;
STICKLINE(减持<0,0,OBV,2,0),COLORCYAN;
增持:IF(FINANCE(3)==0,SCJYVALUE(11,1,0)+SCJYVALUE(11,2,0),GPJYVALUE(4,2,0)),NODRAW;
溢额:IF(FINANCE(3)==0,SCJYVALUE(11,1,0),0);
STICKLINE(增持>0,MOBV,OBV,2,0),COLORBROWN;
STICKLINE(溢额>0,MOBV,0,2,0),COLORRED;
{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 通达信 通达信 OBV量柱 顶底背离指标 https://www.694.cn/ziliaoxiazai/tongdaxin/4241.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务