通达信 月开线主图 指标公式

2024-04-26 0 763

通达信 月开线主图 指标公式
Z1:=stRCAT(HYBLOCK,’ ‘);
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,’ ‘);
板块所属:DRAWTEXT_FIX(1,0,0.21,0,’板块所属:’),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0.055,0.21,0,STRCAT(Z3,GNBLOCK)),COLOR00CC99;
DRAWTEXT_FIX(1,0.00,0.00,0,’主题投资:’)COLORWHITE;
DRAWTEXT_FIX(1,0.054,0.00,0,EXTERNSTR(0,1))COLOR00CC99;
DRAWTEXT_FIX(1,0.00,0.08,0,’主营业务:’)COLORWHITE;
DRAWTEXT_FIX(1,0.055,0.08,0,EXTERNSTR(0,2))COLOR00CC99;
DRAWTEXT_FIX(1,0,0.15,0,’股票风格:’)COLORWHITE;
DRAWTEXT_FIX(1,0.055,0.15,0,FGBLOCK),COLOR00CC99;
DRAWTEXT_FIX(ISLASTBAR,0,1,0,STRCAT(”,ZDBLOCK)),COLORFFFF00;
DRAWTEXT_FIX(1,0.7,0.98,0,’核心题材:’)COLORWHITE;
DRAWTEXT_FIX(1,0.76,0.98,0,EXTERNSTR(0,3))COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1,L*0.995,EXTERNSTR(0,4)); { 涨停原因}
跟庄看盘:DRAWNULL,COLOR0088FF;
现价:REFDATE(C,DATE),DOTLINE,COLORLIGRAY;
STICKLINE((BArslAST(MONTH!=REF(MONTH,1) OR DATETODAY(DATE)=1))+1=1,H#MONTH,L#MONTH,0,-1),COLORGREEN;
月:REF(O,BARSLAST(MONTH!=REF(MONTH,1))),COLORRED,NODRAW;
STICKLINE(C>月,月,月,5,0),COLORRED;
STICKLINE(C<月,月,月,5,0),COLORFFFF00;
STICKLINE(C=月,月,月,5,0),COLORWHITE;
小月线:=ma(C,20);
月线:=MA(C,21);
DRAWBAND(月线,RGB(0,200,0),小月线,RGB(250,0,0));
mcst:DMA(AMOUNT/(100*V),V/CAPITAL),COLORFC9F99;
妖线:EMA(EMA(C,9)*1.11,5),COLORYELLOW,DOTLINE;
XA8:=crOSS(C,妖线) AND C>=REF(C,1)*1.048;
DRAWICON(XA8,L*0.99,13);
高:=REF(HHV(H,72),5);
龙门:REFDATE(高,DATE),COLORFFFFFF,LINETHICK2;
警示:=NAMEINCLUDE(‘S’);
跌停:DTPRICE(REF(C,1),IF(警示,0.05,0.1)),NODRAW,COLORGREEN;
涨停:ZTPRICE(REF(C,1),IF(警示,0.05,0.1)),NODRAW,COLORRED;
明涨停:IF(C<500,C*1.1,DRAWNULL),NODRAW,COLORFF00FF;
获利筹码:IF(WINNER(CLOSE),WINNER(CLOSE)*100,0),NODRAW;
W:=IF(NAMELIKE(‘W’) OR NAMELIKE(‘*W’),0.05,0.1);
DT:=(REF(C,1)/C-1>=W-0.01/REF(C,1) AND L=C AND PERIOD=5) OR C=DTPRICE(REF(C,1),IF(警示,0.05,0.1));
ZT:=C>=ZTPRICE(REF(C,1),IF(警示,0.05,0.099)),NODRAW,COLORRED;
ZT1:=H>=ZTPRICE(REF(C,1),IF(警示,0.05,0.099)) AND C<H;
DT1:=REF(C,1)/L-1>=W-0.01/REF(C,1) AND L<C AND PERIOD=5;
涨停距今天数:BARSLAST(ZT),NODRAW;
STICKLINE(ZT,CLOSE,(OPEN+CLOSE)/2,3,0),COLOR000099;
STICKLINE(ZT,CLOSE,(OPEN+CLOSE)/2,2.2,0),COLOR0000CC;
STICKLINE(ZT,CLOSE,(OPEN+CLOSE)/2,1.5,0),COLOR0000FF;
STICKLINE(ZT,CLOSE,(OPEN+CLOSE)/2,0.5,0),COLORCC66FF;
STICKLINE(ZT,OPEN,(OPEN+CLOSE)/2,3,0),COLOR999999;
STICKLINE(ZT,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;
STICKLINE(ZT,OPEN,(OPEN+CLOSE)/2,1.5,0),COLORDDDDDD;
STICKLINE(ZT,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFFF;
STICKLINE(DT,OPEN,(OPEN+CLOSE)/2,3,0),COLOR999999;
STICKLINE(DT,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;
STICKLINE(DT,OPEN,(OPEN+CLOSE)/2,1.5,0),COLORDDDDDD;
STICKLINE(DT,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFFF;
STICKLINE(DT,CLOSE,(OPEN+CLOSE)/2,3,0),COLOR009900;
STICKLINE(DT,CLOSE,(OPEN+CLOSE)/2,2.2,0),COLOR00BB00;
STICKLINE(DT,CLOSE,(OPEN+CLOSE)/2,1.5,0),COLOR00DD00;
STICKLINE(DT,CLOSE,(OPEN+CLOSE)/2,0.5,0),COLOR00FF00;
{曾涨跌停打开k线颜色设置}
STICKLINE(ZT1,CLOSE,(OPEN+CLOSE)/2,3,0),COLORFF00FF;
STICKLINE(ZT1,CLOSE,(OPEN+CLOSE)/2,2.2,0),COLORFF00FF;
STICKLINE(ZT1,CLOSE,(OPEN+CLOSE)/2,1.5,0),COLOR0000FF;
STICKLINE(ZT1,CLOSE,(OPEN+CLOSE)/2,0.5,0),COLORCC66FF;
STICKLINE(ZT1,OPEN,(OPEN+CLOSE)/2,3,0),COLOR999999;
STICKLINE(ZT1,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;
STICKLINE(ZT1,OPEN,(OPEN+CLOSE)/2,1.5,0),COLORDDDDDD;
STICKLINE(ZT1,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFFF;
STICKLINE(DT1,OPEN,(OPEN+CLOSE)/2-0.01,2.7,0),COLORGREEN;
STICKLINE(DT1,C,(OPEN+CLOSE)/2+0.01,2.7,0),COLORWHITE;
STICKLINE(DT,OPEN,(OPEN+CLOSE)/2-0.01,0.5,0),COLORFFFFFF;
假阴:=REF(C>=O,1) AND AMOUNT/V/100>REF(C,1) AND C<O;
假阳:=REF(C<=O,1) AND H<REF(O,1) AND C<(REF(O-C,1))/3+REF(C,1) AND AMOUNT/V/100<REF(C,1) AND C>O;
STICKLINE(假阴,O,C,0.2,0),COLORRED;{假阴柱};
STICKLINE(假阳,O,C,0.7,0),COLORLIGREEN;{假阳};
连阴:=COUNT((C<REF(C,1) OR L<REF(L,1)),10)>=5;
间谍柱:=REF(连阴,1) AND (DT OR DT1);
DRAWLINE(间谍柱,C,REF(间谍柱,1),REF(C,1),1),DOTLINE,COLOR09FFCF;
卧龙根价:DRAWLINE(间谍柱,(C+O)/2,REF(间谍柱,1),REF((C+O)/2,1),1),COLOR55FFCC;
收阴:=(C<REF(C,1) OR L<REF(L,1) OR AMOUNT/V/100<REF((C+O)/2,1)) AND O<=REF(C,1);
多阴:=EVERY(收阴,2);
小阳:=O-L<=0.03 AND H>C AND C>O AND O<REF(C,1) AND C<REF(MAX(C,O),1) AND V<REF(V,1);
宝莲灯:=REF(多阴,1) AND 小阳;
STICKLINE(宝莲灯,O,C,2.5,0),COLORCC22FF;
STICKLINE(宝莲灯,(O+C)/2-0.02,(O+C)/2+0.02,2,0),COLORWHITE;
SY:=H/MAX(C,O);
必跌形态:=EVERY((L>REF(L,1) OR H>REF(H,1)) AND SY>1.012,4);
DRAWTEXT(必跌形态,H*1.025,’卖’),COLORCCFF00;
首板:=ZT AND COUNT(ZT,2)=1;
二板:=REF(首板,1) AND ZT;
三板:=REF(二板,1) AND ZT;
四板:=REF(三板,1) AND ZT;
五板:=REF(四板,1) AND ZT;
六板:=REF(五板,1) AND ZT;
七板:=REF(六板,1) AND ZT;
八板:=REF(七板,1) AND ZT;
九板:=REF(八板,1) AND ZT;
十板:=REF(九板,1) AND ZT;
DRAWTEXT(首板,0.1+(C+O)/2,’1′),COLORWHITE;
DRAWTEXT(二板,0.1+(C+O)/2,’2′),COLORYELLOW;
DRAWTEXT(三板,0.1+(C+O)/2,’3′),COLOR00CC99;
DRAWTEXT(四板,0.1+(C+O)/2,’4′),COLORGREEN;
DRAWTEXT(五板,0.1+(C+O)/2,’5′),COLORLIGRAY;
DRAWTEXT(六板,0.1+(C+O)/2,’6′),COLORLIRED;
DRAWTEXT(七板,0.1+(C+O)/2,’7′),COLORLIBLUE;
DRAWTEXT(八板,0.1+(C+O)/2,’8′),COLORBLUE;
DRAWTEXT(九板,0.1+(C+O)/2,’9′),COLORWHITE;
DRAWTEXT(十板,0.1+(C+O)/2,’10’),COLORYELLOW;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 通达信 通达信 月开线主图 指标公式 https://www.694.cn/ziliaoxiazai/tongdaxin/5417.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务