通达信 趋势大道主图源码

2024-04-28 0 371

通达信 趋势大道主图源码

DE:=CONST(LLV(L,90));
JI:=CONST(HHV(H,90))-DE;
DE_K:=DE+JI/3*2;
JI_K:=JI/2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
DE_A:=CONST(LLV(RSV,90));
DD_A:=CONST(HHV(RSV,90))-DE_A;
R:=(RSV-DE_A)/DD_A;
RSV1:=R*JI_K+DE_K;
DE_M:=DE+JI/3;
JI_M:=JI/2;
KDL:=CONST(LLV(EMA(C,26),90));
KDH:=CONST(HHV(EMA(C,26),90))-KDL;
R_K1:=(EMA(C,12)-KDL)/KDH;
R_K2:=(EMA(C,26)-KDL)/KDH;
DIF~:(R_K1-R_K2)*JI*1.5+DE_M,NODRAW;
DEA~:EMA(DIF~,9),NODRAW;
MACD~:=(DIF~-DEA~)*2+DE_M;
STICKLINE(MACD~>=DE_M,MACD~,DE_M,1,0),COLOR2F2F4F;
D_1:=MACD~>H AND H>=DE_M AND DE_M>=L;
D_2:=MACD~>H AND H>=L AND L>DE_M;
D_3:=H>MACD~ AND MACD~>=L AND L>DE_M;
D_4:=H>MACD~ AND MACD~>DE_M AND DE_M>=L;
STICKLINE(D_1>0,H,DE_M,1,0),COLOR2F2F4F;
STICKLINE(D_2,H,L,1,0),COLOR2F2F4F;
STICKLINE(D_3,MACD~,L,1,0),COLOR2F2F4F;
STICKLINE(D_4,MACD~,DE_M,1,0),COLOR2F2F4F;
D_5:=MACD~<L AND L<=DE_M AND DE_M<=H;
D_6:=MACD~<L AND H<DE_M;
D_7:=L<MACD~ AND MACD~<=H AND H<DE_M;
D_8:=L<MACD~ AND MACD~<DE_M AND DE_M<=H;
STICKLINE(MACD~<DE_M,DE_M,MACD~,1,0),COLOR2F2F4F;
STICKLINE(D_5,DE_M,L,1,0),COLOR2F2F4F;
STICKLINE(D_6,H,L,1,0),COLOR2F2F4F;
STICKLINE(D_7,H,MACD~,1,0),COLOR2F2F4F;
STICKLINE(D_8,DE_M,MACD~,1,0),COLOR2F2F4F;
HAN:=DATE<1141230;
当前获利筹码:=IF(WINNER(CLOSE),WINNER(CLOSE)*100,0);
DRAWKLINE(H,O,L,C);
九十成本集中:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
成本价:COST(九十成本集中),LINETHICK2,POINTDOT,COLORFFFFFF;
入1:IF(成本价>REF(成本价,1),成本价,DRAWNULL),COLORFF00FF,POINTDOT,LINETHICK4;
出1:IF(成本价<REF(成本价,1),成本价,DRAWNULL),COLORFFFF00,POINTDOT,LINETHICK4;
STICKLINE(C>=O,H,L,0,0),COLOREAADEA;
STICKLINE(C>=O,C,O,3,0),COLOREAADEA;
STICKLINE(C<O,H,L,0,0),COLORFF0000;
STICKLINE(C<O,C,O,3,0),COLORFF0000;
STICKLINE(C>O,C,O,2.0,0),COLOR8C8C00;
STICKLINE(C>O,C,O,1.8,0),COLOR959500;
STICKLINE(C>O,C,O,1.6,0),COLOR9F9F00;
STICKLINE(C>O,C,O,1.3,0),COLORAAAA00;
STICKLINE(C>O,C,O,1.0,0),COLORB5B500;
STICKLINE(C>O,C,O,0.6,0),COLORBFBF00;
STICKLINE(C>O,C,O,0.3,0),COLORD0D000;
STICKLINE(C=O,C,O,0.1,0),COLOR8C8C00;
STICKLINE(C<O,C,O,2.0,0),COLOR8C8C00;
STICKLINE(C<O,C,O,1.8,0),COLOR959500;
STICKLINE(C<O,C,O,1.5,0),COLOR9F9F00;
STICKLINE(C<O,C,O,1.3,0),COLORAAAA00;
STICKLINE(C<O,C,O,1.0,0),COLORB5B500;
STICKLINE(C<O,C,O,0.6,0),COLORBFBF00;
STICKLINE(C<O,C,O,0.3,0),COLORD0D000;
STICKLINE(C=O,C,O,0.1,0),COLOR8C8C00;
均线7:MA(C,7),NODRAW;
均线13:MA(C,13),NODRAW;
STICKLINE((C>均线13),O,C,2,0),COLOR1313FF;
STICKLINE((C>均线13),O,C,1.6,0),COLOR2424FF;
STICKLINE((C>均线13),O,C,1.2,0),COLOR2D2DFF;
STICKLINE((C>均线13),O,C,0.8,0),COLOR4444FF;
STICKLINE((C>均线13),O,C,0.5,0),COLOR5757FF;
STICKLINE((C>均线13),O,C,0.3,0),COLOR6666FF;
STICKLINE((C>均线13),O,C,0.1,0),COLOR7D7DFF;
STICKLINE((C>均线7),O,C,0.3,0),COLOREBC79E;
B1:=EMA(C,3);
B2:=EMA(C,13);
B3:=B1-B2;
WDIF:EMA(EMA(EMA(C,3),3),3)+B3,COLORFFFFFF;
WDEA:EMA(WDIF,3),COLORFFF000;
重心:(2*C+H+L)/4,COLOR00FFFF,LINETHICK0;
SJ:=WMA((重心-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);
DRAWTEXT(CROSS(SJ,ZJ) AND SJ<30,L-0.1,’←低吸’),COLOR00FF00;
DRAWTEXT(CROSS(ZJ,SJ) AND SJ>70,H+0.1,’←高抛’),COLOR0077FF;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 通达信 通达信 趋势大道主图源码 https://www.694.cn/ziliaoxiazai/tongdaxin/5618.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务