通达信 双紫擒龙 主图 指标

2024-03-25 0 726

通达信 双紫擒龙 主图 指标

VAR1:=EMA(EMA(CLOSE,9),9);

控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

STICKLINE(控盘<0,控盘,0,4,0),COLORWHITE;

A10:=CROSS(控盘,0);

无庄控盘:IF(控盘<0,控盘,0),COLORWHITE,NODRAW;

开始控盘:IF(A10,25,0),LINETHICK1,COLORYELLOW;

STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,4,0),COLORRED;

有庄控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;

VAR2:=100*WINNER(CLOSE*0.95);

STICKLINE(VAR2>50 AND C=HHV(C,10)  AND 控盘>0,控盘,0,4,0),COLORFF00FF;

高度控盘:IF(VAR2>50 AND C=HHV(C,10)  AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;

STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,4,0),COLOR00FF00;

主力出货:IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;

VAR3:=((C-MA(C,6))/(MA(C,6)))*(100);

VAR4:=((C-MA(C,12))/(MA(C,12)))*(100);

VAR5:=((C-MA(C,24))/(MA(C,24)))*(100);

VAR6:=(VAR3+(2)*(VAR4)+(3)*(VAR5))/6;

VAR7:=MA(VAR6,3);

挖坑捡机会:EVERY(VAR7<=(-10),7) AND DYNAINFO(4)>0 AND C>1*REF(C,1);

STICKLINE(挖坑捡机会,40,25,1,0),COLORYELLOW;

STICKLINE(挖坑捡机会,25,10,2,0),COLOR00FF00;

STICKLINE(挖坑捡机会,10,0,2,0),COLORBLUE;

STICKLINE(挖坑捡机会,25,15,0.5,0),COLORRED;

STICKLINE(挖坑捡机会,15,6,1,0),COLOR00FF00;

STICKLINE(挖坑捡机会,6,0,2,0),COLORBLUE;

DRAWTEXT(FILTER(挖坑捡机会=1,5),36,’—挖坑捡机会’),COLORYELLOW;

DCV1:=(C-REF(C,1))/REF(C,1)*100;

DCV2:=BARSLASTCOUNT(C<REF(C,1)),NODRAW;

DCV3:=C<REF(C,1),NODRAW;

DCV4:=DCV3*DCV1,NODRAW;

DCV5B:=SUM(DCV4,DCV2) ,NODRAW;

KK:=C/REF(C,1)>1.099  AND H>L  AND H=C;

BMM:=BARSLAST(KK),NODRAW;

A:=DCV2>=3 AND DCV5B<-10;

QA:=C>REF(C,1) AND C>O AND REF(A=1,1) AND BMM<=15;

STICKLINE(QA,0,2,2.5,1),COLORYELLOW;

STICKLINE(QA,40,50,2.5,1),COLORYELLOW;

STICKLINE(QA,0,50,1,1),COLORMAGENTA;

DRAWTEXT(QA,45,’  一线攻击’),COLORYELLOW;

DRAWICON(QA,52,1);

DRAWTEXT(QA=1 AND DCV1>=5,35,’  大阳攻击’),COLORMAGENTA;

DRAWTEXT(QA=1 AND DCV1<5,25,’  小阳攻击’),COLORRED;

AU:= DCV2>=4 AND DCV5B<-15;

QAU:=C>REF(C,1) AND C>O AND REF(AU=1,1) AND BMM<=8 ;

DRAWTEXT(QAU,20.15,’  强信号’),COLORYELLOW;

AA7:=C-REF(C,1);

AA8:=100*EMA(EMA(AA7,6),6)/EMA(EMA(ABS(AA7),6),6);

AA9:=LLV(AA8,2)=LLV(AA8,7) AND COUNT(AA8<0,2) AND CROSS(AA8,MA(AA8,2));

VARP2:=((((2*CLOSE)+HIGH)+LOW)/4);

VARP4:=LLV(LOW,5);

VARP5:=HHV(HIGH,4);

C1:=(EMA((((VARP2-VARP4)/(VARP5-VARP4))*100),4));

C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2));

C3:=CROSS(C1,C2) AND REF(C1,1)<25;

C4:=AA9 OR C3;

C5:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);

C6:=EMA(C5,3);

C7:=C6>REF(C6,1);

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

B1:=C>O;

AB:CROSS(J,3.8) AND HHV(H,11)/REF(C,1)>1.11 AND REF(V,1)<REF(V,2) AND C4 AND C7 AND B1;

STICKLINE(IF(AB,120,0),46,20,1,0),COLORYELLOW;

STICKLINE(IF(AB,120,0),20,0,1,0),COLORRED;

DRAWTEXT(AB,40,’一’),COLORRED;

DRAWTEXT(AB,30,’触’),COLORRED;

DRAWICON(AB,52,1);

DRAWTEXT(AB,20,’即’),COLORYELLOW;

DRAWTEXT(AB,12,’发’),COLORYELLOW;

X_1:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)=REF(HIGH,3);

X_2:=CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,3),1.1,0.91) AND LOW<REF(CLOSE,3) AND REF(CLOSE,1)/REF(CLOSE,2)<0.96 AND REF(CLOSE,1)<REF(OPEN,1) AND NOT(REF(HIGH,2)/REF(CLOSE,3)>1.05 AND REF(HIGH,2)/MAX(REF(CLOSE,2),REF(OPEN,2))>1.05) AND NOT(REF(CLOSE,2)<REF(OPEN,2) AND REF(OPEN,2)/REF(CLOSE,2)>1.05 AND REF(OPEN,2)/REF(CLOSE,3)>1.05);

X_3:=X_1 AND X_2;

X_4:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)=REF(HIGH,4);

X_5:=CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,4),1.1,0.91) AND LOW<REF(CLOSE,4) AND REF(CLOSE,1)/REF(CLOSE,2)<0.96 AND REF(CLOSE,1)<REF(OPEN,1) AND NOT(REF(HIGH,3)/REF(CLOSE,4)>1.07 AND REF(HIGH,3)/MAX(REF(CLOSE,3),REF(OPEN,3))>1.07) AND NOT(REF(CLOSE,3)<REF(OPEN,3) AND REF(OPEN,3)/REF(CLOSE,3)>1.03 AND REF(CLOSE,2)<REF(OPEN,2) AND REF(OPEN,2)/REF(CLOSE,2)>1.04);

X_6:=X_4 AND X_5;

X_7:=REF(CLOSE,5)/REF(CLOSE,6)>1.09 AND REF(CLOSE,5)=REF(HIGH,5);

X_8:=CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,5),1.1,0.91) AND LOW<REF(CLOSE,5) AND REF(CLOSE,1)/REF(CLOSE,2)<0.96 AND REF(CLOSE,1)<REF(OPEN,1) AND NOT(REF(HIGH,4)/REF(CLOSE,5)>1.05 AND REF(HIGH,4)/MAX(REF(CLOSE,4),REF(OPEN,4))>1.07);

X_9:=X_7 AND X_8;

X_10:=REF(CLOSE,6)/REF(CLOSE,7)>1.09 AND REF(CLOSE,6)=REF(HIGH,6);

X_11:=CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,6),1.1,0.91) AND LOW<REF(CLOSE,6) AND REF(CLOSE,1)/REF(CLOSE,2)<0.96 AND REF(CLOSE,1)<REF(OPEN,1) AND NOT(REF(HIGH,5)/REF(CLOSE,6)>1.05 AND REF(HIGH,5)/MAX(REF(CLOSE,5),REF(OPEN,5))>1.05);

X_12:=X_10 AND X_11;

X_13:=X_3 OR X_6 OR X_9 OR X_12;

X_14:=REF(CLOSE,2)/REF(CLOSE,3)<1.09;

X_15:=NOT(REF(CLOSE,2)<REF(OPEN,2) AND REF(OPEN,2)/REF(CLOSE,2)>1.03 AND REF(OPEN,2)=REF(HIGH,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(OPEN,1)/REF(CLOSE,1)>1.025);

X_16:=NOT(REF(CLOSE,4)/REF(CLOSE,5)>1.095 AND REF(HIGH,3)>REF(HIGH,4) AND REF(OPEN,3)/REF(CLOSE,3)>1.08 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,3)<REF(OPEN,4));

X_17:=NOT(REF(CLOSE,1)/REF(CLOSE,2)<0.91 AND REF(OPEN,1)<REF(MA(CLOSE,10),1) AND REF(LOW,1)=REF(CLOSE,1) AND REF(CLOSE,2)/REF(CLOSE,3)<0.95 AND OPEN<MA(CLOSE,10));

X_18:=NOT(REF(CLOSE,3)/REF(CLOSE,4)>1.095 AND REF(OPEN,2)>REF(CLOSE,3) AND REF(CLOSE,2)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(OPEN,2)/REF(CLOSE,2)>1.02);

X_19:=NOT(CROSS(REF(MA(CLOSE,10),1),REF(MA(CLOSE,5),1)) AND REF(OPEN,1)<REF(MA(CLOSE,10),1) AND OPEN<MA(CLOSE,10) AND REF(MA(CLOSE,10),1)/REF(MA(CLOSE,20),1)>1.07);

X_20:=NOT(REF(CLOSE,3)/REF(CLOSE,4)>1.095 AND REF(CLOSE,4)/REF(CLOSE,5)<1.09 AND REF(LOW,3)>REF(HIGH,4) AND REF(LOW,2)>REF(HIGH,4) AND REF(LOW,1)>REF(HIGH,4) AND OPEN>REF(CLOSE,4));

X_21:=NOT(MA(CLOSE,60)>MA(CLOSE,30) AND MA(CLOSE,30)>MA(CLOSE,20) AND MA(CLOSE,20)>MA(CLOSE,10) AND OPEN<MA(CLOSE,10) AND REF(CLOSE,5)/REF(CLOSE,6)>1.095 AND REF(HIGH,2)/REF(CLOSE,3)>1.03);

X_22:=X_13 AND X_14 AND X_15 AND X_16 AND X_17 AND X_18 AND X_19 AND X_20 AND X_21;

X_23:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)=REF(HIGH,4);

X_24:=CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,4),1.02,0.98) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,3)<REF(OPEN,3) AND REF(OPEN,2)>REF(OPEN,1) AND REF(OPEN,3)>REF(OPEN,2) AND REF(OPEN,3)/REF(CLOSE,4)<1.01 AND NOT(REF(HIGH,3)/REF(CLOSE,4)>1.07 AND REF(HIGH,3)/MAX(REF(CLOSE,3),REF(OPEN,3))>1.07) AND NOT(REF(CLOSE,3)<REF(OPEN,3) AND REF(OPEN,3)/REF(CLOSE,3)>1.03 AND REF(CLOSE,2)<REF(OPEN,2) AND REF(OPEN,2)/REF(CLOSE,2)>1.04) AND CLOSE>OPEN;

X_25:=X_23 AND X_24;

X_26:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)=REF(HIGH,3);

X_27:=CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,3),1.05,0.93) AND LOW<REF(CLOSE,3) AND REF(CLOSE,1)/REF(CLOSE,2)<0.965 AND REF(CLOSE,1)<REF(OPEN,1) AND NOT(REF(HIGH,2)/REF(CLOSE,3)>1.07) AND REF(MA(CLOSE,5),1)>REF(MA(CLOSE,10),1);

X_28:=X_26 AND X_27;

X_29:=X_28;

X_30:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)=REF(HIGH,4);

X_31:=CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,4),1.05,0.93) AND LOW<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,2) AND REF(CLOSE,2)<REF(CLOSE,3) AND REF(OPEN,3)<REF(CLOSE,4) AND REF(MA(CLOSE,5),1)>REF(MA(CLOSE,10),1) AND REF(CLOSE,1)/REF(CLOSE,2)<1.01;

X_32:=X_30 AND X_31;

X_33:=REF(CLOSE,11)/REF(CLOSE,12)>1.095 AND REF(HIGH,11)=REF(CLOSE,11) AND BETWEEN(REF(CLOSE,1)/REF(CLOSE,2),1.01,0.99) AND COUNT(EVERY(REF(MA(CLOSE,5),1)>REF(MA(CLOSE,10),1),6),10) AND OPEN<MA(CLOSE,10) AND REF(CLOSE,1)<REF(CLOSE,11) AND OPEN<REF(CLOSE,11) AND REF(OPEN,11)<REF(MA(CLOSE,60),11) AND OPEN<MA(CLOSE,60) AND CLOSE/REF(CLOSE,1)>1.03;

X_34:=REF(CLOSE,28)/REF(CLOSE,29)>1.095 AND REF(CLOSE,28)=REF(HIGH,28) AND BETWEEN(OPEN/REF(OPEN,28),1.01,0.98) AND OPEN<MA(CLOSE,5) AND OPEN<MA(CLOSE,10) AND OPEN<MA(CLOSE,20) AND OPEN<MA(CLOSE,30) AND CLOSE>MA(CLOSE,5) AND CLOSE/REF(CLOSE,1)>1.031;

X_35:=REF(CLOSE,9)/REF(CLOSE,10)>1.095 AND BETWEEN(OPEN/REF(OPEN,9),1.01,0.99) AND BETWEEN(REF(CLOSE,1)/REF(CLOSE,2),1.01,0.99) AND BETWEEN(REF(CLOSE,2)/REF(CLOSE,3),1.01,0.99) AND EVERY(MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,20)>MA(CLOSE,30),10) AND OPEN<MA(CLOSE,5) AND OPEN<MA(CLOSE,10);

X_36:=REF(CLOSE,9)/REF(CLOSE,10)>1.095 AND REF(HIGH,9)=REF(CLOSE,9) AND REF(0,9)/CLOSE<1.02 AND REF(CLOSE,2)/REF(CLOSE,3)<0.95 AND BETWEEN(REF(CLOSE,1)/REF(CLOSE,2),1.03,1.01) AND EVERY(MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,20)>MA(CLOSE,30),4) AND CLOSE>MA(CLOSE,10) AND CLOSE/REF(CLOSE,1)>1.031;

X_37:=REF(CLOSE,6)/REF(CLOSE,7)>1.095 AND REF(HIGH,6)=REF(CLOSE,6) AND REF(OPEN,1)>REF(MA(CLOSE,5),1) AND REF(CLOSE,1)<REF(MA(CLOSE,10),1) AND REF(CLOSE,1)/REF(CLOSE,2)<0.96 AND OPEN<MA(CLOSE,10) AND CLOSE/REF(CLOSE,1)>1.031;

X_38:=X_32 OR X_33 OR X_34 OR X_35 OR X_36 OR X_37;

X_39:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)=REF(HIGH,4);

X_40:=CLOSE/REF(CLOSE,1)>=1.031 AND REF(CLOSE,1)<REF(CLOSE,4) AND BETWEEN(REF(CLOSE,1)/REF(CLOSE,2),1.015,0.985) AND OPEN<REF(CLOSE,4) AND OPEN<MA(CLOSE,5) AND EVERY(REF(MA(CLOSE,5),1)>REF(MA(CLOSE,10),1),2);

X_41:=REF(HIGH,1)>REF(CLOSE,1);

X_42:=X_39 AND X_40 AND X_41;

X_43:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)=REF(HIGH,3);

X_44:=CLOSE/REF(CLOSE,1)>=1.031 AND REF(CLOSE,1)<REF(CLOSE,3) AND (REF(CLOSE,1)/REF(CLOSE,2)<0.96 AND REF(CLOSE,1)<REF(OPEN,1) AND REF(OPEN,1)/REF(CLOSE,1)<1.01) AND OPEN<REF(CLOSE,3) AND OPEN<MA(CLOSE,5) AND EVERY(REF(MA(CLOSE,5),1)>REF(MA(CLOSE,10),1),2);

X_45:=REF(HIGH,1)>REF(CLOSE,1);

X_46:=X_43 AND X_44 AND X_45;

X_47:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)=REF(HIGH,3);

X_48:=CLOSE/REF(CLOSE,1)>=1.031 AND REF(CLOSE,1)<REF(CLOSE,3) AND (REF(CLOSE,1)<REF(OPEN,1) AND REF(OPEN,1)/REF(CLOSE,1)<1.01) AND OPEN<REF(CLOSE,3) AND OPEN<MA(CLOSE,5) AND EVERY(REF(MA(CLOSE,5),1)>REF(MA(CLOSE,10),1),3);

X_49:=REF(HIGH,1)>REF(CLOSE,1);

X_50:=X_47 AND X_48 AND X_49;

X_51:=NOT(REF(CLOSE,4)/REF(CLOSE,5)>1.095 AND REF(CLOSE,3)/REF(CLOSE,4)<0.92 AND REF(OPEN,3)>REF(CLOSE,4) AND REF(CLOSE,3)<REF(OPEN,4));

X_52:=X_42 OR X_46 OR X_50 AND X_51;

X_53:=NOT(REF(CLOSE,6)/REF(CLOSE,7)>1.06 AND REF(CLOSE,5)/REF(CLOSE,6)<1.095 AND REF(LOW,4)>REF(HIGH,5) AND REF(HIGH,3)/REF(OPEN,3)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND OPEN>REF(HIGH,1) AND OPEN/REF(CLOSE,1)>1.01 AND REF(HIGH,3)/REF(CLOSE,4)>1.03);

X_54:=IF(NAMELIKE(1),0,1) AND IF(NAMELIKE(2),0,1);

X_55:=DYNAINFO(4)>0;

X_56:=X_54 AND X_55;

擒龙捉妖:X_22 OR X_25 OR X_29 OR X_38 OR X_52 AND X_53 AND X_56,COLORYELLOW,LINETHICK2;

STICKLINE(擒龙捉妖,0,25.5,1,0),COLORLIBLUE;

STICKLINE(擒龙捉妖,25,45.5,1,0),COLORWHITE;

DRAWTEXT(擒龙捉妖,35.5,’ 擒龙捉妖’),COLORWHITE;

RA:=MAX(O,C);{RA}

RB:=MIN(O,C);{RB}

RC:=REF(L,1);

RD:=IF(RA>REF(H,1),IF(RB<=RC,0,1),IF(RB<=RC,-1,0));

RE:=BARSLAST(RD=-1);

RF:=REF(H,RE);

RGG:=BARSLAST(RD=1);

RH:=REF(L,RGG);

T1:=IF(RD=1,IF(L>RF,1,0),IF(RD=-1,IF(H<RH,-1,0),0));

T2:=BARSLAST(T1=0);

TH:=REF(REF(H,BARSLAST(T1=1)),T2);

TL:=REF(REF(L,BARSLAST(T1=-1)),T2);

TA:=IF(T1=1,IF(RA>TH,1,0),IF(T1=-1,IF(RB<TL,-1,0),0));

{只在特定走势内显示}

X:=CURRBARSCOUNT;

P1:=BARSLAST(TA=-1);

P2:=BARSSINCEN(CROSS(0.5,TA),P1)+1;

{临界水平线}

P3:=BARSLAST(CROSS(COUNT(CROSS(-0.5,RD),P1),0.5));

PAH:=REF(HHV(RA,P1),P3);

NOTEXT1:=IF(X<CONST(P3)+1,PAH,DRAWNULL),DOTLINE,COLOR197800,LINETHICK2;{虚线}

NOTEXT2:=IF(X<CONST(P2)+1,PAH,DRAWNULL),COLOR197800,LINETHICK2;{虚线};

XG:=CROSS(C,NOTEXT1) OR CROSS(C,NOTEXT2);

X_01:=(3*CLOSE+LOW+OPEN+HIGH)/6;

X_02:=(20*X_01+19*REF(X_01,1)+18*REF(X_01,2)+17*REF(X_01,3)+16*REF(X_01,4)+15*REF(X_01,5)+14*REF(X_01,6)+13*REF(X_01,7)+12*REF(X_01,8)+11*REF(X_01,9)+10*REF(X_01,10)+9*REF(X_01,11)+8*REF(X_01,12)+7*REF(X_01,13)+6*REF(X_01,14)+5*REF(X_01,15)+4*REF(X_01,16)+3*REF(X_01,17)+2*REF(X_01,18)+REF(X_01,20))/210;

X_03:=EMA(X_02,13);

X_04:=REF(CLOSE,1)<REF(X_03,1) AND CLOSE>X_03;

X_05:=CLOSE/REF(CLOSE,1)>1.048;

踏歌行:=XG AND X_04 AND X_05;

STICKLINE(踏歌行,0,28,1.5,0),COLORYELLOW;

DRAWICON(踏歌行,31,34);

STICKLINE(踏歌行,0,35,0.3,0),COLORRED;

DRAWTEXT(踏歌行,22.5,’ 踏歌行’),COLORRED;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 通达信 通达信 双紫擒龙 主图 指标 https://www.694.cn/ziliaoxiazai/tongdaxin/3345.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务