通达信 掘金红筹 公式底部连续涨停捉妖抄底指标 黑马启动源码

2024-03-26 0 253

指标使用说明:

标准启动:股票启动连续涨停的第一日,发出‘标准启动信号
强力启动:标准信号发出信号偏多,强力启动会进行筛选和屏蔽
超级启动:标准启动信号多,强力启动信号少,超级启动信号数量适中
特级启动:属于特殊而珍贵的启动信号
顶底通道:解密股票涨跌的秘密,所有股票都在顶底通道上下轨中运行,当股价运行至下轨必然会向上运行,反之亦然。
超级底线:孕育底部连续涨停
底部标准启动:最经典的底部连续涨停启动信号
底部超级启动:最稳健的底部连续涨停启动信号
底部反转信号:最霸气的底部连续涨停启动信号

说明:盘中利用预警的指标(信号监控1,信号监控2做监控观察,封板预警指标做预警打板买入)可以及时发现符合信号的股票,然后再结合以下副图指标决定。
通达信 掘金红筹 公式底部连续涨停捉妖抄底指标 黑马启动源码
超级通道主图 与上次重复

 

STICKLINE(CLOSE>REF(CLOSE,1),HIGH,LOW,0,1),COLORRED;

STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,3.1,0),COLOR000055;

STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,2.7,0),COLOR000088;

STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,2.1,0),COLOR0000AA;

STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLOR0000CC;

STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLORRED;

STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLOR0000EE;

STICKLINE(CLOSE<REF(CLOSE,1),HIGH,LOW,0,1),COLOR666600;

STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,3.1,0),COLOR555500;

STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,2.7,0),COLOR888800;

STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,2.1,0),COLORAAAA00;

STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLORBBBB00;

STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLORCCCC00;

STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLOREEEE00;

STICKLINE(CLOSE=REF(CLOSE,1),HIGH,LOW,0,1),COLORWHITE;

STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,3.1,0),COLOR555555;

STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,2.7,0),COLOR777777;

STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,2.1,0),COLOR999999;

STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLORBBBBBB;

STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLORDDDDDD;

STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLORWHITE;

X_1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.058 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)<0.095;

X_2:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.098;

STICKLINE(X_1,OPEN,CLOSE,0,1),COLOR9B37FF;

STICKLINE(X_1,OPEN,CLOSE,3,0),COLOR6300C6;

STICKLINE(X_1,OPEN,CLOSE,2.7,0),COLOR6D00DB;

STICKLINE(X_1,OPEN,CLOSE,2.1,0),COLOR7800F0;

STICKLINE(X_1,OPEN,CLOSE,1.5,0),COLORLIMAGENTA;

STICKLINE(X_1,OPEN,CLOSE,0.9,0),COLOR8F20FF;

STICKLINE(X_1,OPEN,CLOSE,0.3,0),COLOR9B37FF;

STICKLINE(X_2,CLOSE,OPEN,3,0),COLOR00AAFF;

STICKLINE(X_2,CLOSE,OPEN,2.1,0),COLOR00BBFF;

STICKLINE(X_2,CLOSE,OPEN,1.5,0),COLOR00CCFF;

STICKLINE(X_2,CLOSE,OPEN,1,0),COLOR00DDFF;

STICKLINE(X_2,CLOSE,OPEN,0.6,0),COLOR00EEFF;

STICKLINE(X_2,CLOSE,OPEN,0.2,0),COLORYELLOW;

X_3:=MA(CLOSE,20);

标准上轨:X_3+2*STD(CLOSE,20),DOTLINE,COLORYELLOW;

标准下轨:X_3-2*STD(CLOSE,20),DOTLINE,COLORRED;

X_4:=MA(CLOSE,120);

X_5:=MA(CLOSE,250);

X_6:=MA(CLOSE,20*5);

超级上轨:X_6+2*STD(CLOSE,20*5),COLORYELLOW,LINETHICK2;

超级下轨:X_6-2*STD(CLOSE,20*5),COLORRED,LINETHICK2;

 

超级底部买点副图

参数1: X, 最小: 15, 最大: 40, 缺省: 30

参数2: Y, 最小: 12, 最大: 37, 缺省: 27

参数3: Z, 最小: 20, 最大: 52, 缺省: 42

 

X_1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100<9;

X_2:=REF(CLOSE,1);

X_3:=SMA(MAX(CLOSE-X_2,0),6,1)/SMA(ABS(CLOSE-X_2),6,1)*100;

X_4:=CROSS(X_3,25) AND X_1;

X_5:=EMA((CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2)*5;

X_6:=EMA((CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7)*5;

X_7:=CROSS(X_5,X_6) AND X_5<(-10) AND X_1;

X_8:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,48)*100+X;

X_9:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+Y;

X_10:=X_8 AND X_9;

X_11:=X_8 AND X_9 AND COUNT(X_10,2)=1 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(OPEN,1)>REF(CLOSE,1) OR REF(OPEN,1)<REF(CLOSE,1)) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5));

X_12:=DMA(EMA(CLOSE,8),SUM(VOL,9)/2.8/CAPITAL);

X_13:=(CLOSE-X_12)/X_12*100;

X_14:=REF(X_13,1)+Z<0 AND X_13>REF(X_13,1) AND REF(X_13,1)<REF(X_13,2) AND X_13-REF(X_13,1)>1.8 AND HIGH>LOW AND REF(HIGH,1)>REF(LOW,1) AND REF(HIGH,2)>REF(LOW,2) AND REF(HIGH,3)>REF(LOW,3) AND REF(HIGH,4)>REF(LOW,4) AND REF(HIGH,5)>REF(LOW,5);

X_15:=X_8;

X_16:=X_9;

X_17:=X_13+Z;

X_18:=IF(X_11 OR X_14,40,0);

X_19:=X_15<0 OR X_16<0 OR X_17<0;

X_20:=MA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);

X_21:=(-100)*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));

X_22:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);

X_23:=X_20+100;

X_24:=X_21+100;

X_25:=X_22+100;

X_26:=X_23<12 AND X_25<8 AND (X_24<7.2 OR REF(X_24,1)<5) AND (X_25>REF(X_25,1) OR X_24>REF(X_24,1)) OR (X_23<8 AND X_25<7 AND X_24<15 AND X_24>REF(X_24,1)) OR (X_23<10 AND X_25<7 AND X_24<1);

X_27:=X_23<15 AND REF(X_23,1)<15 AND X_25<18 AND X_24>REF(X_24,1) AND CROSS(X_24,X_23) AND X_24>X_25 AND (REF(X_24,1)<5 OR REF(X_24,2)<5) AND (X_25>=X_23 OR REF(X_24,1)<1);

X_28:=REF(CLOSE,1);

X_29:=SMA(MAX(CLOSE-X_28,0),6,1)/SMA(ABS(CLOSE-X_28),6,1)*100;

X_30:=CROSS(X_29,25);

X_31:=X_26 AND X_30;

X_32:=X_27 AND X_30;

X_33:=X_31 OR X_32;

X_34:=X_4 AND X_7 AND X_19 AND X_33;

STICKLINE(X_34>0,0,X_34,4,0),COLORRED;

STICKLINE(X_34>0,0,X_34,4,0),COLOR000088;

STICKLINE(X_34>0,0,X_34,3.8,0),COLOR000099;

STICKLINE(X_34>0,0,X_34,3.6,0),COLOR0000AA;

STICKLINE(X_34>0,0,X_34,3.4,0),COLOR0000BB;

STICKLINE(X_34>0,0,X_34,3,2),COLOR0000CC;

STICKLINE(X_34>0,0,X_34,3,0),COLOR0000DD;

STICKLINE(X_34>0,0,X_34,2.7,0),COLOR0000EE;

STICKLINE(X_34>0,0,X_34,2.2,0),COLORRED;

STICKLINE(X_34>0,0,X_34,0,0),COLORRED;

DRAWTEXT_FIX(1,0.8,0.05,1,1),COLORRED;

 

超级底线副图

参数1: X, 最小: 15, 最大: 40, 缺省: 30

参数2: Y, 最小: 12, 最大: 37, 缺省: 27

参数3: Z, 最小: 20, 最大: 52, 缺省: 42

参数4: M1, 最小: 2, 最大: 120, 缺省: 25

参数5: M2, 最小: 2, 最大: 120, 缺省: 6

 

STICKLINE(CLOSE>REF(CLOSE,1),HIGH,LOW,0,1),COLORRED;

STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,3.1,0),COLOR000055;

STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,2.7,0),COLOR000088;

STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,2.1,0),COLOR0000AA;

STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLOR0000CC;

STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLORRED;

STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLOR0000EE;

STICKLINE(CLOSE<REF(CLOSE,1),HIGH,LOW,0,1),COLOR666600;

STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,3.1,0),COLOR555500;

STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,2.7,0),COLOR888800;

STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,2.1,0),COLORAAAA00;

STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLORBBBB00;

STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLORCCCC00;

STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLOREEEE00;

STICKLINE(CLOSE=REF(CLOSE,1),HIGH,LOW,0,1),COLORWHITE;

STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,3.1,0),COLOR555555;

STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,2.7,0),COLOR777777;

STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,2.1,0),COLOR999999;

STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLORBBBBBB;

STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLORDDDDDD;

STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLORWHITE;

X_1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.058 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)<0.095;

X_2:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.098;

STICKLINE(X_1,OPEN,CLOSE,0,1),COLOR9B37FF;

STICKLINE(X_1,OPEN,CLOSE,3,0),COLOR6300C6;

STICKLINE(X_1,OPEN,CLOSE,2.7,0),COLOR6D00DB;

STICKLINE(X_1,OPEN,CLOSE,2.1,0),COLOR7800F0;

STICKLINE(X_1,OPEN,CLOSE,1.5,0),COLORLIMAGENTA;

STICKLINE(X_1,OPEN,CLOSE,0.9,0),COLOR8F20FF;

STICKLINE(X_1,OPEN,CLOSE,0.3,0),COLOR9B37FF;

STICKLINE(X_2,CLOSE,OPEN,3,0),COLOR00AAFF;

STICKLINE(X_2,CLOSE,OPEN,2.1,0),COLOR00BBFF;

STICKLINE(X_2,CLOSE,OPEN,1.5,0),COLOR00CCFF;

STICKLINE(X_2,CLOSE,OPEN,1,0),COLOR00DDFF;

STICKLINE(X_2,CLOSE,OPEN,0.6,0),COLOR00EEFF;

STICKLINE(X_2,CLOSE,OPEN,0.2,0),COLORYELLOW;

X_3:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)<LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10);

X_4:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>9.8;

X_5:=(OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100<5.5;

X_6:=NOT(OPEN=HIGH);

X_7:=NOT(REF(CLOSE,1)/REF(CLOSE,2)>1.098);

X_8:=20;

X_9:=MA(CLOSE,X_8);

X_10:=POW(CLOSE-X_9,2);

X_11:=MA(X_10,X_8);

X_12:=SQRT(X_11);

X_13:=X_9+2*X_12;

X_14:=X_9-2*X_12;

X_15:=REF(X_13,1);

通道上轨:X_15,COLORYELLOW,LINETHICK2;

通道下轨:(1-M2/100)*MA(CLOSE,M1),COLORRED,LINETHICK2;

X_16:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,48)*100+X;

X_17:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+Y;

X_18:=X_16 AND X_17;

X_19:=X_16 AND X_17 AND COUNT(X_18,2)=1 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(OPEN,1)>REF(CLOSE,1) OR REF(OPEN,1)<REF(CLOSE,1)) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5));

X_20:=DMA(EMA(CLOSE,8),SUM(VOL,9)/2.8/CAPITAL);

X_21:=(CLOSE-X_20)/X_20*100;

X_22:=REF(X_21,1)+Z<0 AND X_21>REF(X_21,1) AND REF(X_21,1)<REF(X_21,2) AND X_21-REF(X_21,1)>1.8 AND HIGH>LOW AND REF(HIGH,1)>REF(LOW,1) AND REF(HIGH,2)>REF(LOW,2) AND REF(HIGH,3)>REF(LOW,3) AND REF(HIGH,4)>REF(LOW,4) AND REF(HIGH,5)>REF(LOW,5);

X_23:=X_16;

X_24:=X_17;

X_25:=X_21+Z;

X_26:=IF(X_19 OR X_22,40,0);

X_27:=REF(X_23,5)>0 AND REF(X_23,4)>0 AND REF(X_23,3)>0 AND REF(X_23,2)>0 AND REF(X_23,1) AND REF(X_23,6)>0 AND REF(X_23,7)>0 AND REF(X_23,8)>0 AND REF(X_23,9)>0 AND REF(X_23,10) AND REF(X_23,15)>0 AND REF(X_23,14)>0 AND REF(X_23,13)>0 AND REF(X_23,12)>0 AND REF(X_23,11)>0;

X_28:=CROSS(X_26,X_23) AND X_27;

STICKLINE(X_28>0,CLOSE,CLOSE+0.1,100,0),COLORGRAY;

STICKLINE(X_28>0,CLOSE-0.02,CLOSE,100,0),COLOR0000CC;

 

超级底线选股

参数1: X, 最小: 15, 最大: 40, 缺省: 30

参数2: Y, 最小: 12, 最大: 37, 缺省: 27

参数3: Z, 最小: 20, 最大: 52, 缺省: 42

 

X_1:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,48)*100+X;

X_2:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+Y;

X_3:=X_1 AND X_2;

X_4:=X_1 AND X_2 AND COUNT(X_3,2)=1 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(OPEN,1)>REF(CLOSE,1) OR REF(OPEN,1)<REF(CLOSE,1)) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5));

X_5:=DMA(EMA(CLOSE,8),SUM(VOL,9)/2.8/CAPITAL);

X_6:=(CLOSE-X_5)/X_5*100;

X_7:=REF(X_6,1)+Z<0 AND X_6>REF(X_6,1) AND REF(X_6,1)<REF(X_6,2) AND X_6-REF(X_6,1)>1.8 AND HIGH>LOW AND REF(HIGH,1)>REF(LOW,1) AND REF(HIGH,2)>REF(LOW,2) AND REF(HIGH,3)>REF(LOW,3) AND REF(HIGH,4)>REF(LOW,4) AND REF(HIGH,5)>REF(LOW,5);

X_8:=X_1;

X_9:=X_2;

X_10:=X_6+Z;

X_11:=IF(X_4 OR X_7,40,0);

ABC:X_8<X_11;

 

底部大区域副图

 

X_1:=MA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);

X_2:=(-100)*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));

X_3:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);

X_4:=X_1+100;

X_5:=X_2+100;

X_6:=X_3+100;

X_7:=CLOSE>1.1*REF(CLOSE,1)-0.01 AND CLOSE<1.1*REF(CLOSE,1)+0.01 AND HIGH=CLOSE;

X_8:=CLOSE>0.9*REF(CLOSE,1)-0.01 AND CLOSE<0.9*REF(CLOSE,1)+0.01 AND LOW=CLOSE;

X_9:=NOT(X_7 OR X_8);

X_10:=X_4<12 AND X_6<8 AND (X_5<7.2 OR REF(X_5,1)<5) AND (X_6>REF(X_6,1) OR X_5>REF(X_5,1)) OR (X_4<8 AND X_6<7 AND X_5<15 AND X_5>REF(X_5,1)) OR (X_4<10 AND X_6<7 AND X_5<1) AND X_9;

STICKLINE(X_10,(-4),0,22,0),COLORRED;

 

底部反转启动副图

参数1: X, 最小: 15, 最大: 40, 缺省: 30

参数2: Y, 最小: 12, 最大: 37, 缺省: 27

参数3: Z, 最小: 20, 最大: 52, 缺省: 42

参数4: N, 最小: 1, 最大: 100, 缺省: 9

参数5: M1, 最小: 1, 最大: 100, 缺省: 3

参数6: M2, 最小: 1, 最大: 100, 缺省: 3

 

X_1:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,48)*100+X;

X_2:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+Y;

X_3:=X_1 AND X_2;

X_4:=X_1 AND X_2 AND COUNT(X_3,2)=1 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(OPEN,1)>REF(CLOSE,1) OR REF(OPEN,1)<REF(CLOSE,1)) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5));

X_5:=DMA(EMA(CLOSE,8),SUM(VOL,9)/2.8/CAPITAL);

X_6:=(CLOSE-X_5)/X_5*100;

X_7:=REF(X_6,1)+Z<0 AND X_6>REF(X_6,1) AND REF(X_6,1)<REF(X_6,2) AND X_6-REF(X_6,1)>1.8 AND HIGH>LOW AND REF(HIGH,1)>REF(LOW,1) AND REF(HIGH,2)>REF(LOW,2) AND REF(HIGH,3)>REF(LOW,3) AND REF(HIGH,4)>REF(LOW,4) AND REF(HIGH,5)>REF(LOW,5);

X_8:=X_1;

X_9:=X_2;

X_10:=X_6+Z;

X_11:=IF(X_4 OR X_7,40,0);

X_12:=X_8<0 OR X_9<0 OR X_10<0;

X_13:=NOT(HIGH=LOW);

X_14:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>9.8;

X_15:=NOT(REF(CLOSE,1)/REF(CLOSE,2)>1.098);

X_16:=NOT(HIGH=LOW);

X_17:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

X_18:=SMA(X_17,M1,1);

X_19:=SMA(X_18,M2,1);

X_20:=3*X_18-2*X_19;

X_21:=CROSS(X_20,1) AND X_14 AND X_15 AND X_16 AND X_12 AND X_13;

STICKLINE(X_21>0,0,X_21,4,0),COLORRED;

STICKLINE(X_21>0,0,X_21,4,0),COLOR000088;

STICKLINE(X_21>0,0,X_21,3.8,0),COLOR000099;

STICKLINE(X_21>0,0,X_21,3.6,0),COLOR0000AA;

STICKLINE(X_21>0,0,X_21,3.4,0),COLOR0000BB;

STICKLINE(X_21>0,0,X_21,3,2),COLOR0000CC;

STICKLINE(X_21>0,0,X_21,3,0),COLOR0000DD;

STICKLINE(X_21>0,0,X_21,2.7,0),COLOR0000EE;

STICKLINE(X_21>0,0,X_21,2.2,0),COLORRED;

STICKLINE(X_21>0,0,X_21,0,0),COLORRED;

DRAWTEXT_FIX(1,0.8,0.05,1,1),COLORRED;

 

底部反转启动选股

参数1: X, 最小: 15, 最大: 40, 缺省: 30

参数2: Y, 最小: 12, 最大: 37, 缺省: 27

参数3: Z, 最小: 20, 最大: 52, 缺省: 42

参数4: N, 最小: 1, 最大: 100, 缺省: 9

参数5: M1, 最小: 1, 最大: 100, 缺省: 3

参数6: M2, 最小: 1, 最大: 100, 缺省: 3

 

X_1:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,48)*100+X;

X_2:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+Y;

X_3:=X_1 AND X_2;

X_4:=X_1 AND X_2 AND COUNT(X_3,2)=1 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(OPEN,1)>REF(CLOSE,1) OR REF(OPEN,1)<REF(CLOSE,1)) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5));

X_5:=DMA(EMA(CLOSE,8),SUM(VOL,9)/2.8/CAPITAL);

X_6:=(CLOSE-X_5)/X_5*100;

X_7:=REF(X_6,1)+Z<0 AND X_6>REF(X_6,1) AND REF(X_6,1)<REF(X_6,2) AND X_6-REF(X_6,1)>1.8 AND HIGH>LOW AND REF(HIGH,1)>REF(LOW,1) AND REF(HIGH,2)>REF(LOW,2) AND REF(HIGH,3)>REF(LOW,3) AND REF(HIGH,4)>REF(LOW,4) AND REF(HIGH,5)>REF(LOW,5);

X_8:=X_1;

X_9:=X_2;

X_10:=X_6+Z;

X_11:=IF(X_4 OR X_7,40,0);

X_12:=X_8<0 OR X_9<0 OR X_10<0;

X_13:=NOT(HIGH=LOW);

X_14:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>9.8;

X_15:=NOT(REF(CLOSE,1)/REF(CLOSE,2)>1.098);

X_16:=NOT(HIGH=LOW);

X_17:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

X_18:=SMA(X_17,M1,1);

X_19:=SMA(X_18,M2,1);

X_20:=3*X_18-2*X_19;

X_21:=CROSS(X_20,1) AND X_14 AND X_15 AND X_16 AND X_12 AND X_13;

XG:X_21>0;

 

底部买点副图

参数1: X, 最小: 15, 最大: 40, 缺省: 30

参数2: Y, 最小: 12, 最大: 37, 缺省: 27

参数3: Z, 最小: 20, 最大: 52, 缺省: 42

 

X_1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100<9;

X_2:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,48)*100+X;

X_3:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+Y;

X_4:=X_2 AND X_3;

X_5:=X_2 AND X_3 AND COUNT(X_4,2)=1 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(OPEN,1)>REF(CLOSE,1) OR REF(OPEN,1)<REF(CLOSE,1)) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5));

X_6:=DMA(EMA(CLOSE,8),SUM(VOL,9)/2.8/CAPITAL);

X_7:=(CLOSE-X_6)/X_6*100;

X_8:=REF(X_7,1)+Z<0 AND X_7>REF(X_7,1) AND REF(X_7,1)<REF(X_7,2) AND X_7-REF(X_7,1)>1.8 AND HIGH>LOW AND REF(HIGH,1)>REF(LOW,1) AND REF(HIGH,2)>REF(LOW,2) AND REF(HIGH,3)>REF(LOW,3) AND REF(HIGH,4)>REF(LOW,4) AND REF(HIGH,5)>REF(LOW,5);

X_9:=X_2;

X_10:=X_3;

X_11:=X_7+Z;

X_12:=IF(X_5 OR X_8,40,0);

X_13:=X_9<0 OR X_10<0 OR X_11<0;

X_14:=MA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);

X_15:=(-100)*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));

X_16:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);

X_17:=X_14+100;

X_18:=X_15+100;

X_19:=X_16+100;

X_20:=X_17<12 AND X_19<8 AND (X_18<7.2 OR REF(X_18,1)<5) AND (X_19>REF(X_19,1) OR X_18>REF(X_18,1)) OR (X_17<8 AND X_19<7 AND X_18<15 AND X_18>REF(X_18,1)) OR (X_17<10 AND X_19<7 AND X_18<1);

X_21:=X_17<15 AND REF(X_17,1)<15 AND X_19<18 AND X_18>REF(X_18,1) AND CROSS(X_18,X_17) AND X_18>X_19 AND (REF(X_18,1)<5 OR REF(X_18,2)<5) AND (X_19>=X_17 OR REF(X_18,1)<1);

X_22:=REF(CLOSE,1);

X_23:=SMA(MAX(CLOSE-X_22,0),6,1)/SMA(ABS(CLOSE-X_22),6,1)*100;

X_24:=CROSS(X_23,25);

X_25:=X_20 AND X_24;

X_26:=X_21 AND X_24;

X_27:=X_25 OR X_26;

X_28:=X_13 AND X_27 AND X_1;

STICKLINE(X_28>0,0,X_28,4,0),COLORRED;

STICKLINE(X_28>0,0,X_28,4,0),COLOR000088;

STICKLINE(X_28>0,0,X_28,3.8,0),COLOR000099;

STICKLINE(X_28>0,0,X_28,3.6,0),COLOR0000AA;

STICKLINE(X_28>0,0,X_28,3.4,0),COLOR0000BB;

STICKLINE(X_28>0,0,X_28,3,2),COLOR0000CC;

STICKLINE(X_28>0,0,X_28,3,0),COLOR0000DD;

STICKLINE(X_28>0,0,X_28,2.7,0),COLOR0000EE;

STICKLINE(X_28>0,0,X_28,2.2,0),COLORRED;

STICKLINE(X_28>0,0,X_28,0,0),COLORRED;

DRAWTEXT_FIX(1,0.8,0.05,1,1),COLORRED;

 

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 通达信 通达信 掘金红筹 公式底部连续涨停捉妖抄底指标 黑马启动源码 https://www.694.cn/ziliaoxiazai/tongdaxin/3354.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务