通达信 浪子缠 黄金起换手率 缠MACD 抄底 指标套装

2024-04-09 0 845

通达信 浪子缠 黄金起换手率 缠MACD 抄底 指标套装

主图

 

DRAWGBK(C>0,RGB(150,100,0),RGB(50,100,0),0,”,0);

{盖世英雄}

AA:=EMA(INDEXC,300)/EMA(C,300);

XC:=(INDEXC/AA);

大盘:EMA(XC,10),COLORWHITE;

BB:=(H+L+2*C)/4,COLORBLUE;

DRAWBAND(大盘,RGB(50,150,0),LLV(L,600),RGB(250,200,0));

{牛线}

A:=(20 * H) + 19 * (REF(H,1)) + 18 * (REF(H,2)) + 17 * (REF(H,3)) + 16 * (REF(H,4)) + 15 * (REF(H,5)) + 14 * (REF(H,6)) + 13 * (REF(H,7)) + 12 * (REF(H,8)) + 11 * (REF(H,9));

B:=10 * (REF(H,10)) + 9 * (REF(H,11)) + 8 * (REF(H,12)) + 7 * (REF(H,13)) + 6 * (REF(H,14)) + 5 * (REF(H,15)) + 4 * (REF(H,16)) + 3 * (REF(H,17)) + 2 * (REF(H,18)) + REF(H,20);

AAAR5:=(A+ B) / 210;

DRAWBAND(IF(((EMA(AAAR5,90)) – ((((C – (EMA(AAAR5,90))) * C) – (EMA(AAAR5,90))) / (EMA(AAAR5,90))))>(EMA(AAAR5,90)),((EMA(AAAR5,90)) – ((((C – (EMA(AAAR5,90))) * C)

– (EMA(AAAR5,90))) / (EMA(AAAR5,90)))),(EMA(AAAR5,90))),RGB(0,0,0),(EMA(AAAR5,90)),RGB(250,200,0));

龙线:MA(C,240),COLOR00FF00,LINETHICK2;

牛线:EMA(AAAR5,90),LINETHICK1,COLORYELLOW;

相对:=(牛线-(((C-牛线)*C)-牛线)/牛线),COLORYELLOW;

缠牛线:IF(相对>牛线,相对,牛线),COLOR00AAAA;

重心:=(C+0.618*REF(C,1)+0.382*REF(C,2)+0.236*REF(C,3)+0.146*REF(C,4))/2.382,COLORRED,LINETHICK1;

GAO:=HHV(C,60)-LLV(C,60);

RSI:=SMA(MAX(重心-REF(重心,1),0),5,1)/SMA(ABS(重心-REF(重心,1)),5,1);

准线:EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55),COLORFFAA00,LINETHICK1;

缠准:=重心+GAO*(RSI-0.5),COLOR999900,LINETHICK1;

缠准线:IF(准线>REF(准线,1) AND C>牛线,缠准,准线),COLOR999900;

EMA(AAAR5,90),LINETHICK2,COLORYELLOW;

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

{彩K}

XG1:=C/REF(C,1)>1.0618;

STICKLINE(XG1,L,H,0,1),COLOR0088EE;

STICKLINE(XG1,CLOSE,OPEN,3,0),COLOR0055AA;

STICKLINE(XG1,CLOSE,OPEN,2.8,0),COLOR0066BB;

STICKLINE(XG1,CLOSE,OPEN,2.5,0),COLOR0077CC;

STICKLINE(XG1,CLOSE,OPEN,2.2,0),COLOR0088DD;

STICKLINE(XG1,CLOSE,OPEN,1.7,0),COLOR0099EE;

STICKLINE(XG1,CLOSE,OPEN,1.2,0),COLOR00AAFF;

STICKLINE(XG1,CLOSE,OPEN,0.7,0),COLOR00CCFF;

STICKLINE(XG1,CLOSE,OPEN,0.2,0),COLOR00FFFF;

涨停:=BETWEEN(CLOSE/REF(CLOSE,1),1.0989,1.110) AND C=H AND C>=O;

STICKLINE(涨停,H,L,0,1),COLORRED;

IF(准线>=REF(准线,1) AND C>牛线,缠准,准线),COLOR999900;

IF(准线<REF(准线,1),准线,DRAWNULL),COLORFFAA00,LINETHICK2;

IF(准线>=REF(准线,1),准线,DRAWNULL),COLOR0000FF,LINETHICK2;

{周KDJ}

RSV周:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45));

K周:=SMA(RSV周,15,1),COLORFF00FF,LINETHICK1;

D周:=SMA(K周,15,1),COLORWHITE,LINETHICK3;

J周:=3*K周-2*D周;

DRAWICON(CROSS(C,缠牛线) AND (牛线>龙线 OR (C>龙线 AND C>牛线)),牛线*1.05,14);

DRAWICON(CROSS(C,大盘) AND C>缠牛线,牛线,31);{走强};

{所属板块、概念}

DRAWTEXT_FIX(1,0.005,0,0,’所属风格:’),COLORRED;DRAWTEXT_FIX(1,0.06,0,0,FGBLOCK),COLORRED;

DRAWTEXT_FIX(1,0.005,0.06,0,’所属概念:’),COLORMAGENTA;DRAWTEXT_FIX(1,0.06,0.06,0,GNBLOCK),COLORMAGENTA;

DRAWTEXT_FIX(1,0.005,0.12,0,’所属板块:’),COLORYELLOW;DRAWTEXT_FIX(1,0.06,0.12,0,DYBLOCK),COLORYELLOW;DRAWTEXT_FIX(1,0.11,0.12,0,HYBLOCK),COLORYELLOW;

{流通盘}

DRAWTEXT_FIX(1,0.42,0.05,0,’流通股’),COLORYELLOW;

DRAWNUMBER_FIX(1,0.47,0.05,0,CONST(FINANCE(7)/100000000)),COLORYELLOW;

DRAWTEXT_FIX(1,0.42,0.0,0,STRCAT(STRCAT(‘流通盘:’,CON2STR((FINANCE(46)*C/100000000),2)),’亿’)),COLORYELLOW;

YSTB:=STRCAT(CON2STR(FINANCE(44)/1,2),’%’);

LRTB:=STRCAT(CON2STR(FINANCE(43)/1,2),’%’);

DRAWTEXT_FIX(1,0.6,0,0,’营收同比:’),COLORWHITE;

DRAWTEXT_FIX(1,0.66,0,0,YSTB),COLORWHITE;

DRAWTEXT_FIX(1,0.74,0,0,’利润同比:’),COLORWHITE;

DRAWTEXT_FIX(1,0.8,0,0,LRTB),COLORWHITE;

净资收益率:=(FINANCE(33)/FINANCE(34)*100);主营利润率:=(FINANCE(23)/FINANCE(20)*100);

主营业增长率:=FINANCE(44);

每股净资产:=CONST(FINANCE(34));每股收益:=CONST(FINANCE(38));

净利润增长率:=FINANCE(43);市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));

现金负债比:=(FINANCE(25)/FINANCE(15));

每股未分配:=CONST(FINANCE(32));每股公积金:=CONST(FINANCE(18));

SY01:=净资收益率>3;SY02:=净资收益率>0.01 AND 净资收益率<=3;SY03:=主营利润率>2;SY04:=主营利润率>0;

SY05:=主营业增长率>1;SY06:=主营业增长率>0;SY07:=净利润增长率>2;SY08:=净利润增长率>0.2;SY09:=每股收益>0.01;

SY10:= 每股收益>0.001;SY11:=每股净资产>2;SY12:=每股净资产>0.01;SY13:=每股未分配>0.5;SY14:=每股未分配>0.001;

SY15:=每股公积金>0.5;SY16:=每股公积金>0.002;SY17:=每股未分配>=2 AND 每股公积金>=2;SY18:=每股未分配<2 OR 每股公积金<2;

优秀:=SY01 AND SY03 AND SY05 AND SY07 AND SY09 AND SY11 AND SY13 AND SY15;

较好:=SY02 AND SY04 AND SY06 AND SY08 AND SY10 AND SY12 AND SY14 AND SY16;

一般:=NOT(优秀) AND NOT(较好);

DRAWTEXT_FIX(优秀 AND 较好=0,0.6,0.05,0,’综合评估基本面:优秀!’),COLORMAGENTA;

DRAWTEXT_FIX(较好,0.6,0.05,0,’综合评估基本面:较好!’),COLORRED;

DRAWTEXT_FIX(一般,0.6,0.05,0,’综合评估基本面:一般!’),COLORGREEN;

DRAWTEXT_FIX(SY17,0.74,0.05,0,’是否具备高送转潜力:是!’),COLORMAGENTA;

DRAWTEXT_FIX(SY18,0.74,0.05,0,’是否具备高送转潜力:否!’),COLORGREEN;

{DRAWTEXT_FIX(1,0,5,0,’~☆~ 买入不下准线涨个不停个股=买点在60KD金叉且缠准线V型反转时 ~☆~’),COLORRED;};

 

 

副图1

 

 

DRAWGBK(C>0,RGB(150,100,0),RGB(50,100,0),0,”,0);

DIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORRED;

DEA:EMA(DIF,9),COLORYELLOW;

DRAWBAND(DIF,RGB(255,0,0),DEA,RGB(0,255,0));

MACD:(DIF-DEA)*2,COLORSTICK;

金叉:CROSS(DIF,DEA),NODRAW;

死叉:CROSS(DEA,DIF),NODRAW;

空中加油:IF(DIF>REF(DIF,1) AND DIF>=DEA AND REF(DIF,1)<=REF(DIF,2) AND REF(DIF,1)>=REF(DEA,1),1,0),NODRAW,COLORFF6600;

红柱拐点:IF(MACD<REF(MACD,1) AND REF(MACD,1)>REF(MACD,2) AND MACD>0.3,1,0),NODRAW,COLORCC9933;

DRAWICON(红柱拐点=1,MACD,2);

绿柱拐点:IF(MACD<=(-0.3) AND MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2),1,0),NODRAW;

强:IF(DIF>=DEA,DIF,DRAWNULL),COLORRED,LINETHICK2;

弱:IF(DEA>=DIF,DEA,DRAWNULL),COLORCC9933;

STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,2,0),COLORFF6600;

STICKLINE(MACD>=REF(MACD,1) AND MACD>0,0,MACD,2,0),COLOR0011EE;

STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,2,0),COLORBB11BB;

STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,2,0),COLORFFBB11;

DRAWICON(空中加油=1,DIF,23);

DRAWICON(CROSS(DIF,DEA),0.05,34);

DRAWICON(CROSS(DEA,DIF),DEA+0.05,35);

 

副图2

 

 

DRAWGBK(C>0,RGB(150,100,0),RGB(50,100,0),0,”,0);

STICKLINE(C>0,0,3,6,0),COLORAAAA00;

AA:=EMA(INDEXC,300)/EMA(C,300);

XC:=(INDEXC/AA);

大盘:=EMA(XC,10);

BB:=(H+L+2*C)/4;

换手:VOL/CAPITAL*100,COLORRED,NODRAW;

低换:换手<2,COLORFFFF00,NODRAW;

温和换:换手>2 AND 换手<5,COLORMAGENTA,NODRAW;

热换:换手>5 AND 换手<11,COLORYELLOW,NODRAW;

烫手换:换手>11 AND 换手<17,COLORRED,NODRAW;

高潮换:换手>17,COLORGREEN,NODRAW;

STICKLINE(换手<2,0,换手,2.3,0),COLORFF4400;

STICKLINE(换手<2,0,换手,1.8,0),COLORFF6600;

STICKLINE(换手<2,0,换手,1.3,0),COLORFF9900;

STICKLINE(换手<2,0,换手,0.6,0),COLORFFCC00;

STICKLINE(换手<2,0,换手,0.3,0),COLORGREEN;

STICKLINE(换手>2 AND 换手<5,0,换手,2.3,0)COLORFF0033;

STICKLINE(换手>2 AND 换手<5,0,换手,1.8,0)COLORFF0066;

STICKLINE(换手>2 AND 换手<5,0,换手,1.2,0)COLORFF0099;

STICKLINE(换手>2 AND 换手<5,0,换手,0.6,0)COLORFF00CC;

STICKLINE(换手>2 AND 换手<5,0,换手,0.3,0)COLORFF00FF;

STICKLINE(换手>5 AND 换手<11,0,换手,2.3,0)COLOR0035FF;

STICKLINE(换手>5 AND 换手<11,0,换手,1.8,0)COLOR0064FF;

STICKLINE(换手>5 AND 换手<11,0,换手,1.3,0)COLOR0093FF;

STICKLINE(换手>5 AND 换手<11,0,换手,0.8,0)COLOR00C2FF;

STICKLINE(换手>5 AND 换手<11,0,换手,0.3,0)COLOR00FFFF;

STICKLINE(换手>11 AND 换手<17,0,换手,2.3,0),COLOR000055;

STICKLINE(换手>11 AND 换手<17,0,换手,2,0),COLOR000077;

STICKLINE(换手>11 AND 换手<17,0,换手,1.8,0),COLOR000099;

STICKLINE(换手>11 AND 换手<17,0,换手,1.5,0),COLOR0000BB;

STICKLINE(换手>11 AND 换手<17,0,换手,0.9,0),COLOR0000DD;

STICKLINE(换手>11 AND 换手<17,0,换手,0.3,0),COLOR0000FF;

STICKLINE(换手>17,0,换手,2.3,0),COLOR006000;

STICKLINE(换手>17,0,换手,2.1,0),COLOR007500;

STICKLINE(换手>17,0,换手,1.8,0),COLOR009100;

STICKLINE(换手>17,0,换手,1.3,0),COLOR00A600;

STICKLINE(换手>17,0,换手,0.8,0),COLOR00BB00;

STICKLINE(换手>17,0,换手,0.3,0),COLOR00CC00;

换手5:MA(换手,5),COLOR0000FF,LINETHICK2;

量比:=V/REF(MA(V,5),1),COLORFFFFFF,LINETHICK2;

3;

DRAWICON(CROSS(BB,大盘),3,31);{开始走强点};

 

 

副图3

 

DRAWGBK(C>0,RGB(150,100,0),RGB(50,100,0),0,”,0);

X_1:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);

X_2:=HIGH-REF(HIGH,1);

X_3:=REF(LOW,1)-LOW;

X_4:=EXPMEMA(IF(X_2>0 AND X_2>X_3,X_2,0),14);

X_5:=EXPMEMA(IF(X_3>0 AND X_3>X_2,X_3,0),14);

X_6:=X_4*100/X_1;

X_7:=X_5*100/X_1;

X_8:=EXPMEMA(ABS(X_7-X_6)/(X_7+X_6)*100,6);

X_9:=X_8-X_6;

X_10:=X_9/X_6>13.88;

X_11:=(MA(CLOSE,30)-LOW)/MA(CLOSE,60)*200;

X_12:=REF(CLOSE,1);

X_13:=SMA(MAX(CLOSE-X_12,0),7,1)/SMA(ABS(CLOSE-X_12),7,1)*100;

X_14:=FILTER(REF(X_13,1)<20 AND X_13>REF(X_13,1),5);

X_15:=CLOSE/MA(CLOSE,40)<0.74;

X_16:=5;

X_17:=EMA(CLOSE,X_16);

X_18:=EMA(X_17,X_16);

X_19:=X_17-REF(X_17,1);

X_20:=X_18-REF(X_18,1);

X_21:=ABS(X_17-X_18);

X_22:=(HIGH-LOW)/REF(CLOSE,1)>0.05;

X_23:=(X_19+X_20)/2;

X_24:=POW(X_21,1)*POW(X_23,3);

X_25:=X_24/HHV(ABS(X_24),X_16*3);

X_26:=COUNT(X_22,5)>1;

X_27:=X_15 AND X_22 AND X_26;

X_28:=CROSS(X_25,(-0.9));

XG:X_10 AND X_28;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 套装公式 通达信 浪子缠 黄金起换手率 缠MACD 抄底 指标套装 https://www.694.cn/ziliaoxiazai/tongdaxin/4034.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务