​通达信指标 定海神针主副图 力度强弱模型

2024-04-09 0 661

​通达信指标 定海神针主副图 力度强弱模型

主图

STICKLINE((C-REF(C,1))/REF(C,1)>=0.098,C,O,2,0),COLORMAGENTA;

STICKLINE((C-REF(C,1))/REF(C,1)>=0.098,H,L,0,0),COLORMAGENTA;

STICKLINE((C-REF(C,1))/REF(C,1)<=-0.098,C,O,2,0),COLORLIGRAY;

STICKLINE((C-REF(C,1))/REF(C,1)<=-0.098,H,L,0,0),COLORLIGRAY;

STICKLINE((C-REF(C,1))/REF(C,1)>=0.196,C,O,2,0),COLORYELLOW;

STICKLINE((C-REF(C,1))/REF(C,1)>=0.196,H,L,0,0),COLORYELLOW;

STICKLINE((C-REF(C,1))/REF(C,1)<=-0.196,C,O,2,0),COLORLICYAN;

STICKLINE((C-REF(C,1))/REF(C,1)<=-0.196,H,L,0,0),COLORLICYAN;

换手率:V*100/FINANCE(46)*100 NODRAW;

换手周期:=SUMBARS(换手率,100) NODRAW;

筹码参数:TOTALCAPITAL*100/FINANCE(46) NODRAW;

获利比例:WINNER(C)*100 NODRAW;

周期内低点:=LLV(L,换手周期) NODRAW;

低点:=L=周期内低点;

低起日:=BARSLAST(低点)+1 NODRAW;

周期内高点:=HHV(H,低起日) NODRAW;

高点:=H=周期内高点;

高起日:=BARSLAST(高点)+1 NODRAW;

换手:SUM(换手率,低起日) NODRAW COLORYELLOW;

见底日:=BARSLAST(CROSS(换手,50));

见底日1:=BARSLAST(CROSS(换手,100));

见底日2:=BARSLAST(CROSS(换手,200));

见底日3:=BARSLAST(CROSS(换手,300));

见底日4:=BARSLAST(CROSS(换手,400));

趋势高点:HHV(H,低起日) NODRAW;

见底:IF(CURRBARSCOUNT<=CONST(见底日+1),CONST(REF(C,见底日)),DRAWNULL)  CROSSDOT COLORRED LINETHICK3;

建仓:IF(CURRBARSCOUNT<=CONST(见底日1+1),CONST(REF(C,见底日1)),DRAWNULL)  COLORWHITE LINETHICK3;

二:IF(CURRBARSCOUNT<=CONST(见底日2+1),CONST(REF(C,见底日2)),DRAWNULL)  COLORYELLOW LINETHICK3;

三:IF(CURRBARSCOUNT<=CONST(见底日3+1),CONST(REF(C,见底日3)),DRAWNULL)  COLORGREEN LINETHICK3;

四:IF(CURRBARSCOUNT<=CONST(见底日4+1),CONST(REF(C,见底日4)),DRAWNULL)  COLORFF00FF LINETHICK3;

DRAWICON(低点,L,9);

DRAWICON(CROSS(换手,50),L,1);

DRAWTEXT(CROSS(换手,50),L*0.95,’见底’)COLORYELLOW;

DRAWICON(CROSS(换手,100),L,1);

DRAWTEXT(CROSS(换手,100),L*0.95,’建仓完成’)COLORYELLOW;

DRAWICON(CROSS(换手,200),L,1);

DRAWTEXT(CROSS(换手,200),L*0.95,’分歧2′)COLORYELLOW;

DRAWICON(CROSS(换手,300),L,1);

DRAWTEXT(CROSS(换手,300),L*0.95,’分歧3′)COLORYELLOW;

DRAWICON(CROSS(换手,400),L,1);

DRAWTEXT(CROSS(换手,400),L*0.95,’分歧4′)COLORYELLOW;

主力换手:换手 NODRAW COLORYELLOW;

{DRAWICON(主力换手>300,H,2);};

 

副图1

 

DRAWGBK(C>0, RGB(310,108,108),RGB(88,30,0),0,”,0);

NOTEXT顶部标线:120,COLORBROWN;

NOTEXT底部标线:-80,COLORBROWN;

{力度平衡信号}

力度平衡点:40,COLORBROWN,LINETHICK2;

LDA1:=FORCAST(FORCAST(SMA(MAX(CLOSE-REF(CLOSE,1),0),9,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),9,1)*100,3),18);

LDA2:=LDA1>REF(LDA1,1) AND LDA1>40;

LDA3:=LDA1<=REF(LDA1,1) AND LDA1>40;

LDA4:=LDA1>REF(LDA1,1) AND LDA1<=40;

LDA5:=LDA1<=REF(LDA1,1) AND LDA1<=40;

STICKLINE(LDA2,40,LDA1,3,0),COLORFF00FF;

STICKLINE(LDA3,40,LDA1,3,0),COLORBROWN;

STICKLINE(LDA4,40,LDA1,3,0),COLORRED;

STICKLINE(LDA5,40,LDA1,3,0),COLORWHITE;

趋势平衡线:MA(SMA(MAX(CLOSE-REF(CLOSE,1),0),9,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),9,1)*100,26),COLORBLUE,LINETHICK2;

{力度强弱信号}

力度强弱:=(((CLOSE – MA(CLOSE,30)) / MA(CLOSE,30)) * 100);

STICKLINE(力度强弱>=20,8,10,3,0),COLORFF00FF;

STICKLINE(力度强弱>=0 AND 力度强弱<20 AND 力度强弱>6,8,10,3,0),COLORRED;

STICKLINE(力度强弱>=0 AND 力度强弱<20 AND 力度强弱<=6,8,10,3,1),COLORDDDDDD;

STICKLINE(力度强弱<=0 AND 力度强弱>-20,8,10,3,1),COLORDDDDDD;

STICKLINE(力度强弱<=-20,8,10,3,0),COLORDDDDDD;

{力度波动信号}

BD1:=(3*CLOSE+LOW+OPEN+HIGH)/6;

BD2:=(20*BD1+19*REF(BD1,1)+18*REF(BD1,2)+17*REF(BD1,3)+16*REF(BD1,4)+15*REF(BD1,5)+

14*REF(BD1,6)+13*REF(BD1,7)+12*REF(BD1,8)+11*REF(BD1,9)+10*REF(BD1,10)+9*REF(BD1,11)+

8*REF(BD1,12)+7*REF(BD1,13)+6*REF(BD1,14)+5*REF(BD1,15)+4*REF(BD1,16)+3*REF(BD1,17)+

2*REF(BD1,18)+REF(BD1,20))/210;

BD3:=MA(BD2,6);

BD4:=V*100/CAPITAL;

BD5:=MA(BD4,5);

BD6:=MA(BD4,55);

BD7:=(BD5-BD6);

BD8:=(C-BD2);

BD9:=BD7+BD8;

BD10:=EMA(V,5);

BD11:=EMA(V,50);

OBV:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);

BD12:=EMA(OBV,5);

BD13:=EMA(OBV,50);

BD14:=(BD10-BD11)*0.00001;

BD15:=(BD12-BD13)*0.000001;

BD16:=BD14+BD15;

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;

DKX:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+

16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+

13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+

10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+

7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+

4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;

BD17:=MA(DKX,6);

BD18:=(DKX-BD17)*1.2;

BD19:=(C*2+H+L)/4*10;

BD20:=EMA(BD19,6)-EMA(BD19,55);

BD21:=EMA(BD20,6);

BD22:=(BD20-BD21)*0.06;

BD23:=BD18+BD22;

BD24:=MA(C,5)>REF(MA(C,5),1);

BD25:=EMA(C,12)>REF(EMA(C,12),1);

BD26:=MA(C,20)>REF(MA(C,20),1);

BD27:=MA(C,30)>REF(MA(C,30),1);

BD28:=MA(C,60)>REF(MA(C,60),1);

BD29:=MA(C,120)>REF(MA(C,120),1);

BD30:=MA(C,250)>REF(MA(C,250),1);

BD31:=BD25 + BD26 + BD27 + BD28;

BD32:=C>BD2 AND BD9>0 AND BD16>0 AND BD23>0;

BD33:=C<=BD2 OR BD9<=0 OR BD16<=0 OR BD23<=0;

力度波动A:=BD31=4 AND BD32;

力度波动B:=BD31=3 AND BD32;

力度波动C:=BD31<3 OR BD33;

STICKLINE(力度波动A,-2,0,3,0),COLORFF00FF;

STICKLINE(力度波动B,-2,0,3,0),COLORRED;

STICKLINE(力度波动C,-2,0,3,1),COLORDDDDDD;

BD34:=C>MA(C,3) AND BD24 AND BD25  AND BD26 AND BD27 AND BD28;

一帆风顺:BD34 AND (COUNT(BD34,5)=2) AND REF(NOT(BD34),1),COLORGREEN,NODRAW;

DRAWTEXT(一帆风顺,38,’↖★’),COLORGREEN;

STICKLINE(一帆风顺,40,LDA1,2.06,0),COLORGREEN;

BD35:=C>MA(C,5) AND BD24 AND BD25  AND BD26 AND BD27 AND BD28 AND BD29;

BD36:=COUNT(BD35,5)=2 OR COUNT(BD35,5)=3 OR COUNT(BD35,5)=4 OR COUNT(BD35,9)=2;

二龙戏珠:BD35 AND BD36 AND REF(BD35=0,1) AND BD32,COLORYELLOW,NODRAW;

DRAWTEXT(二龙戏珠,35,’↖★★’),COLORYELLOW;

STICKLINE(二龙戏珠,40,LDA1,1.36,0),COLORYELLOW;

三阳开泰:BD32 AND (REF(BD32=0,1) OR REF(BD32=1,1)) AND BD35 AND REF(BD35=0,1),COLORRED,NODRAW;

DRAWTEXT(三阳开泰,32,’↖★★★’),COLORRED;

STICKLINE(三阳开泰,40,LDA1,0.56,0),COLORRED;

{力度临界信号}

破界线1:=EMA(C,21)*4;

封印1:=EMA(HY_INDEXC,144)/MA(C,144);

临界线:=EMA(HY_INDEXC/封印1,21)*4;

STICKLINE(破界线1>临界线,-12,-10,3,0),COLORRED;

STICKLINE(破界线1<=临界线,-12,-10,3,1),COLORDDDDDD;

破除临界点:=CROSS(破界线1,临界线) AND 破界线1>REF(破界线1,1);

DRAWTEXT(破除临界点,-15,’↖越过临界’);

{力度结界信号}

破界线2:=EMA(C,21)*4;

封印2:=EMA(INDEXC,144)/MA(C,144);

结界线:=EMA(INDEXC/封印2,21)*4;

STICKLINE(破界线2>结界线,-22,-20,3,0),COLORRED;

STICKLINE(破界线2<=结界线,-22,-20,3,1),COLORDDDDDD;

破除结界点:=CROSS(破界线2,结界线) AND 破界线2>REF(破界线2,1);

DRAWTEXT(破除结界点,-25,’↖冲破结界’);

{信号名称标注}

DRAWTEXT(ISLASTBAR,40,’★力度平衡点★’)COLORGREEN;

DRAWTEXT(ISLASTBAR,10,’★力度强弱★’)COLORGREEN;

DRAWTEXT(ISLASTBAR,0,’★力度波动★’)COLORGREEN;

DRAWTEXT(ISLASTBAR,-10,’★力度临界★’)COLORGREEN;

DRAWTEXT(ISLASTBAR,-20,’★力度结界★’)COLORGREEN;

{用法标注}

DRAWTEXT_FIX(ISLASTBAR,0,0.01,0,’★模型设计思路★ 当股价上涨的时候,其内在影响因素很多,

其中力度强弱就是重要因素之一。基于此,准确判定股价上涨力度的强弱,就是判定股价上涨是否

具备持续性的关键环节’),COLORB2FFAA;

DRAWTEXT_FIX(ISLASTBAR,0,0.05,0,’★力度基本判定★ 1.“4柱+1点+1线”:

洋红柱+棕色柱+白色柱+红色柱+力度平衡点+趋势平衡线’),COLORCYAN;

DRAWTEXT_FIX(ISLASTBAR,0.078,0.09,0,’2.洋红柱:代表力度持续增大;棕色柱:代表力度逐渐减小;

白色柱:代表力度明显弱势;红色柱:代表力度开始增大’),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.078,0.13,0,’3.力度平衡点:代表力度变强、变弱的分界点,

在平衡点之上的力度柱,需要重点关注’),COLORFFD1C3;

DRAWTEXT_FIX(ISLASTBAR,0.078,0.17,0,’4.趋势平衡线:代表力度强弱的重要分界线,

在平衡线之上的力度柱,需要进一步重点关注,这是力度增强的象征’),COLORGREEN;

DRAWTEXT_FIX(ISLASTBAR,0.078,0.21,0,’5.力度柱在趋势平衡线下方,下跌概率大,宜观望空仓;

趋势平衡线在40之下,加速下跌或者下跌末期的概率大,宜等待转势’),COLORWHITE;

DRAWTEXT_FIX(ISLASTBAR,0,0.72,0,’★力度辅助判定★ 1.分为四个维度:力度强弱、力度波动、

力度临界、力度结界’),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.078,0.76,0,’2.第一维度~力度强弱:顾名思义,股价向上拉升,

必须是有力度的上涨,才能形成上涨趋势。因此,这个维度是判定股价上涨力度是否增强的要素之一。

红色代表上涨力度由弱转强,洋红色代表上涨力度明显增强’),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.078,0.80,0,’3.第二维度~力度波动:顾名思义,就是上涨力度具备了

很大波动空间,才能推动股价不断向上,这也是股价能否上涨的重要特征之一,更是影响股价上涨的

要素之一。洋红色代表力度波动开始加大’),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.078,0.84,0,’4.第三维度~力度临界:是从逆向思维的角度考虑,当出现

股价横盘期间该跌不跌、下跌末期刻意无量下跌等情况,意味着股价内在走势发生改变,

突破弱的极限转为强的状态。红色为信号,伴随越过临界信号更好’),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.078,0.88,0,’5.第四维度~力度结界:是从抽向思维的角度考虑,将市场

的无形力量看作无形压力,如同束缚股价的结界一样。当股价走势悄然冲破结界之时,意味着股价

内在走势发生质变。红色为信号,伴随冲破结界信号更好’),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0,0.92,0,’★力度判定步骤★ 1.力度柱位于40之上;2.力度柱超过趋势平衡线;

3.“四个维度”全部红色,2个红色+2个洋红更好;4.伴随“冲破结界+越过临界”信号更好;

5.出现“打破力度平衡”信号;6.优选“力度结界”红色的个股进行关注’),COLORMAGENTA;

DRAWTEXT_FIX(ISLASTBAR,0.788,0.01,0,’★判断打破力度平衡的3种信号★’),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.788,0.05,0,’1.一帆风顺:绿色力度柱 【等级】★      力度突增’),COLORWHITE;

DRAWTEXT_FIX(ISLASTBAR,0.788,0.09,0,’2.二龙戏珠:黄色力度柱 【等级】★★   力度大增’),COLORWHITE;

DRAWTEXT_FIX(ISLASTBAR,0.788,0.13,0,’3.三阳开泰:红色力度柱 【等级】★★★力度巨增’),COLORWHITE;

 

 

 

副图2

DRAWGBK((CLOSE > 1),RGB(0,0,0),RGB(0,0,255),0,0,0);

S1:=(C-LLV(L,18))/(HHV(H,18)-LLV(L,18))*100;

S2:=(C-LLV(L,34))/(HHV(H,34)-LLV(L,34))*100;

S3:=(C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100;

S4:=MA(C,34);

S5:=(C-S4)/S4*100;

A:=MA(S5,2);

B:=BARSLAST(CROSS(-10,A)=1);

X:=SMA(SMA(S1,3,1),3,1)+3*STD(C,14);

X1:=SMA(S2,5,1)+2*STD(C,14);

X2:=SMA(S3,5,1);

Q:=X<18 AND X1<18 AND X2<18;

W:=A<-10 AND B>3;

JC:=COUNT(Q,10)>1 OR COUNT(W,10)>1;

Z:=(C-L)*100/L>1;

F:=L*100-INTPART(L*10)*10;

E:=INTPART(L)-INTPART(L/10)*10;

P:=(INTPART(L)-E)/10;

S11:=REF(CCI<-190,1) AND CCI>0 ;

Y:=Z AND L=LLV(L,9) AND JC AND (P=F) OR S11;

STICKLINE(Y,50,38,0.5,0),COLORYELLOW ;

STICKLINE(Y,38,12,0.5,0),COLORRED;

STICKLINE(Y,12,0,0.5,0),COLORYELLOW;

DRAWTEXT(Y,40,’定海神针‘),COLORYELLOW;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 套装公式 ​通达信指标 定海神针主副图 力度强弱模型 https://www.694.cn/ziliaoxiazai/tongdaxin/4054.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务