通达信 股海垂钓 主图 股海垂钓副图 指标

2024-04-09 0 522

通达信 股海垂钓 主图 股海垂钓副图 指标

主图源码

参数1: N, 最小: 0, 最大: 50, 缺省: 5

参数2: M, 最小: 0, 最大: 50, 缺省: 5

DRAWGBK(CURRBARSCOUNT=1,RGB(110,600,108),RGB(88,120,100),0,3,0);

DRAWGBK(CURRBARSCOUNT=1,RGB(110,600,108),RGB(88,120,100),0,3,0);

X_1:=(3*CLOSE+HIGH+LOW+OPEN)/6;

X_2:=(8*X_1+7*REF(X_1,1)+6*REF(X_1,2)+5*REF(X_1,3)+4*REF(X_1,4)+3*REF(X_1,5)+2*REF(X_1,6)+REF(X_1,8))/36;

X_3:=(HHV(X_2,5)+HHV(X_2,10)+HHV(X_2,20))/3;

X_4:=(LLV(X_2,5)+LLV(X_2,10)+LLV(X_2,20))/3;

X_5:=(HHV(X_3,5)+HHV(X_3,10)+HHV(X_3,20))/3;

X_6:=(LLV(X_4,5)+LLV(X_4,10)+LLV(X_4,20))/3;

X_7:=(LLV(X_2,2)+LLV(X_2,4)+LLV(X_2,6))/3;

DRAWBAND(X_2,RGB(155,50,50),X_7,RGB(250,250,0));

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

X_8:=(3*CLOSE+LOW+OPEN+HIGH)/6;

X_9:=(20*X_8+19*REF(X_8,1)+18*REF(X_8,2)+17*REF(X_8,3)+16*REF(X_8,4)+15*REF(X_8,5)+14*REF(X_8,6)+13*REF(X_8,7)+12*REF(X_8,8)+11*REF(X_8,9)+10*REF(X_8,10)+9*REF(X_8,11)+8*REF(X_8,12)+7*REF(X_8,13)+6*REF(X_8,14)+5*REF(X_8,15)+4*REF(X_8,16)+3*REF(X_8,17)+2*REF(X_8,18)+REF(X_8,20))/210;

X_10:=MA(X_9,10);

X_11:=(CLOSE+HIGH+OPEN+LOW)/4;

X_12:=XMA(X_11,20)*(1+80/1000);

X_13:=XMA(X_11,32)*(1-100/1000);

鱼来了:DRAWBAND(X_13>X_10,RGB(155,50,50),X_13<X_10,RGB(250,250,0));

短线:X_2,NODRAW,COLORWHITE;

中线:X_7,NODRAW,COLORYELLOW;

下跌:IF(X_2=X_7,X_7,DRAWNULL),COLORGREEN;

X_14:=5;

X_15:=7;

X_16:=11;

X_17:=EMA(CLOSE,X_14);

X_18:=EMA(CLOSE,X_15);

X_19:=EMA(CLOSE,X_16);

X_20:=BETWEEN(X_18,X_17,X_19);

X_21:=MA(CLOSE,20);

IF(X_21>REF(X_21,1),X_21,DRAWNULL),NODRAW,COLORRED,LINETHICK3;

X_22:=FILTER(X_20=0,5);

X_23:=EMA(CLOSE,20);

X_24:=EMA(CLOSE,40);

X_25:=EMA(CLOSE,60);

X_26:=BARSLAST(X_24>X_25 AND (X_23=X_24 OR X_23>X_24));

X_27:=REF(COUNT(CLOSE<X_25,X_26)=X_26,1);

X_28:=CROSS(CLOSE,X_25) AND VOL>MA(VOL,5) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>3;

X_29:=LLV(HIGH,240);

X_30:=100*(CLOSE-X_29)/X_29;

X_31:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;

X_32:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;

X_33:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;

X_34:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;

X_35:=BARSCOUNT(CLOSE);

X_36:=X_33<20 AND X_34<23 AND X_35>35;

X_37:=X_36 AND COUNT(X_36,1)=1;

X_38:=EMA(CLOSE,21)-EMA(CLOSE,8);

X_39:=EMA(X_38,5);

X_40:=TROUGHBARS(3,6,1)<4 AND CROSS(X_38,X_39);

X_41:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);

X_42:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

X_43:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);

X_44:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

X_45:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);

X_46:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

X_47:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);

X_48:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

X_49:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

X_50:=EMA(CLOSE,2)-EMA(CLOSE,150);

X_51:=EMA(X_50,100);

X_52:=2*(X_50-X_51);

X_53:=POW(X_52,3)*0.1+POW(X_52,1);

X_54:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));

X_55:=EMA(X_54*0.97,3);

X_56:=(HIGH+LOW+CLOSE)/3;

X_57:=(X_56-MA(X_56,14))/(0.015*AVEDEV(X_56,14));

X_58:=CROSS(X_55,LOW);

X_59:=X_41;

X_60:=EMA(HHV(HIGH,500),21);

X_61:=EMA(HHV(HIGH,250),21);

X_62:=EMA(HHV(HIGH,90),21);

X_63:=EMA(LLV(LOW,500),21);

X_64:=EMA(LLV(LOW,250),21);

X_65:=EMA(LLV(LOW,90),21);

X_66:=EMA((X_63*0.96+X_64*0.96+X_65*0.96+X_60*0.558+X_61*0.558+X_62*0.558)/6,21);

X_67:=EMA((X_63*1.25+X_64*1.23+X_65*1.2+X_60*0.55+X_61*0.55+X_62*0.65)/6,21);

X_68:=EMA((X_63*1.3+X_64*1.3+X_65*1.3+X_60*0.68+X_61*0.68+X_62*0.68)/6,21);

X_69:=EMA((X_66*3+X_67*2+X_68)/6*1.738,21);

X_70:=REF(LOW,1);

X_71:=SMA(ABS(LOW-X_70),3,1)/SMA(MAX(LOW-X_70,0),3,1)*100;

X_72:=EMA(IF(CLOSE*1.35<=X_69,X_71*10,X_71/10),3);

X_73:=LLV(LOW,30);

X_74:=HHV(X_72,30);

X_75:=IF(MA(CLOSE,58),1,0);

X_76:=EMA(IF(LOW<=X_73,(X_72+X_40*2)/2,0),3)/618*X_75;

X_77:=MA(CLOSE,5);

X_78:=MA(CLOSE,10);

X_79:=MA(CLOSE,20);

X_80:=MA(CLOSE,30);

X_81:=(X_77+X_78+X_79+X_80)/4;

X_82:=(X_81-REF(X_81,5))/REF(X_81,5)*1500;

X_83:=(X_81-REF(X_81,5))/REF(X_81,5)*1500;

X_84:=EMA(X_82,8);

X_85:=TROUGHBARS(3,15,1)<10;

X_86:=PEAKBARS(3,15,1)<10;

X_87:=IF(X_85=1,50,0);

X_88:=IF(X_86=1,50,0);

X_89:=IF(X_87=50,50,0);

X_90:=IF(X_88=50,100,0);

X_91:=IF(X_89>REF(X_89,1),6,0);

X_92:=IF(X_90>REF(X_90,1),0,6);

X_93:=BARSLAST(BARSLAST(X_91)>0);

X_94:=X_42+X_44+X_46+X_48;

X_95:=X_43+X_45+X_47+X_49;

X_96:=IF(BARSLAST(X_92=0)>BARSLAST(X_91=6),BARSLAST(X_92=0)+1,0);

X_97:=IF(BARSLAST(X_95>0)>BARSLAST(X_94>0),BARSLAST(X_95>0)+1,0);

X_98:=短线>中线>REF(短线>中线,1) AND X_96>0 AND X_97>0 AND X_21>REF(X_21,1);

DRAWICON(ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3),LOW*0.98,1);

DRAWICON(ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3),HIGH*1.01,2);

月±%:(CLOSE/REF(CLOSE,22)-1)*100,NODRAW,COLORYELLOW;

年±%:(CLOSE/REF(CLOSE,240)-1)*100,NODRAW,COLORYELLOW;

X_99:=MA(CLOSE,5);

X_100:=MA(CLOSE,24);

X_101:=REF(HIGH,X_14)=HHV(HIGH,2*X_14+1);

X_102:=FILTER(X_101,X_14);

X_103:=BACKSET(X_102,X_14+1);

X_104:=FILTER(X_103,X_14);

X_105:=REF(LOW,X_14)=LLV(LOW,2*X_14+1);

X_106:=FILTER(X_105,X_14);

X_107:=BACKSET(X_106,X_14+1);

X_108:=FILTER(X_107,X_14);

X_109:=(REF(LLV(LOW,2*X_14),1)+REF(HHV(HIGH,2*X_14),1))/2;

X_110:=(HIGH+LOW)/2;

X_111:=X_104 AND NOT(X_108 AND X_109>=X_110) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;

X_112:=X_108 AND NOT(X_104 AND X_109<X_110);

X_113:=X_104 AND NOT(X_108 AND X_109>=X_110);

X_114:=REF(BARSLAST(X_111),1)+1;

X_115:=BACKSET(X_111 AND COUNT(X_112,X_114)>0,LLVBARS(IF(X_112,LOW,10000),X_114));

X_116:=X_115>REF(X_115,1);

X_117:=BACKSET(X_116,2);

X_118:=X_117>REF(X_117,1);

X_119:=X_118 OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;

X_120:=REF(BARSLAST(X_119),1)+1;

X_121:=BACKSET(X_119 AND COUNT(X_113,X_120)>0,HHVBARS(IF(X_113,HIGH,0),X_120));

X_122:=X_121>REF(X_121,1);

X_123:=BACKSET(X_122,2);

X_124:=X_123>REF(X_123,1);

X_125:=BACKSET(ISLASTBAR,BARSLAST(X_124)+1);

X_126:=X_125>REF(X_125,1);

X_127:=BACKSET(ISLASTBAR,BARSLAST(X_118)+1);

X_128:=X_127>REF(X_127,1);

X_129:=BACKSET(X_126,REF(BARSLAST(X_124),1)+2);

X_130:=X_129>REF(X_129,1);

X_131:=BACKSET(X_128,REF(BARSLAST(X_118),1)+2);

X_132:=X_131>REF(X_131,1);

X_133:=DRAWLINE(X_130,HIGH,X_126,HIGH,1);

 

 

副图

中点:(H+L)/2,NODRAW;{御览图}

 

OK1:=BARSLAST(L=LLV(L,360))+1;

OK2:=REF(L,OK1);

日360最低:=IF(CURRBARSCOUNT<=CONST(OK1+1),CONST(IF(OK1,OK2,OK2)),DRAWNULL)COLORGREEN;

OK6:=IF(CURRBARSCOUNT<=CONST(OK1),CONST(IF(OK1,OK1,OK1)),DRAWNULL);

 

月开:=O#MONTH;

月高:H#MONTH,NODRAW,COLORRED;

月中:(H#MONTH+L#MONTH)/2,NODRAW,COLORYELLOW;

月低:L#MONTH,NODRAW,COLORGREEN;

月收:=C#MONTH;

STICKLINE(OK6&&月收>=月开,月高,月低,3.2,-1),COLORRED;

STICKLINE(OK6&&月收<=月开,月高,月低,3.2,-1),COLORCYAN;

 

周开:=O#WEEK;

周高:H#WEEK,NODRAW,COLORRED;

周中:(H#WEEK+L#WEEK)/2,NODRAW,COLORYELLOW;

周低:L#WEEK,NODRAW,COLORGREEN;

周收:=C#WEEK;

STICKLINE(OK6&&周收>=周开,周高,周低,4.1,0),COLORFF0098;{COLORFF0098}

STICKLINE(OK6&&周收<=周开,周高,周低,4.1,0),COLOR006000;{COLOR006000}

DRAWKLINE(H,O,L,C);{K线}

STICKLINE(O>C,C,O,3,1),COLOR00CC00;

O5:=OK6&&O<C;

STICKLINE(O5,C,O,3.03,0),COLOR450099;{红}

STICKLINE(O5,C,O,2.5,0),COLOR4500AA;

STICKLINE(O5,C,O,2,0),COLOR4500BB;

STICKLINE(O5,C,O,1.5,0),COLOR4500CC;

STICKLINE(O5,C,O,1,0),COLOR4500DD;

STICKLINE(O5,C,O,0.5,0),COLOR4500EE;

STICKLINE(O5,C,O,0.1,0),COLOR4500FF;

O2:=OK6&&O>C;

STICKLINE(O2,C,O,3.03,0),COLOR009900;{绿}

STICKLINE(O2,C,O,2.5,0),COLOR00AA00;

STICKLINE(O2,C,O,2,0),COLOR00BB00;

STICKLINE(O2,C,O,1.5,0),COLOR00CC00;

STICKLINE(O2,C,O,1,0),COLOR00DD00;

STICKLINE(O2,C,O,0.5,0),COLOR00EE00;

STICKLINE(O2,C,O,0.1,0),COLOR00FF00;

STICKLINE(中点,中点,中点,0.01,1),COLOR00FFFF;

HHH:=STICKLINE(周中,周中,周中,4.1,0),COLORCYAN;

Q1:=STICKLINE(月中,月中,月中,4.1,-1),COLORYELLOW;

STICKLINE(OK6&&周中,周中,周中,4.1,-1),COLORYELLOW;

 

K8:=BARSLAST(EMA(C,5)>=EMA(C,20));

K9:=BARSLAST(EMA(C,5)<=EMA(C,20));

K110:=IF(EMA(C,5)>=EMA(C,20),(EMA(C,5)+EMA(C,20))/2,DRAWNULL);

K115:=IF(EMA(C,5)>=EMA(C,20),EMA(C,5),DRAWNULL);

K120:=IF(EMA(C,5)>=EMA(C,20),EMA(C,20),DRAWNULL);

线5:IF(CURRBARSCOUNT<CONST(K9+2),K115,DRAWNULL)COLORYELLOW;

线10:IF(CURRBARSCOUNT<CONST(K9+2),K110,DRAWNULL),COLORYELLOW;

线20:IF(CURRBARSCOUNT<CONST(K9+2),K120,DRAWNULL),COLORYELLOW;

 

立春:=FILTER(MONTH=2 AND (DAY=3 OR DAY=5 ),2);

雨水:=FILTER(MONTH=2 AND (DAY=18 OR DAY=20),2);

惊蛰:=FILTER(MONTH=3 AND (DAY=5 OR DAY=7 ),2);

春分:=FILTER(MONTH=3 AND (DAY=20 OR DAY=22),2);

清明:=FILTER(MONTH=4 AND (DAY=3 OR DAY=6 ),2);

谷雨:=FILTER(MONTH=4 AND (DAY=19 OR DAY=21),2);

立夏:=FILTER(MONTH=5 AND (DAY=6 OR DAY=8 ),2);

小满:=FILTER(MONTH=5 AND (DAY=20 OR DAY=22),2);

芒种:=FILTER(MONTH=6 AND (DAY=5 OR DAY=7 ),2);

夏至:=FILTER(MONTH=6 AND (DAY=20 OR DAY=22),2);

小暑:=FILTER(MONTH=7 AND (DAY=6 OR DAY=8 ),2);

大暑:=FILTER(MONTH=7 AND (DAY=22 OR DAY=24),2);

立秋:=FILTER(MONTH=8 AND (DAY=7 OR DAY=9 ),2);

处暑:=FILTER(MONTH=8 AND (DAY=22 OR DAY=24),2);

白露:=FILTER(MONTH=9 AND (DAY=7 OR DAY=9 ),2);

秋分:=FILTER(MONTH=9 AND (DAY=22 OR DAY=24),2);

寒露:=FILTER(MONTH=10 AND (DAY=7 OR DAY=9 ),2);

霜降:=FILTER(MONTH=10 AND (DAY=22 OR DAY=24),2);

立冬:=FILTER(MONTH=11 AND (DAY=7 OR DAY=9 ),2);

小雪:=FILTER(MONTH=11 AND (DAY=22 OR DAY=24),2);

大雪:=FILTER(MONTH=12 AND (DAY=6 OR DAY=8 ),2);

冬至:=FILTER(MONTH=12 AND (DAY=21 OR DAY=23),2);

小寒:=FILTER(MONTH=1 AND (DAY=5 OR DAY=7 ),2);

大寒:=FILTER(MONTH=1 AND (DAY=19 OR DAY=21),2);

OK7:=IF(CURRBARSCOUNT<=CONST(4),CONST(IF(4,4,4)),DRAWNULL);

DRAWTEXT(OK7&&立春,L/1.003,’立’);

DRAWTEXT(OK7&&立春,L/1.008,’春’);

DRAWTEXT(OK7&&雨水,L/1.003,’雨’);

DRAWTEXT(OK7&&雨水,L/1.008,’水’);

DRAWTEXT(OK7&&惊蛰,L/1.003,’惊’);

DRAWTEXT(OK7&&惊蛰,L/1.008,’蛰’);

DRAWTEXT(OK7&&春分,L/1.003,’春’);

DRAWTEXT(OK7&&春分,L/1.008,’分’);

DRAWTEXT(OK7&&清明,L/1.003,’清’);

DRAWTEXT(OK7&&清明,L/1.008,’明’);

DRAWTEXT(OK7&&谷雨,L/1.003,’谷’);

DRAWTEXT(OK7&&谷雨,L/1.008,’雨’);

DRAWTEXT(OK7&&立夏,L/1.003,’立’);

DRAWTEXT(OK7&&立夏,L/1.008,’夏’);

DRAWTEXT(OK7&&小满,L/1.003,’小’);

DRAWTEXT(OK7&&小满,L/1.008,’满’);

DRAWTEXT(OK7&&芒种,L/1.003,’芒’);

DRAWTEXT(OK7&&芒种,L/1.008,’种’);

DRAWTEXT(OK7&&夏至,L/1.003,’夏’);

DRAWTEXT(OK7&&夏至,L/1.008,’至’);

DRAWTEXT(OK7&&小暑,L/1.003,’小’);

DRAWTEXT(OK7&&小暑,L/1.008,’暑’);

DRAWTEXT(OK7&&大暑,L/1.003,’大’);

DRAWTEXT(OK7&&大暑,L/1.008,’暑’);

DRAWTEXT(OK7&&立秋,L/1.003,’立’);

DRAWTEXT(OK7&&立秋,L/1.008,’秋’);

DRAWTEXT(OK7&&处暑,L/1.003,’处’);

DRAWTEXT(OK7&&处暑,L/1.008,’暑’);

DRAWTEXT(OK7&&白露,L/1.003,’白’);

DRAWTEXT(OK7&&白露,L/1.008,’露’);

DRAWTEXT(OK7&&秋分,L/1.003,’秋’);

DRAWTEXT(OK7&&秋分,L/1.008,’分’);

DRAWTEXT(OK7&&寒露,L/1.003,’寒’);

DRAWTEXT(OK7&&寒露,L/1.008,’露’);

DRAWTEXT(OK7&&霜降,L/1.003,’霜’);

DRAWTEXT(OK7&&霜降,L/1.008,’降’);

DRAWTEXT(OK7&&立冬,L/1.003,’立’);

DRAWTEXT(OK7&&立冬,L/1.008,’冬’);

DRAWTEXT(OK7&&小雪,L/1.003,’小’);

DRAWTEXT(OK7&&小雪,L/1.008,’雪’);

DRAWTEXT(OK7&&大雪,L/1.003,’大’);

DRAWTEXT(OK7&&大雪,L/1.008,’雪’);

DRAWTEXT(OK7&&冬至,L/1.003,’冬’);

DRAWTEXT(OK7&&冬至,L/1.008,’至’);

DRAWTEXT(OK7&&小寒,L/1.003,’小’);

DRAWTEXT(OK7&&小寒,L/1.008,’寒’);

DRAWTEXT(OK7&&大寒,L/1.003,’大’);

DRAWTEXT(OK7&&大寒,L/1.008,’寒’);

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 套装公式 通达信 股海垂钓 主图 股海垂钓副图 指标 https://www.694.cn/ziliaoxiazai/tongdaxin/4068.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务