通达信 九重天外 超级主升 主图副图指标

2024-04-09 0 139

通达信 九重天外 超级主升 主图副图指标

主图源码

参数

N9  1   500   18

 

MA1:=MA(C,20);

JX1:=IF(CAPITAL=0,IF(PERIOD=7,1.11,IF(PERIOD=8,1.30,1.06)),IF(PERIOD=7,1.20,IF(PERIOD=8,1.38,1.14)));

JX2:=IF(CAPITAL=0,IF(PERIOD=7,1.09,IF(PERIOD=8,1.25,1.05)),IF(PERIOD=7,1.15,IF(PERIOD=8,1.33,1.11)));

JX3:=IF(CAPITAL=0,IF(PERIOD=7,0.985,IF(PERIOD=8,1.01,0.985)),IF(PERIOD=7,0.99,1.01));

JX4:=IF(CAPITAL=0,IF(PERIOD=7,0.88,IF(PERIOD=8,0.75,0.93)),IF(PERIOD=7,0.85,IF(PERIOD=8,0.75,0.90)));

JX5:=IF(CAPITAL=0,IF(PERIOD=7,0.85,IF(PERIOD=8,0.70,0.92)),IF(PERIOD=7,0.80,IF(PERIOD=8,0.70,0.86)));

疯狂:MA1*JX1,COLOR0000DD,LINETHICK2,NODRAW;

超买:MA1*JX2,COLORDD00DD,LINETHICK2,NODRAW;

轴心:MA1*JX3,COLOR0000FF;

IF(轴心<REF(轴心,1),轴心,DRAWNULL),COLOR00FF00;

超卖:MA1*JX4,COLORDD00DD,LINETHICK2,NODRAW;

恐慌:MA1*JX5,COLOREEDD00,LINETHICK2,NODRAW;

DRAWBAND(疯狂,RGB(66,66,66),超买,DRAWNULL);

DRAWBAND(超卖,RGB(80,00,00),恐慌,DRAWNULL);

DRAWKLINE(H,O,L,C);

STICKLINE(C>=REF(C,1),H,L,0,1),COLOR0000FF;

STICKLINE(C>=REF(C,1),C,O,2.8,0),COLOR0000BB;

STICKLINE(C>=REF(C,1),C,O,2,0),COLOR0000DD;

STICKLINE(C>=REF(C,1),C,O,1.2,0),COLOR0000EE;

STICKLINE(C>=REF(C,1),C,O,0.4,0),COLOR0000FF;

STICKLINE(C<REF(C,1),H,L,0,1),COLORFFFF00;

STICKLINE(C<REF(C,1),C,O,2.8,0),COLOR999900;

STICKLINE(C<REF(C,1),C,O,2,0),COLORBBBB00;

STICKLINE(C<REF(C,1),C,O,1.2,0),COLORDDDD00;

STICKLINE(C<REF(C,1),C,O,0.4,0),COLORFFFF00;

STICKLINE(C<=O,H,L,0,0),COLORWHITE;

K7:=BARSLAST(CURRBARSCOUNT=N9);

GD:=CONST(IF(ISLASTBAR=1,HHV(H,K7),0));

DD:=CONST(IF(ISLASTBAR=1,LLV(L,K7),0));

ZW:=(GD+DD)/2;JC:=(GD-DD);

DRAWTEXT(CURRBARSCOUNT=N9,ZW-JC/1.3,’★超级主升!★’),COLOR00FFFF;

 

上涨家数:INDEXADV,NODRAW,COLORRED;

下跌家数:INDEXDEC,NODRAW,COLORGREEN;

Z1:=STRCAT(HYBLOCK,’ ‘);

Z2:=STRCAT(Z1,DYBLOCK);

Z3:=STRCAT(Z2,’ ‘);

DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLOR00FFFF;

DRAWTEXT_FIX(1,0.00,0.05,0,’主题投资:’)COLOR0000FF;

DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,1))COLORFFFFFF;

DRAWTEXT_FIX(1,0.00,0.10,0,’主营业务:’)COLORFFFFFF;

DRAWTEXT_FIX(1,0.06,0.10,0,EXTERNSTR(0,2))COLORFFFFFF;

 

总股本:=STRCAT(STRCAT(‘总股本: ‘,CON2STR(TOTALCAPITAL/1000000,3)),’亿股’);

流通盘:=STRCAT(STRCAT(‘流通盘: ‘,CON2STR(CAPITAL/1000000,3)),’亿股’);

每股收益:=STRCAT(STRCAT(‘每股收益: ‘,CON2STR(FINANCE(29)/FINANCE(1),2)),’元’);

每股未分配:=STRCAT(STRCAT(‘每股未分配: ‘,CON2STR(FINANCE(32),2)),’元’);

每股公积金:=STRCAT(STRCAT(‘每股公积金: ‘,CON2STR(FINANCE(18),2)),’元’);

每股净资产:=STRCAT(STRCAT(‘每股净资产: ‘,CON2STR(FINANCE(34),2)),’元’);

总市值:=STRCAT(STRCAT(‘总市值: ‘,CON2STR(FINANCE(1)*C/100000000,3)),’亿元’);

市值:=STRCAT(STRCAT(‘流通值: ‘,CON2STR((CAPITAL/1000000)*C,3)),’亿元’);

SHI:INTPART(DATE+19000000),NODRAW;

上市日期:=STRCAT(‘ 上市日:’,CON2STR(SHI,0));

收入同比增长:=STRCAT(STRCAT(‘收入同比增长: ‘,CON2STR(FINANCE(44),2)),’%’);

市盈率:=STRCAT(‘市盈率: ‘,CON2STR(DYNAINFO(39),2));

主营毛利润率:=STRCAT(STRCAT(‘主营毛利润率: ‘,CON2STR((FINANCE(20)-            FINANCE(21))/FINANCE(20)*100,2)),’%’);

主营净利润率:=STRCAT(STRCAT(‘主营净利润率: ‘,CON2STR(FINANCE(30)/FINANCE(20)*100,2)),’%’);

主营利润率:=STRCAT(‘ 主营利润率 ‘,CON2STR(FINANCE(23)/FINANCE(20)*100,2));

净利同比增长:=STRCAT(STRCAT(‘净利同比增长: ‘,CON2STR(FINANCE(43),2)),’%’);

{ DRAWTEXT_FIX(ISLASTBAR,0.002,0,0,’上市日期:’),COLORMAGENTA;

DRAWNUMBER_FIX(ISLASTBAR,0.1,0,0,SHI),COLORMAGENTA;

}

 

DRAWTEXT_FIX(ISLASTBAR,0.002,0.15,0,总股本),COLORWHITE;

DRAWTEXT_FIX(ISLASTBAR,0.127,0.15,0,收入同比增长),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.257,0.15,0,每股收益),COLORWHITE;

 

DRAWTEXT_FIX(ISLASTBAR,0.002,0.20,0,流通盘),COLORWHITE;

DRAWTEXT_FIX(ISLASTBAR,0.127,0.20,0,主营毛利润率),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.257,0.20,0,每股净资产),COLORWHITE;

 

DRAWTEXT_FIX(ISLASTBAR,0.002,0.25,0,总市值),COLORWHITE;

DRAWTEXT_FIX(ISLASTBAR,0.127,0.25,0,主营净利润率),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.257,0.25,0,每股未分配),COLORWHITE;

 

DRAWTEXT_FIX(ISLASTBAR,0.002,0.30,0,市值),COLORWHITE;

DRAWTEXT_FIX(ISLASTBAR,0.127,0.30,0,净利同比增长),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.257,0.30,0,每股公积金),COLORWHITE;

 

DRAWTEXT_FIX(ISLASTBAR,0.002,0.35,0,市盈率),COLORWHITE;

 

HSL:=100*VOL/(FINANCE(7)/100);

换手:=STRCAT(STRCAT(‘换手: ‘,CON2STR(HSL,2)),’%’);

DRAWTEXT_FIX(ISLASTBAR,0.127,0.35,0,换手),COLORMAGENTA;

CJ:=DYNAINFO(10)/100000000;

成交:=STRCAT(STRCAT(‘成交: ‘,CON2STR(CJ,2)),’亿’);

DRAWTEXT_FIX(ISLASTBAR,0.257,0.35,0,成交),COLORMAGENTA;

 

 

 

副图

DRAWGBK(O>C,RGB(48,41,124),RGB(0,0,0),0,’1′,0);

 

VAR11:=3*SMA((C-LLV(L,180))/(HHV(H,180)-LLV(L,180))*100,5,1)

-2*SMA(SMA((C-LLV(L,180))/(HHV(H,180)-LLV(L,180))*100,180,1),15,1);

超级主升:EMA(VAR11,5), LINETHICK2,COLOR6600FF;

DRAWBAND(超级主升,255,100,0);

100,LINETHICK2 ,COLOR999999;

STICKLINE(CROSS(超级主升,100),100,120,3,0),COLORLIRED;

DRAWTEXT(CROSS(超级主升,100),100,’超级主升’),COLORYELLOW;

 

VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);

VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);

XG:=(FILTER((VAR4AA>90),45)),COLORYELLOW;

STICKLINE(XG,150,0,4,0),COLOR000099;

STICKLINE(XG,150,0,2,0),COLOR0000BB;

STICKLINE(XG,150,0,1,0),COLOR0000DD;

STICKLINE(XG,150,0,0.9,0),COLOR0000FF;

DRAWTEXT(XG>0,130,’神量‘),COLOR00C5FF;

DRAWTEXT_FIX(1,0,100,0,’★出现神量后市看涨‘),COLORYELLOW;

 

MA5:=MA(CLOSE,5);

MA15:=MA(CLOSE,15);

MA30:=MA(CLOSE,30);

MA60:=MA(CLOSE,60);

离散量30:=100*(MA5-(MA15+MA30)/2)/MA30+50,COLOR00FFFF;

离散量60:=100*(MA5-(MA15+MA30+MA60)/3)/MA60+50,COLORFFAA00;

粘合K:=-3*(离散量30-离散量60)+50,COLORRED,LINETHICK2;

粘合D:=EMA(粘合K,3);

主升:BARSLAST(CROSS(粘合K,粘合D))*(粘合K>粘合D),COLORYELLOW;

{STICKLINE(粘合K>108,105,粘合K,5,1),COLORGREEN;}

STICKLINE(主升,主升,主升+2,4,1),COLORMAGENTA;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 套装公式 通达信 九重天外 超级主升 主图副图指标 https://www.694.cn/ziliaoxiazai/tongdaxin/4071.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务