通达信 三色天龙 主图 伏击启动 双副图 指标

2024-04-09 0 428

通达信 三色天龙 主图 伏击启动 双副图 指标

主图源码

 

VARQ0:=1.04;

MA5:MA(CLOSE,5),COLORWHITE;

MA10:MA(CLOSE,10),颜色黄色;

MA20:MA(CLOSE,20),COLORMAGENTA;

MA30:=MA(CLOSE,30),COLORMAGENTA;

MA60:MA(CLOSE,60),COLORGREEN;

MA120:MA(CLOSE,120),COLORAAAAAA;

MA250:=MA(CLOSE,250),COLORAAAAAA;

天龙看盘:(COST(99)+COST(93)+COST(85))/3,LINETHICK1;

VARQ5:=MA(CLOSE,13);

VARQ6:=MA(CLOSE,34);

VARQ7:=MA(CLOSE,55);

画带(MA10,RGB(180,50,0),MA20,RGB(0,50,100));

画带(MA5,RGB(200,120,0),MA10,RGB(0,100,150));

NOTEXTMA120:MA120,COLORAAAAAA;

画线(HIGH,OPEN,LOW,CLOSE);

STICKLINE(收盘价 > 1.097 * REF(CLOSE,1),CLOSE,OPEN,2.8,0),COLORRED;

STICKLINE(收盘价 < 0.907 * REF(CLOSE,1),CLOSE,OPEN,2.8,0),COLORGREEN;

VARQ15:=打开< VARQ5 并关闭> VARQ5;

VARQ16:=打开< VARQ6 并关闭> VARQ6;

VARQ17:=< VARQ7 打开并关闭 VARQ7 >;

VARQ18:=关闭/打开 >= VARQ0;

VARQ19:=VOL > HHV(HIGH,10);

VARQ20:=VARQ5 >= REF(VARQ5,1);

VARQ21:=VARQ15 和 VARQ16 和 VARQ17 和 VARQ18 和 VARQ19 和 VARQ20;

DRAWICON(VARQ21,低 – 低 * 0.05,1);

DRAWICON(VARQ21,低 – 低 * 0.1,7);

VARQ24:=BARSLAST(VARQ21 > 0) < 25 并收< MA10;

VARQ25:=过滤器(VARQ24,25 – BARSLAST(VARQ21 > 0));

DRAWICON(VARQ25,高 + 高 * 0.01,2);

VARQ27:=(开盘+收盘)/ 2;

粘线(VARQ21 > 0,VARQ27,VARQ27,20,0),黄色;

VARQ29:=CLOSE = HHV(CLOSE,13);

VARQ30:=BARSLAST(FILTER(CROSS(0.8,VARQ29),2)) + 1;

平台高点:REF(CLOSE,VARQ30),NODRAW,COLOR8800FF;

STICKLINE(VARQ30 <= 13,平台高点,平台高点,1,0),COLOR8800FF;

{WWW.GUPANG.COM 股旁网}

VARQ33:=CLOSE = LLV(CLOSE,13);

VARQ34:=BARSLAST(FILTER(CROSS(0.8,VARQ33),2)) + 1;

平台低点:REF(CLOSE,VARQ34),NODRAW,COLORFF8800;

STICKLINE(VARQ34 <= 13,平台低点,平台低点,1,0),COLORFF8800;

VARQ37:=IF(CLOSE / REF(CLOSE,1) >= 1.099,1,0);

粘线(VARQ37 > 0,LOW,HIGH,0,0),COLORRED;

STICKLINE(VARQ37 > 0,OPEN,CLOSE,3,0),COLOR0022CC;

STICKLINE(VARQ37 > 0,OPEN,CLOSE,2,0),COLOR0033EE;

STICKLINE(VARQ37 > 0,OPEN,CLOSE,1,0),COLOR4444FF;

涨停:=IF(REF(C,1)*1.095-C<0.01 ,1,0);

STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;

STICKLINE(涨停,OPEN,CLOSE,3,0),COLORYELLOW;

ZT:=C/REF(C,1)>1.099 和 C=H;

A1:=MA5>L和MA5<O;

A2:=MA60>L 和 MA60<O;

A3:=MA120>L 和 MA120<O;

A4:=A1 或 A2 或 A3;

昨日涨幅:=(REF(C,1)/REF(C,(2)))<1.09;

主升浪:=ZT AND MA5>MA120 AND C>MA5 AND 昨日涨幅,COLORCYAN;

DRAWTEXT(主升浪,(LOW * 0.97),’←主升浪’),COLORRED;

均线金叉:=ZT AND (CROSS(MA5,MA60) OR CROSS(MA5,MA120)) AND 昨日涨幅,COLORRED;

DRAWTEXT(均线金叉,(LOW * 0.97),’←均线金叉’),COLOR00FFFF;

击穿均线:=ZT AND A4 AND 昨日涨幅,COLORMAGENTA;

DRAWTEXT(击穿均线,(LOW * 0.97),’←击穿均线’),COLORRED;

海底捞月:=ZT AND C<MA5 AND 昨日涨幅,COLORWHITE;

DRAWTEXT(海底捞月,(LOW * 0.93),’←海底捞月’),COLORBROWN;

鱼跃龙门:=CROSS(C,MA120) AND ZT and MA5>MA60 AND (CROSS(MA5,MA60) OR CROSS(MA5,MA120)) AND 昨日涨幅,COLORBROWN;

DRAWTEXT(鱼跃龙门,(LOW * 0.97),’←鱼跃龙门’),COLORMAGENTA;

突破半年线:=CROSS(C,MA120) AND ZT AND 昨日涨幅,COLORYELLOW;

DRAWTEXT(突破半年线,(LOW * 0.97),’←突破半年线’),COLORRED;

一阳洞穿:=REF(C,1)<MA5 AND REF(C,1)<MA20 AND REF(C,1)<MA30 AND REF(C,1)<MA60 AND

C>MA5 和 C>MA20 和 C>MA30 和 C>MA60 和 ZT 和 昨日涨幅,彩色;

DRAWTEXT(一阳洞穿,(LOW * 0.97),’←一阳洞穿’),COLORLIMAGENTA;

旱地拔葱:=ZT AND MA120>MA5 AND MA5>MA60 AND OPEN>MA120 AND CLOSE>MA120 AND 昨日涨幅;

DRAWTEXT(旱地拔葱,(LOW * 0.97),’←旱地拔葱’),COLORLIRED;

超跌反攻:=ZT AND C> MA5 AND MA120/MA5>1.15 AND 昨日涨幅,COLORLIMAGENTA;

DRAWTEXT(超跌反攻,(LOW * 0.97),’←超跌反攻’),COLOR00FFFF;

反转:=ZT AND REF(MA5,1)/REF(C,1)>1 AND C/MA5>1 AND 昨日涨幅,COLORBLUE;

DRAWTEXT(反转,(LOW * 0.93),’←反转’),COLOR00FFFF;

AA:= REF(EVERY((C/REF(C,1)>1.099 AND O=C AND H=L),3),1);

BB:=O/REF(C,1)>1.099 AND H=O AND L<O ;

CC:=BARSCOUNT(C)<30;

打开一字:=AA AND BB AND CC;

DRAWTEXT(打开一字,(LOW * 0.93),’←打开一字’),COLORRED;

A5:=HHV(H,30);

A6:=CROSS(C,REF(A5,1));

DDT:=MA5>MA10 AND MA10>MA30 AND MA30>MA60;

CDT:=MA30>MA60 AND MA60>MA120 AND MA120>MA250;

PC:=NOT(NAMELIKE(‘S’) OR NAMELIKE(‘*S’)) AND DYNAINFO(17)>=2 AND CAPITAL<=8000000;{非ST}

T1:=MA30>MA5 AND MA30>MA10 AND MA60>MA5 AND MA60>MA10;

T2:=CROSS(C,MA30) AND CROSS(C,MA60);

T3:=MA120>MA60 AND MA120>MA30 AND MA120>MA10 AND MA120>MA5;

T4:=MA250>MA120 AND MA250>MA60 AND MA250>MA30 AND MA250>MA10 AND MA250>MA5;

TP1:=T1 AND T2 AND PC AND C>MA250 AND C>MA120;

TP2:=CDT AND PC AND CROSS(C,MA5) AND CROSS(C,MA10) AND C>MA30;

TP3:=T3 AND CROSS(C,MA120) AND PC OR T4 AND CROSS(C,MA250) AND PC;

TP4:=DDT AND CDT AND PC AND A2;

ZF:=C>O AND C/REF(C,1)>=1.05;

TP5:=EXIST(CROSS(MA10,MA5),10) AND CROSS(C,MA5) AND CROSS(C,MA10) AND ZF;

短线起爆:=TP1 AND ZF OR TP2 AND ZF OR TP3 AND ZF OR TP5 AND CDT;

DRAWTEXT(短线起爆,(LOW * 0.97),’←短线起爆’),COLOR00FFFF;

跳空高开:=ZT AND OPEN>MA5 AND LOW/REF(CLOSE,1)>1 AND OPEN/REF(CLOSE,1)>1 AND O<C AND 昨日涨幅;

DRAWTEXT(跳空高开,(LOW * 0.93),’←跳空高开’),COLOR8800FF;

{DRAWGBK(跳空高开,RGB(0,0,0),RGB(0,0,0),0,’AS6′,0);}

DIFF:=EMA(CLOSE,3)-EMA(CLOSE,8);

DEA:=EMA(DIFF,5);

MACD := 2*(DIFF-DEA);

X1:=EMA(DIFF,5)*5;

X2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*5;

A7:=CROSS(X2,X1) AND X1>=0;

DRAWICON(A7,L*0.96,13);

DRAWTEXT(A7,(LOW * 0.90),’←回调买’),COLORYELLOW;

STICKLINE((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,2.8,0),COLORYELLOW;

STICKLINE((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,2.8,0),COLOR007700;

LC:=REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

DRAWTEXT(CROSS(90,RSI) , HIGH*0.98,’←逢高出局’),COLOR00FF00 ;

 

副图1

参数

N  1    100    5

A:=C>=REF(C,1)*1.09;

B:=BARSSINCEN(A,N);

XG:=REF(VOL,B+1)>REF(VOL,B) AND REF(VOL,B-1)>REF(VOL,B) AND L>=0.96*REF(C,B+1) AND L<=1.04*REF(C,B+1) AND EXIST(A,N);

STICKLINE(XG, 0,0.3, 0.3,0),COLORMAGENTA;

STICKLINE(XG, 0,0.05, 3,0),COLORMAGENTA;

STICKLINE(XG, 0.05,0.1, 2,0),COLORGREEN;

DRAWICON(XG,0.35,17);

DRAWTEXT(XG,0.4,’MAI’),COLORMAGENTA;

 

 

副图2

 

DRAWTEXT_FIX(1,0.15,0.85,0,’微信’),COLORYELLOW;

A30:=MA(CLOSE,7);

A60:=MA(C,13);

A120:=MA(C,25);

A250:=MA(C,60);

MAXF:=MAX(MAX(MAX(A30,A60),A120),A250);

MINF:=MIN(MIN(MIN(A30,A60),A120),A250);

SXPC:=(MAXF-MINF)/MINF*100<=17;

 

B20:=MA(C,30);

B60:=MA(C,60);

B89:=MA(C,89);

B120:=MA(C,120);

MXF:=MAX(MAX(MAX(B20,B60),B89),B120);

MNF:=MIN(MIN(MIN(B20,B60),B89),B120);

PCSX:=(MXF-MNF)/MNF*100<=16;

XXQ:=ABS(MA(C,20)/MA(C,60)-1)<0.18;

X1:=ABS(MA(C,10)/MA(C,20)-1)<0.08;

X2:=ABS(MA(C,5)/MA(C,10)-1)<0.08;

X3:=ABS(MA(C,5)/MA(C,20)-1)<0.15;

SKPC:=X1 AND X2 AND X3;

{均线粘合}

ZTL:=C>REF(C,1)*1.09 AND C=H;

ZTTJ:=COUNT(REF(ZTL,2),88)>=1 ;

{ 涨停条件 }

M5:=MA(CLOSE,5);

BB10:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

M21:=MA(CLOSE,20);

M120:=MA(CLOSE,120);

M250:=MA(C,250);

JXDT:=M5>=MA(C,60) AND M5>M21 AND BB10>=M21 AND BB10>=A250;

JXDT1:=M21>M120 AND BB10>M250 AND A250>M120 AND M21>M250;

LJXS:=COUNT(NOT(REF(ZTL,1)),3)=3 AND REF(V,1)<=REF(V,2)*1.4;

SGCX:=LJXS AND REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.026 AND (OPEN<=REF(CLOSE,1) OR BETWEEN(O,REF(CLOSE,1)-0.3,REF(CLOSE,1)+0.3)) AND CLOSE>REF(CLOSE,1);

 

DFQ:=-(C-REF(C,1))/REF(C,1)*100;

CY1:=O<REF(L,1) AND REF(C<O,1) AND BETWEEN(C/O,0.99,1.02) AND C<REF(C,1) AND (DFQ>1.5 OR (C>REF(C,1) AND C<O));

CY2:=(O<REF(L,1) AND REF(C<O,1) AND BETWEEN(C/O,0.99,1.02) AND C<REF(C,1) AND ABS(OPEN-CLOSE)/CLOSE<0.04 AND CLOSE<MA(CLOSE,5)) OR (O<REF(L,1) AND REF(C<O,1) AND BETWEEN(C/O,0.99,1.02) AND C<REF(C,1));

CRX:=(REF(CY1,1) OR REF(CY2,1)) AND C/REF(C,1)>=1.02;

ZTT:=C>REF(C,1)*1.09 AND C=H;

ZTLL:=COUNT(REF(ZTT,3),89)>=1 ;

FL:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));

FS:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);

SBB:=IF(MA(CLOSE,17)<FS,FS,MA(CLOSE,17));

NX:=EMA(C,189);

NXX:=EMA(COST(27),120);

XBB:=EMA((NX-(EMA(C,3)-NX)),5);

DIF:=EMA(CLOSE,12) – EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=2*(DIF-DEA);

BLX:=(SBB>=XBB OR CROSS(SBB,XBB)) AND C>XBB AND C>NXX;

SSMACD:=DIF>=0 和 DEA>=0;

GO:=ZTLL AND BLX AND SSMACD AND NOT(REF(ZTT,1));

A7:=C-REF(C,1);

A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);

MM1:=LLV(A8,2)=LLV(A8,7)和COUNT(A8<0,2)和CROSS(A8,MA(A8,2))和C<MA(C,20);

MM2:=LLV(A8,2)=LLV(A8,7)和COUNT(A8<0,2)和CROSS(A8,MA(A8,2))和C>MA(C,20);

LTPD:=FINANCE(7)/100000000<8.5 和 IF(NAMELIKE(’*’),0,1) 和 IF(NAMELIKE(’S’),0,1) 和 C<28;

LNTJ:=(MA(V,5)>MA(V,20)或MA(V,5)>MA(V,60)或CROSS(MA(V,5),MA(V,60))或CROSS(MA(V,5),MA(V,20)))和C>O和C>MA(C,5);

MM3:=COUNT(MM1=1,4)>0 和 LNTJ 和 (C>MA(C,20) 或 MA(V,5)>REF(MA(V,5),1)) 和 NOT(REF(COUNT(MM1=1,4)>0 和 LNTJ,1));

MM4:=COUNT(MM2,2)>0 和 MA(C,10)>MA(C,20) 和 H>MA(C,10) 和 H>MA(C,5) 和 MA(CLOSE,20)>REF(MA(CLOSE,20),1) 和 NOT(REF(COUNT(MM2,2)>0 和 MA(C,10)>MA(C,20) 和 H>MA(C,10)和H>MA(C,5),1));

BHOK:=(MM3 或 MM4) 和 LTPD 和 GO 和 DYNAINFO(9)>0 和 C>O 和 C>MA(C,120) 和 C>MA(C,250) 和 C>=MA(C,20) 和 MA(C,13)>MA(C,60);

MAK:=MA(CLOSE,7);

MAN:=MA(CLOSE,14);

DTPL:=MA(C,14)>MA(C,14*1.5)和MA(C,14*1.5)>MA(C,14*3)和MA(C,3)>MA(C,14*6);

LXZQ:=计数(C>MA(C,14),7)=7;

ZQSJ:=BARSLAST(LXZQ);

XCD:=十字(MA(C,14),C);

GL:=MA(C,14/2)/MA(C,14*2)>=1.05;

MDX:=(XCD 和 ZQSJ<=3 和 DTPL 和 GL)*14;

DD:=BARSLAST(MDX);

MDYX:=REF(MDX>0,1) 和 C>REF(O,DD) 和 C/REF(C,1)>=1.02;

 

{买点基因}

JYZY:=C>REF(C,1) 和 C<O 和 O/REF(C,1)>1.02 和 C>REF(C,1);

VAR1:=EMA(EMA(CLOSE,9),9);

KPQ:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

VAR2:=100*赢家(收盘价*0.95);

YZKP:=(KPQ>REF(KPQ,1) 和 KPQ>0) 或 (VAR2>50 和 COST(85)<CLOSE 和 KPQ>0);

MV5:=MA(V,5);

MV13:=MA(V,13);

MV60:=MA(V,60);

CJLXT:=((MV5>=MV13 OR CROSS(MV5,MV13)) OR (MV13>=MV60 AND MV5>=MV60)) AND (MV5>=MV60 OR CROSS(MV5,MV60));

TQQ:=H>=SMA(LLV(C,3)*1.1,22,1);

QSH:=SMA(LLV(C,3)*1.1,22,1);

HCH:=COUNT(ABS((QSH-MA(C,60))/MA(C,60))*100<=15,15)>=14和CJLXT;

{涨停基因}

GJTT:=C>MA(C,10)和C>MA(C,20)和C>MA(C,250)和C>MA(C,120);

HC20:=ABS((C-MA(C,20))/MA(C,20))*100<6;

GFG:=M5>=MA(C,10) 和 MA(C,10)>=M21 和 M21>=B60 和 (CROSS(DIF,DEA) 或 DIF>DEA) 和 DIF>=0 和 DEA>=0;

BLY:= C/REF(C,1)>=1.015 AND VOL>=REF(V,1)*1.6 AND C>O 和 V/REF(V,1)<2.5 和 C>=MA(C,20) ;

DLZ:=V<=REF(LLV(V,13),1);

SBL:=REF(VOL,1)/VOL>1.9;

XBY:=BLY 和 GFG 和 SXPC 和 PCSX 和 HCH 和 TQQ 和 (COUNT(REF(SBL,1) 或 REF(DLZ,1),7)>=1);

TJMD:=JXDT 和 JXDT1 和 L<=BB10 和 (SGCX 或 MDYX 或 CRX 或 BHOK 或 XBY) 和 L>A250 和 L>M120 ;

JXJH:=COUNT(HC20,4)>=1 和 COUNT(REF(XXQ,1),30)>=29 和 COUNT(REF(SKPC,1),60)>=54 和 COUNT(REF(SXPC,1),60)>=55 和 HCH 和 TQQ;

XG:=COUNT(NOT(REF(ZTL,2) 和 REF(ZTL,1) 和 ZTL),40)=40 和 JXJH 和 ZTTJ 和 TJMD 和 GJTT 和 YZKP 和 COUNT(REF(ZTL,1),4)=0;

 

粘线(XG,0,XG,3,0),颜色黄色;

粘线(XG,0,XG,1.8,0),COLORFF00FF;

绘制图标(XG,0.5,26);

绘制图标(XG,0.2,26);

绘制图标(XG,0.9,26);

DRAWTEXT(XG,0.2,’ ★ 低位启动‘),COLORFF00FF;

DRAWTEXT(XG,0.5,’ ★ 量价异动‘),COLORYELLOW ;

DRAWTEXT(XG,0.8,’ ★ 题材共振’),COLORRED;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 套装公式 通达信 三色天龙 主图 伏击启动 双副图 指标 https://www.694.cn/ziliaoxiazai/tongdaxin/4077.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务