通达信 主力潜伏 主图 副图 公式

2024-04-09 0 761

通达信 主力潜伏 主图 副图 公式

主图 

参数

买入低位            0        1000       0

买入高位            0          1000      0

自动显示根数     1           1000      1

卖出高位           0        1000        0

卖出低位           0         1000        0

{DRAWTEXT_FIX(1,0.9,0.01,1,’说明:双击鼠标出现十字浮标,移动浮标到选定的高、低位K线位置,在标题栏的“K线根数”处就可看到K线数值,右键点击“两点预测”公式标题,选调整指标参数,在调整窗口栏分别填进要选择买入或卖出的低位、高位的K线数,填好后点关闭窗口即可。’),COLORYELLOW;

{K线根数}

AR1:=BARSCOUNT(C);

AR2:=CONST(AR1);

AR3:=AR2-AR1;

K线根数:AR3+1,NODRAW,COLORYELLOW;

 

{自动显示根数}

DRAWKLINE(H,O,L,C);

A1 := (REF(HIGH,自动显示根数) = HHV(HIGH,(自动显示根数 + 1)));

B1 := FILTER(A1,自动显示根数);

C1 := BACKSET(B1,(自动显示根数 + 1));

D1 := FILTER(C1,自动显示根数);

A2 := (REF(LOW,自动显示根数) = LLV(LOW,(自动显示根数 + 1)));

B2 := FILTER(A2,自动显示根数);

C21 := BACKSET(B2,(自动显示根数 + 1));

D2 := FILTER(C21,自动显示根数);

E1 := ((REF(LLV(LOW,自动显示根数),1) + REF(HHV(HIGH,自动显示根数),1)) / 2);

{资金带}

XA_1:=(3*CLOSE+LOW+OPEN+HIGH)/6;

BBC:=(20*XA_1+19*REF(XA_1,1)+18*REF(XA_1,2)+17*REF(XA_1,3)+16*REF(XA_1,4)+15*REF(XA_1,5)+14*REF(XA_1,6)+13*REF(XA_1,7)+12*REF(XA_1,8)+11*REF(XA_1,9)+10*REF(XA_1,10)+9*REF(XA_1,11)+8*REF(XA_1,12)+7*REF(XA_1,13)+6*REF(XA_1,14)+5*REF(XA_1,15)+4*REF(XA_1,16)+3*REF(XA_1,17)+2*REF(XA_1,18)+REF(XA_1,20))/210,LINETHICK3;

DD:=MA(BBC,15),LINETHICK3;

DRAWBAND(BBC,RGB(217,71,248),DD,RGB(24,192,241));

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

 

LL1:=REF(L,买入低位-1),NODRAW;

GG1:=REF(H,买入高位-1),NODRAW;

VAR1:=SQRT(GG1/LL1);

VAR2:=SQRT(VAR1);

A:=GG1/SQRT(VAR1);

B:=GG1/VAR1;

D:=GG1/(VAR1+VAR2-1);

买C1:CONST(A),COLORFFFF00,NODRAW;

买C2:CONST(B),COLORFFFF00,NODRAW;

买C3:CONST(D),COLORFFFF00,NODRAW;

DRAWLINE(CURRBARSCOUNT=买入高位,CONST(A),CURRBARSCOUNT=1,A,1),COLORFF8800,DOTLINE;

DRAWLINE(CURRBARSCOUNT=买入高位,CONST(B),CURRBARSCOUNT=1,B,1),COLORFF8800,DOTLINE;

DRAWLINE(CURRBARSCOUNT=买入高位,CONST(D),CURRBARSCOUNT=1,D,1),COLORFF8800,DOTLINE;

 

DRAWTEXT(CURRBARSCOUNT=买入高位,买C1,VARCAT(‘买C1:’,VAR2STR(买C1,2))),COLORWHITE;

DRAWTEXT(CURRBARSCOUNT=买入高位,买C2,VARCAT(‘买C2:’,VAR2STR(买C2,2))),COLORWHITE;

DRAWTEXT(CURRBARSCOUNT=买入高位,买C3,VARCAT(‘买C3:’,VAR2STR(买C3,2))),COLORWHITE;

 

DRAWTEXT(CURRBARSCOUNT=买入低位,L,VARCAT(‘低位【A】’,VAR2STR(L,2))),COLORGREEN;

DRAWTEXT(CURRBARSCOUNT=买入高位,H,VARCAT(‘高位【B】’,VAR2STR(H,2))),COLORRED;

 

DRAWLINE(CURRBARSCOUNT=买入高位,H,买C3,买C3,-1)DOTLINE,LINETHICK1,COLORFF8800;

DRAWLINE(CURRBARSCOUNT=买入低位,L,CURRBARSCOUNT=买入高位,H,0),COLORGREEN,LINETHICK2;

STICKLINE(CURRBARSCOUNT=买入高位,H,CONST(D),0,-1),COLORFF8800;

DRAWICON(CURRBARSCOUNT=买入低位,L,38);

DRAWICON(CURRBARSCOUNT=买入高位,H,39);

 

GG2:=REF(H,卖出高位-1),NODRAW;

LL2:=REF(L,卖出低位-1),NODRAW;

VAR3:=SQRT(GG2/LL2);

VAR4:=SQRT(VAR3);

F:=LL2*SQRT(VAR3),NODRAW;

G:=LL2*VAR3,NODRAW;

J:=LL2*(VAR3+VAR4-1),NODRAW;

卖C1:CONST(F),COLORMAGENTA,NODRAW;

卖C2:CONST(G),COLORMAGENTA,NODRAW;

卖C3:CONST(J),COLORMAGENTA,NODRAW;

DRAWLINE(CURRBARSCOUNT=卖出低位, CONST(F), CURRBARSCOUNT=1, F,1),COLORMAGENTA,DOTLINE;

DRAWLINE(CURRBARSCOUNT=卖出低位, CONST(G), CURRBARSCOUNT=1, G,1),COLORMAGENTA,DOTLINE;

DRAWLINE(CURRBARSCOUNT=卖出低位, CONST(J), CURRBARSCOUNT=1, J,1),COLORMAGENTA,DOTLINE;

 

DRAWTEXT(CURRBARSCOUNT=卖出低位,卖C1,VARCAT(‘卖C1:’,VAR2STR(卖C1,2))),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=卖出低位,卖C2,VARCAT(‘卖C2:’,VAR2STR(卖C2,2))),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=卖出低位,卖C3,VARCAT(‘卖C3:’,VAR2STR(卖C3,2))),COLORYELLOW;

 

DRAWTEXT(CURRBARSCOUNT=卖出高位,H,VARCAT(‘高位【A】’,VAR2STR(H,2))),COLORRED;

DRAWTEXT(CURRBARSCOUNT=卖出低位,L,VARCAT(‘低位【B】’,VAR2STR(L,2))),COLORGREEN;

 

DRAWLINE(CURRBARSCOUNT=卖出低位,L,卖C3,卖C3,-1)DOTLINE,LINETHICK1,COLORMAGENTA;

DRAWLINE(CURRBARSCOUNT=卖出高位,H,CURRBARSCOUNT=卖出低位,L,0),COLORRED,LINETHICK2;

STICKLINE(CURRBARSCOUNT=卖出低位,H,CONST(J),0,-1),COLORMAGENTA;

DRAWICON(CURRBARSCOUNT=卖出低位,L,38);

DRAWICON(CURRBARSCOUNT=卖出高位,H,39);

 

 

 

P:=14;

WW:=(LLV(H,55)+HHV(L,55))/2;

WW2:=(C*4+L*3+H*2+O)/10;OBV:=WW2;

A11:=REF(OBV,P)=HHV(OBV,2*P+1);

B11:=FILTER(A11,P);

C11:=BACKSET(B11,P+1);

D11:=FILTER(C11,P);

A22:=REF(OBV,P)=LLV(OBV,2*P+1);

B22:=FILTER(A22,P);

C22:=BACKSET(B22,P+1);

D22:=FILTER(C22,P);

A111:=REF(H,3)=HHV(H,2*6+1);

B111:=FILTER(A111,3);

C111:=BACKSET(B111,3+1);

D111:=FILTER(C111,3+1);

A112:=REF(L,3)=LLV(L,2*6+1);

B112:=FILTER(A112,3+1);

C112:=BACKSET(B112,3+1);

D112:=FILTER(C112,3);

E111:=(REF(LLV(L,2*3),1)+REF(HHV(H,2*3),1))/2;

E112:=(H+L)/2;

H111:=(D111 AND NOT(D112 AND E111>=E112)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;

L111:=(D112 AND NOT(D111 AND E111<E112));

H112:=D111 AND NOT(D112 AND E111>=E112);

X111:=REF(BARSLAST(H111),1)+1;

F111:=BACKSET(H111 AND COUNT(L111,X111)>0,LLVBARS(IF(L111,LOW,10000),X111));

G111:=F111>REF(F111,1);

I111:=BACKSET(G111,2);

LD:=I111>REF(I111,1);

L112:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;

X112:=REF(BARSLAST(L112),1)+1;

F112:=BACKSET(L112 AND COUNT(H112,X112)>0,HHVBARS(IF(H112,HIGH,0),X112));

G112:=F112>REF(F112,1);

I112:=BACKSET(G112,2);

HD:=I112>REF(I112,1);

实际上涨走势:DRAWLINE(LD,L,HD,H,0),COLORLIRED,DOTLINE;

实际下跌走势:DRAWLINE(HD,H,LD,L,0),COLORLIGREEN,DOTLINE;

J111:=BACKSET(BARSTATUS=2 ,MIN(BARSLAST(HD),BARSLAST(LD))+1);

J112:=J111>REF(J111,1);

预测走势:DRAWLINE(J112,IF(HD,H,L),BARSTATUS=2,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),COLORYELLOW,DOTLINE;

K:=CURRBARSCOUNT,NODRAW;

DRAWNUMBER(HD,H,K),COLORLIRED,DRAWABOVE;

DRAWNUMBER(LD,L,K),COLORFFFF00;

 

 

副图1

MA5:=MA(CLOSE,5);

MA10:=MA(CLOSE,10);

MA20:=MA(CLOSE,20);

A1:=IF(C>=MA5,1,-1);

A2:=IF(C>=MA10,1,-1);

A3:=IF(C>=MA20,1,-1);

A4:=IF(MA5>=REF(MA5,1),1,-1);

A5:=IF(MA10>=REF(MA10,1),1,-1);

A6:=IF(MA20>=REF(MA20,1),1,-1);

趋势:(A1+A2+A3+A4+A5+A6)/6*100,COLOR00FF00;

天佑:趋势>=50,COLOR0000FF,LINETHICK0;

周期:IF(天佑,BARSLAST(CROSS(天佑,0.1))+1,0),COLORFF00FF,LINETHICK0;

临界:IF(CROSS(98,趋势),1,0),COLOR00FF00,LINETHICK0;

WKQY:=BARSLAST(CROSS(50,趋势))<MIN(BARSLAST(CROSS(趋势,1)),BARSLAST(CROSS(趋势,-1)));

挖坑:BETWEEN(趋势,-1,50) AND WKQY,COLOR00FFFF,LINETHICK0;

DRAWBAND(趋势,RGB(250,0,0),50,RGB(0,0,0));

AA:=IF(挖坑,趋势,50);

DRAWBAND(50,RGB(250,250,0),AA,RGB(0,0,0));

STICKLINE(天佑,周期*0.8,周期*0.95,3,0),COLOR0000FF;

STICKLINE(天佑,周期*1.05,周期*1.2,3,0),COLOR0000FF;

STICKLINE(天佑 AND C<REF(C,1),周期*0.9,周期*1.1,3,1),COLORFFFFFF;

STICKLINE(CROSS(天佑,0.1),0,100,0,-1),COLOR0000FF;

DRAWTEXT(临界,90,’☆’),COLOR00FF00;

零轴:0,COLORFFFFFF;

50,POINTDOT,COLOR000000;

选股:周期=1,COLOR0000FF,LINETHICK0;

快跑:趋势<50,,COLOR00FF00,LINETHICK0;

 

 

附图2

N:=8;

M:=13;

P:=60;

S:=3;

V1:=(C*2+H+L)/4*10;

V2:=EMA(V1,13)-EMA(V1,34);

V3:=EMA(V2,5);

V4:2*(V2-V3)*5.5;

超大主力吃: IF(V4>=0,V4,0),COLOR7F00FF,LINETHICK2;

超大主力吐: IF(V4<=0,V4,0),COLOR66FF00,LINETHICK1;

V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;

V6:=EMA(3*V5-2*SMA(V5,18,1),5);

V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;

V8:=(INDEXC*2+INDEXH+INDEXL)/4;

V9:=EMA(V8,13)-EMA(V8,34);

VA:=EMA(V9,3);

VB:=(V9-VA)/2;

主力吃货线:8,COLORFF80FF,LINETHICK2,CROSSDOT;

DH:=REF(HHV(H,10),2);

DC:=REF(HHV(MAX(C,O),10),2);

XGDH:CROSS(C,DH) AND CROSS(超大主力吃,8);

XGDC:CROSS(C,DC) AND CROSS(超大主力吃,8);

STICKLINE(XGDH OR XGDC,0,8,2,0),COLOR3131FF;

倍量吃货:(XGDH OR XGDC) AND V/REF(V,1)>1.95,COLORYELLOW;

STICKLINE(倍量吃货,0,-8,5,0),COLORYELLOW;

{庄家出现}

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

J1:=REVERSE(J);

AA:=REF(MA(C,1),10)>REF(MA(C,60),10);

买点:CROSS(J,J1) AND AA;

STICKLINE(买点,0,30,6,0),COLORBLUE;

STICKLINE(买点,30,60,4,0),COLORWHITE;

STICKLINE(买点,60,80,2,0),COLORYELLOW;

DRAWTEXT(买点,70,’庄家出现’),COLORRED;

 

{主力进出场}

VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);

VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);

VAR3:=EMA(VAR2,10);

VAR4:=LLV(LOW,33);

VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);

主力进场:IF(VAR5>REF(VAR5,1),VAR5,0),COLORRED,NODRAW;

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0 ),COLORRED;

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0 ),COLOR000055;

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.6,0 ),COLOR000077;

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.1,0 ),COLOR000099;

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,1.5,0 ),COLOR0000BB;

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.9,0 ),COLOR0000DD;

STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.3,0 ),COLOR0000FF;

洗盘:IF(VAR5<REF(VAR5,1),VAR5,0),COLORGREEN,NODRAW;

STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,0),COLORGREEN;

STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,0),COLOR005500;

STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.6,0),COLOR007700;

STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.1,0),COLOR009900;

STICKLINE(VAR5<REF(VAR5,1),0,VAR5,1.5,0),COLOR00BB00;

STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.9,0),COLOR00DD00;

STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.3,0),COLOR00FF00;

VAR12:=SMA(ABS(VAR1-H),13,1)/SMA(MAX(VAR1-H,0),10,1);

VAR13:=EMA(VAR12,10);

VAR14:=HHV(H,33);

VAR15:=EMA(IF(H>=VAR14,VAR13,0),3);

冲顶:IF(VAR15>REF(VAR15,1),VAR15,0),COLORFF00FF,NODRAW;

STICKLINE(VAR15>REF(VAR15,1),0,VAR15,3,0),COLORFF00FF;

STICKLINE(VAR15>REF(VAR15,1),0,VAR15,3,0 ),COLOR550055;

STICKLINE(VAR15>REF(VAR15,1),0,VAR15,2.6,0 ),COLOR770077;

STICKLINE(VAR15>REF(VAR15,1),0,VAR15,2.1,0 ),COLOR990099;

STICKLINE(VAR15>REF(VAR15,1),0,VAR15,1.5,0 ),COLORBB00BB;

STICKLINE(VAR15>REF(VAR15,1),0,VAR15,0.9,0 ),COLORDD00DD;

STICKLINE(VAR15>REF(VAR15,1),0,VAR15,0.3,0 ),COLORFF00FF;

主力出场:IF(VAR15<REF(VAR15,1),VAR15,0),COLORYELLOW,NODRAW;

STICKLINE(VAR15<REF(VAR15,1),0,VAR15,3,0 ),COLORYELLOW;

STICKLINE(VAR15<REF(VAR15,1),0,VAR15,3,0),COLOR005555;

STICKLINE(VAR15<REF(VAR15,1),0,VAR15,2.6,0),COLOR007777;

STICKLINE(VAR15<REF(VAR5,1),0,VAR15,2.1,0),COLOR009999;

STICKLINE(VAR15<REF(VAR15,1),0,VAR15,1.5,0),COLOR00BBBB;

STICKLINE(VAR15<REF(VAR15,1),0,VAR15,0.9,0),COLOR00DDDD;

STICKLINE(VAR15<REF(VAR15,1),0,VAR15,0.3,0),COLOR00FFFF;

A1:=REF(CLOSE,2);

A2:=SMA(MAX(CLOSE-A1,0),7,1)/SMA(ABS(CLOSE-A1),7,1)*100;

波段介入点:IF(A2<19,19,0)COLORWHITE;

{主力潜伏}

N1:=8;

MTM:=C-REF(C,1);

ZLGJ:100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1),COLORYELLOW;{N1=9}

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

主力潜伏:COUNT(MACD<0,10)=10,COLORCYAN;

STICKLINE(主力潜伏,0,MACD*(-0.1),2.8,0),LINETHICK6,,COLORCYAN;

DRAWICON(主力潜伏,MACD*(-0.18),28);

DRAWICON(主力潜伏,MACD*(-0.1),26);

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 套装公式 通达信 主力潜伏 主图 副图 公式 https://www.694.cn/ziliaoxiazai/tongdaxin/4091.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务