通达信 买卖指标 源码公式

2024-04-27 0 806

通达信 买卖指标 源码公式

 

DAY32:=MIN( BARSCOUNT(C)-9,32);

DAY42:=MIN( BARSCOUNT(C)-9,42);

DAY34:=MIN( BARSCOUNT(C)-9,34);

DAY50:=MIN( BARSCOUNT(C)-9,50);

DAY55:=MIN( BARSCOUNT(C)-7,55);

DAY89:=MIN( BARSCOUNT(C)-6,89);

DAY144:=MIN( BARSCOUNT(C)-4,144);

DAY233:=MIN( BARSCOUNT(C)-30,233);

PP00:=SUM(L<ma(C,8),5)<=0;

PP0:=SUM(L<MA(C,8),13)/13<=8/100;

PP1:=SUM(L<MA(C,13),21)/21<=8/100;

PP2:=SUM(L<MA(C,21),DAY34)/DAY34<=8/100;

PP3:=SUM(L<MA(C,34),DAY55)/DAY55<=8/100;

PP4:=SUM(L<MA(C,DAY55),DAY89)/DAY89<=8/100;

P00:=SUM(H>MA(C,8),5)<=0 ;

P0:=SUM(H>MA(C,8),13)/13<=8/100;

P1:=SUM(H>MA(C,13),21)/21<=8/100;

P2:=SUM(H>MA(C,21),DAY34)/DAY34<=8/100;

P3:=SUM(H>MA(C,DAY34),DAY55)/DAY55<=8/100;

P4:=SUM(H>MA(C,DAY55),DAY89)/DAY89<=8/100;

obv:=SUM(IF(CLOSE>REF(CLOSE,1),vol,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);

RSV:=(OBV-LLV(OBV,DAY34))/(HHV(OBV,DAY34)-LLV(OBV,DAY34))*100;

K:=SMA(RSV,5,1);

D:=SMA(K,3,1);

JJ:=3*K-2*D;

J:=IF(JJ>100,100,JJ);

AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;

AA4:=(CLOSE-LLV(LOW,DAY34))/(HHV(HIGH,DAY34)-LLV(LOW,DAY34))*100;

AA5:=SMA(AA4,13,8);

OBV走势:=CEILING(SMA(AA5,13,8));

AA6:=SMA(AA3,21,8);

买观注:= OBV走势-AA6<-70;

卖观注:=OBV走势-AA6>88;

ZH:=(SUM(P00 AND SUM(P00,2)=1 ,21)>1 AND P00 AND SUM(P00,2)=1) OR (SUM(P00 AND SUM(P00,2)=1 ,DAY55)>2 AND P00 AND SUM(P00,2)=1) OR (P00 AND SUM(P00,2)=1 AND MA(C,DAY89)>REF(MA(C,DAY89),2)) OR (P0 AND SUM(P0,2)=1) OR (P1 AND SUM(P1,2)=1) OR(P2 AND SUM(P2,2)=1) OR(P3 AND SUM(P3,2)=1) OR(P4 AND SUM(P4,2)=1) ;

HZ:=(SUM(PP00 AND SUM(PP00,2)=1 ,21)>1 AND PP00 AND SUM(PP00,2)=1) OR (SUM(PP00 AND SUM(PP00,2)=1 ,DAY55)>2 AND PP00 AND SUM(PP00,2)=1) OR (PP00 AND SUM(PP00,2)=1 AND MA(C,DAY89)>REF(MA(C,DAY89),2)) OR (PP0 AND SUM(PP0,2)=1) OR (PP1 AND SUM(PP1,2)=1) OR(PP2 AND SUM(PP2,2)=1) OR(PP3 AND SUM(PP3,2)=1) OR(PP4 AND SUM(PP4,2)=1) ;

VAR1:=(2*CLOSE+HIGH+LOW)/4;

VAR2:=LLV(LOW,5);

VAR3:=HHV(HIGH,4);

Y: EMA((VAR1-VAR2)/(VAR3-VAR2)*100,4);

W: EMA(0.667*REF(Y,1)+0.333*Y,2);

VAR5:=(VAR1-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;

VAR6:=SMA(VAR5,2,1);

坦途: SMA(VAR6,2,1), LINEstICK;

YY:=W-Y;

DIFF:=EMA(CLOSE,13)-EMA(CLOSE,21);

DEA:=EMA(DIFF,8);

macd:=2*(DIFF-DEA);

MBC:=0.5*(DIFF+DEA);

低位金叉:=crOSS(DIFF,DEA) AND DIFF<-0.1 ;

DIFFF:=DIFF-REF(DIFF,1);

DEAA:=DEA-REF(DEA,1);

Mac:=MACD;

ABMAC:=MA(MAC*MAC,DAY34);

NN:=BArslAST(MAC*REF(MAC,1)<=0)+1;

ZHGTAA:=(SUM(MAC,0)-REF(SUM(MAC,0),NN))/10;

NNN:=BARSLAST(ZHGTAA<0 AND REF(ZHGTAA,1)>0)+1;

TTT:=BARSLAST(ZHGTAA>0 AND REF(ZHGTAA,1)<0)+1;

BBB:= REF(MAC,1)<REF(MAC,2) AND MAC>REF(MAC,1) ;

SSS:= REF(MAC,1)>REF(MAC,2) AND MAC<REF(MAC,1) ;

RTB:=MAC<0 AND REF(MAC,1)>0;

BTR:=MAC>0 AND REF(MAC,1)<0;

BTR1:=BARSLAST(BTR)+1;

RTB1:=BARSLAST(RTB)+1;

BTR2:=REF(BTR1,BTR1)+1;

RTB2:=REF(RTB1,RTB1)+1;

FRIBB:=BARSLAST(BBB)+1;

SECNBB:=REF(FRIBB,FRIBB)+1;

FRISS:=BARSLAST(SSS)+1;

SECNSS:=REF(FRISS,FRISS)+1;

SSS1:= MAC>0 AND SSS AND ( REF(MAC,1)*REF(MAC,1)>3*ABMAC OR ( NOT((HHV(MAC,FRISS+3)>=HHV(MAC,FRISS+SECNSS+3) AND HHV(H,FRISS+3)>=HHV(H,FRISS+SECNSS+3)) OR (HHV(MAC,FRISS+3)<HHV(MAC,FRISS+SECNSS+3) AND HHV(H,FRISS+3)<HHV(H,FRISS+SECNSS+3))) AND REF(MAC,1)*REF(MAC,1)>1.4*ABMAC));

BBB1:=MAC<0 AND BBB AND ( REF(MAC,1)*REF(MAC,1)>3*ABMAC OR (NOT((LLV(MAC,FRIBB+3)<=LLV(MAC,FRIBB+SECNBB+3) AND LLV(L,FRIBB+3)<=LLV(L,FRIBB+SECNBB+3)) OR (LLV(MAC,FRIBB+3)>LLV(MAC,FRIBB+SECNBB+3) AND LLV(L,FRIBB+3)>LLV(L,FRIBB+SECNBB+3))) AND REF(MAC,1)*REF(MAC,1)>1.4*ABMAC));

BBB12:=BTR AND REF(ZHGTAA,1)>=-65/1000;

BBB13:=REF(MAC,1)<0.05 AND REF(MAC,1)>0 AND MAC/REF(MAC,1)>1.3 AND REF(MAC,2)/REF(MAC,1)>1.1 AND MAC/REF(MAC,2)>1;

SSS12:=RTB AND REF(ZHGTAA,1)<=65/1000;

SSS13:=REF(MAC,1)>-0.05 AND REF(MAC,1)<0 AND REF(MAC,1)/MAC>1.3 AND REF(MAC,1)/REF(MAC,2)>1.1 AND REF(MAC,2)/MAC>1;

STICKLINE(SSS1 AND (C/DYNAINFO(3))<1.098 ,-40,65,3,0), COLOR888888;

STICKLINE(BBB1 OR BBB12 OR BBB13 ,-40,65,3,0), COLORFF00FF;

高位死叉:=CROSS(DEA,DIFF) AND DIFF>0.1;

DIFFZ:=1.02*DIFF;

DEAZ:=1.02*DEA;

JCCOUNT:=COUNT(CROSS(DIFFZ,DEA),BARSLAST(DEA>=0));

JCCOUNTT:=COUNT(CROSS(DEAZ,DIFF),BARSLAST(DEA<=0));

二次金叉:=CROSS(DIFFZ,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

二次死叉:=CROSS(DEAZ,DIFF) AND DEA>0 AND COUNT(JCCOUNTT=2,21)=1;

AZ1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,AZ1+1)>CLOSE AND DIFF>REF(DIFF,AZ1+1) AND CROSS(DIFF,DEA) AND DIFF<-0.005;

AZ2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,AZ2+1)<CLOSE AND REF(DIFF,AZ2+1)>DIFF AND CROSS(DEA,DIFF) ;

A1:=MA(CLOSE,5)-MA(CLOSE,8);

A2:=MA(CLOSE,8)-MA(CLOSE,13);

A3:=MA(CLOSE,13)-MA(CLOSE,21);

A4:=MA(CLOSE,21)-MA(CLOSE,DAY34);

A5:=MA(CLOSE,DAY34)-MA(CLOSE,DAY55);

A6:=MA(CLOSE,DAY55)-MA(CLOSE,DAY89);

A7:=MA(CLOSE,DAY89)-MA(CLOSE,DAY144);

A8:=MA(CLOSE,144)-MA(CLOSE,DAY233);

DQSI:=IF(A1>=REF(A1,1),1,0)+IF(A2>=REF(A2,1),1,0)+IF(A3>=REF(A3,1),1,0)+IF(A4>=REF(A4,1),1,0);

CQSI:=IF(A5>=REF(A5,1),1,0)+IF(A6>=REF(A6,1),1,0)+IF(A7>=REF(A7,1),1,0)+IF(A8>=REF(A8,1),1,0);

QSI:=IF(DQSI=0 AND CQSI=0,1,IF(DQSI>1 OR CQSI>0,1,0));

PPP:=IF( 坦途<REF(坦途,1),1,0);

AS:=IF(W<Y AND REF(W,1)>REF(Y,1) AND Y<32,1,0);

ASAT:=IF(AS=1 AND NOT (REF(坦途,BARSLAST(AS)+1)>坦途 AND REF(C,BARSLAST(AS)+1)<C),1,0);

DING:=IF(SUM(L<MA(C,DAY34),DAY50)/DAY50<=12/100,1,0);

买点11:= (ASAT=1) AND ((QSI+REF(QSI,1)+REF(QSI,2))>1) AND (DIFFF>REF(DIFFF,1) OR MACD>REF(MACD,1)) AND REF(PPP,1)+REF(PPP,2)+REF(PPP,3)+REF(PPP,4)>3 ;

DQSID:=IF(A1<REF(A1,1),1,0)+IF(A2<REF(A2,1),1,0)+IF(A3<REF(A3,1),1,0)+IF(A4<REF(A4,1),1,0);

CQSID:=IF(A5<REF(A5,1),1,0)+IF(A6<REF(A6,1),1,0)+IF(A7<REF(A7,1),1,0)+IF(A8<REF(A8,1),1,0);

QSID:=IF(DQSID=0 AND CQSID=0,1,IF(DQSID>1 OR CQSID>0,1,0));

PPPD:=IF( 坦途>REF(坦途,1),1,0);

AT:=IF(W>Y AND REF(W,1)<REF(Y,1) AND REF(W,1)>68,1,0);

ATAS:=IF(AT=1 AND NOT (REF(坦途,BARSLAST(AT)+1)<坦途 AND REF(H,BARSLAST(AT)+1)<H),1,1);

DINGD:=IF(SUM(H>MA(C,DAY34),DAY50)/DAY50>=12/100,1,0);

卖点11:= (ATAS=1) AND ((QSID+REF(QSID,1)+REF(QSID,2))>1) AND (DIFFF<REF(DIFFF,1) OR MACD<REF(MACD,1)) AND REF(PPPD,1)+REF(PPPD,2)+REF(PPPD,3)+REF(PPPD,4)>3 ;

卖点:=(ATAS=1) AND 坦途>58 AND REF(坦途,1)>58 AND REF(坦途,2)>58 AND PPP=1 AND REF(PPP,1)+REF(PPP,2)+REF(PPP,3)<=0;

买点N:=(ATAS=1) AND 坦途<53 AND REF(坦途,1)<53 AND REF(坦途,2)<55 AND PPPD=1 AND REF(PPPD,1)+REF(PPPD,2)+REF(PPPD,3)<=0;

DRAWTEXT(卖点,1.08*坦途,’◆’),COLORYELLOW;

连卖:=SUM(卖点,21)>1;

买点000:=坦途<48 AND SUM(卖点,55)>2 AND MA(C,21)>REF(MA(C,21),1) AND CROSS(Y,W) AND((OBV走势-AA6<-45) OR OBV<50 OR J<20);

DRAWTEXT(买点000 OR 买点N,-25,’◆0′),COLORRED;

买点001:=坦途<50 AND SUM(卖点,42)>2 AND CROSS(Y,W) AND MA(C,13)>REF(MA(C,13),1) ;

DRAWTEXT(买点001,-15,’◆1′),COLORRED;

买点002:=坦途<51 AND SUM(卖点,26)>2 AND CROSS(Y,W) ;

DRAWTEXT(买点002,25,’◆2′),COLORRED;

买点003:=坦途<52 AND SUM(卖点,21)>1 AND CROSS(Y,W) AND (J<30 OR SUM(买观注,2)>0 ) ;

DRAWTEXT(买点003,50,’◆3′),COLORRED;

买点004:=坦途<52 AND SUM(卖点,16)>1 AND CROSS(Y,W) ;

DRAWTEXT(买点004,75,’◆4′),COLORRED;

买点006:=SUM(卖点,15)>1 AND CROSS(Y,W) AND SUM(BARSLAST(卖点)-1,CROSS(Y,W))<3 ;

DRAWTEXT(买点006,0.2*Y,’★6′),COLOR9966FF;

买点005:=SUM(卖点,22)=1 AND CROSS(Y,W) AND SUM(BARSLAST(卖点)-1,CROSS(Y,W))<3 ;

DRAWTEXT(买点005,0.2*Y,’★5′),COLORFF66FF;

买点0060:=SUM(卖点,3)=1 AND SUM(卖点,13)=1 AND SUM(卖点,1)=0 AND Y>1.01*W AND Y>REF(Y,1) AND W>REF(W,1);

买点0006:=买点0060 AND SUM(买点0060,2)=1;

DRAWTEXT(买点0006,0.2*Y,’★7′),COLOR0066FF;

买点00:=买点000 OR 买点001 OR 买点002 ;

买点10:= 坦途<45 AND ((SUM(ZH,5)>0 AND CROSS(Y,W) ) OR (ZH AND SUM(CROSS(Y,W),5)>0) )AND (SUM(买观注,2)>0 OR OBV<30 OR J<10 OR (OBV走势-AA6<-33)) ;

DRAWICON(买点10,-40,1),COLORGREEN;

DRAWTEXT(买点10 AND ( SUM(买点10,8)>2 OR SUM(买点10,16)>3 OR SUM(买点10,32)>4),40,’1′),COLORRED;

DRAWICON(买点10 AND ( SUM(买点10,8)>2 OR SUM(买点10,16)>3 OR SUM(买点10,32)>4),-40,1),COLORGREEN;

卖点10:= 坦途>68 AND ((SUM(HZ,5)>0 AND CROSS(W,Y) ) OR (HZ AND SUM(CROSS(W,Y),4)>0) )AND (SUM(卖观注,2)>0 OR OBV>76 OR J>92 OR (AA6-OBV走势<-33)) ;

DRAWICON(卖点10,100,2),COLORGREEN;

DRAWTEXT(卖点10 AND ( SUM(卖点10,8)>2 OR SUM(卖点10,16)>3 OR SUM(卖点10,32)>4),80,’1′),COLOR00FF66;

DRAWICON(卖点10 AND ( SUM(卖点10,8)>2 OR SUM(卖点10,16)>3 OR SUM(卖点10,32)>4),120,2),COLORGREEN;

买点20:= 坦途<48 AND ((CROSS(Y,W) AND SUM(二次金叉,3)>0) OR (SUM(CROSS(Y,W),3)>0 AND 二次金叉)) ;

DRAWTEXT(买点20,60,’◆20′),COLORRED;

买点:=(买点11 AND (DING=0)) ;

DRAWICON(买点,-60,38),COLORRED;

卖点0:=(卖点11 AND (DINGD=0)) ;

DRAWICON(卖点0,150,39),COLORGREEN;

AA:=VOL/((HIGH-LOW)*2-Abs(CLOSE-OPEN));

买盘:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));

卖盘:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2));

买卖差:=买盘+卖盘;

换手率:=100*VOL/CAPITAL;

总放量:=IF((买盘>MA(买盘,6)*3) OR (卖盘<MA(卖盘,6)*3) OR (VOL>MA(VOL,5)*2.5),1,0);

买点30:= 坦途<48 AND ((CROSS(Y,W) AND SUM(总放量,2)>0) OR (SUM(CROSS(Y,W),2)>0 AND 总放量)) ;

DRAWTEXT(买点30,90,’◆30′),COLORRED;

久买:=(买点 OR 买点10 OR 买点20 OR 买点30);

卖点005:=SUM(久买,22)=1 AND CROSS(W,Y) AND SUM(BARSLAST(久买)-1,CROSS(W,Y))<3 ;

DRAWTEXT(卖点005,70,’?’),COLORYELLOW;

DRAWTEXT(卖点005,125,’慎’),COLORYELLOW;

慎卖:=买点11 AND (DING=1);

DRAWTEXT(慎卖,坦途+60,’慎’),COLORYELLOW;

买点A:=买点 AND SUM(买点11,32)>=2;

DRAWTEXT(买点A,-40,’买’),COLORRED;

卖点A:=卖点0 AND SUM(卖点11,32)>=2;

DRAWTEXT(卖点A,120,’卖’),COLORGREEN;

ZGT1:=IF(SUM((P00 OR P0 OR P1 OR P2 OR P3 OR P4),3)>0,1,0)+IF(SUM(买观注,3)>0,1,0)+IF(SUM(买点,3)>0 ,1,0)+IF(SUM(总放量,3),1,0);

ZTG1:=IF(SUM((PP00 OR PP0 OR PP1 OR PP2 OR PP3 OR PP4),3)>0,1,0)+IF(SUM(卖观注,3)>0,1,0)+IF(SUM(卖点0 OR 卖点10,3)>0 ,1,0)+IF(SUM(总放量,3),1,0)+IF(SUM(SSS1 OR 二次死叉 OR 高位死叉,3),1,0);

ZHGT00:= (ZGT1>=4) OR (ZGT1=3 AND SUM(二次金叉,13)>0) OR (二次金叉 AND SUM(ZGT1>=3,13)>0) ;

ZHGT:=ZHGT00 AND SUM(ZHGT00,2)=1;

ZHTG:= (ZTG1>=4) AND SUM(ZTG1>=4,2)=1 ;

ZHTG0:= (ZTG1>=5) AND SUM(ZTG1>=5,2)=1 ;

STICKLINE(ZHGT ,-40,90,6,0), COLORWHITE;

DRAWICON(ZHGT,-80,8),COLORGREEN;

STICKLINE(ZHTG ,-45,40,8,0), COLOR008000 ;

DRAWICON(ZHTG,80,15),COLORGREEN;

DRAWICON(ZHTG0,115,15),COLORGREEN;

DXD1:=IF(SUM((PP00 OR PP0 OR PP1 OR PP2 OR PP3 OR PP4),1)>0,1,0)+IF(SUM(卖观注,2)>0,1,0)+IF(SUM(卖点,2)>0 ,1,0)+IF(SUM(总放量,2),1,0);

DXD:=(DXD1=4) OR (DXD1=3 AND SUM(二次死叉,13)>0) OR (二次死叉 AND SUM(DXD1>=3,13)>0) ;

STICKLINE(DXD AND SUM(H<=1.002*L,2)=0 AND (C/DYNAINFO(3))<1.098 ,-60,70,4,0), COLOR00FF00;

DRAWTEXT(DXD AND (C/DYNAINFO(3))<1.098 ,100,’卖’),COLOR00FF00;

总数:=SUM(买点000,24)+SUM(买点001,24)+SUM(买点002,24)+SUM(买点003,24)+SUM(买点004,24)+SUM(买点005,24)+SUM(买点10,24)+SUM(买点20,24)+SUM(买点30,24)+SUM(买点,24);

ATAS0:=(总数>=8);

ATASS:=ATAS0 AND SUM(ATAS0,2)=1 AND (SUM(P00 OR P0 OR P1 OR P2 OR P3 OR P4,3)>0);

STICKLINE(ATASS,-140,120,2,0),COLORRED ;

DRAWTEXT(ATASS AND SUM(ATASS,2)=1 ,-130,’买’),COLOR38B0DE ;

VAR11:= 买点10 AND SUM(买点10,10)>1;

VAR12:= 卖点10 AND SUM(卖点10,10)>1;

PDKS:=P00 AND NOT(REF(P00,1));

PDKSS:=IF(PDKS AND SUM(PDKS,5)=1,1,0);

PDTS:=PP00 AND NOT(REF(PP00,1));

PDTSS:=IF(PDTS AND SUM(PDTS,5)=1,1,0);

DTTIME:=REF(BARSLAST(PDKSS),1)+1;

DTTIME1:=REF(BARSLAST(PDTSS),1)+1;

PDN:=PDKSS AND (SUM(PDTSS,DTTIME)>=1);

PDN1:=PDKSS AND (SUM(PDTSS,DTTIME)<1);

PTN:=PDTSS AND (SUM(PDKSS,DTTIME1)>=1);

PTN1:=PDTSS AND (SUM(PDKSS,DTTIME1)<1);

PDTN1:=PDTSS AND (SUM(PDKSS,DTTIME1)<1);

DTTIMEA:=REF(BARSLAST(PDN),1)+1;

DTTIMEB:=REF(BARSLAST(PTN),1)+1;

DAY11:=MIN( BARSCOUNT(C)-30,DTTIMEA+256);

DAY12:=MIN( BARSCOUNT(C)-30,DTTIMEB+256);

ZHGTA:=PDN1 AND SUM(PDN1,DTTIMEA+1)>=2 AND SUM(PDN,DAY11)>=2;

ZHGTB:=PTN1 AND SUM(PTN1,DTTIMEB+1)>=2 AND SUM(PTN,DAY12)>=2;

VAR21:=ZHGTA;

VAR22:=(VAR21 AND SUM(买点10,4)>0) OR (买点10 AND SUM(VAR21,4)>0);

VAR23:=(ZHGTB AND SUM(卖点10,4)>0) OR (卖点10 AND SUM(ZHGTB,4)>0);

STICKLINE(VAR23 AND (C/DYNAINFO(3))<1.098 ,-100,90,3,0), COLORBLUE;

STICKLINE(VAR22 ,-90,90,3,0), COLORYELLOW;

DRAWTEXT((VAR21 AND SUM(VAR11,4)>0) OR (VAR11 AND SUM(VAR21,4)>0) ,110,’缅’),COLORYELLOW;

总买A:=IF(买点000,1,0)+IF(买点001,1,0)+IF(买点002,1,0)+IF(买点003,1,0)+IF(买点004,1,0)+IF(买点30,4,0)+IF(买点10 ,8,0)+IF(买点,3,0)+IF(买点A,4,0)+IF(买点0006,3,0)+IF(买点005 AND SUM(买点005,DAY32)>=1,5,0)+IF(ZHGT,8,0)+IF(二次金叉,7,0)+IF(买点20,6,0)+IF(底背离,9,0)+IF(低位金叉,3,0)+IF(VAR22,7,0)+IF(BBB1 AND MBC<0,6,0)+IF(BBB1 AND MBC>=0,3,0)+8*IF(BBB12,1,0)+IF(BBB13,6,0);

总卖A:=IF(卖点10,2,0)+IF(卖点0,3,0)+IF(卖点A,4,0)+IF(DXD,4,0)+IF(卖点,4,0)+IF(ZHTG,6,0)+IF(ZHTG0,12,0)+IF(高位死叉,3,0)+IF(顶背离,9,0)+IF(二次死叉,7,0)+IF(VAR23,7,0)+IF(SSS1 AND MBC>0,6,0)+IF(SSS1 AND MBC<=0,3,0)+IF(SSS12,8,0)+IF(SSS13,6,0);

总买:=IF(总买A<4,总买A,IF(SUM(P00 OR P0 OR P1 OR P2 OR P3 OR P4,2)>0,总买A+1,IF(SUM( PP1 OR PP2 OR PP3 OR PP4,2)>0,总买A,总买A))),LINETHICK0;

总卖:=IF(总卖A<4,总卖A,IF(SUM(PP00 OR PP0 OR PP1 OR PP2 OR PP3 OR PP4,2)>0,总卖A+1,IF(SUM( P1 OR P2 OR P3 OR P4,2)>0,总卖A,总卖A))),LINETHICK0;

DRAWNUMBER(总卖>=3 ,135,INTPART(总卖)),COLORGREEN;

DRAWNUMBER(总买>=3 ,-35,INTPART(总买)),COLORWHITE;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 通达信 通达信 买卖指标 源码公式 https://www.694.cn/ziliaoxiazai/tongdaxin/5453.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务