通达信庄氏量学主图指标公式

2024-04-26 0 293

通达信庄氏量学主图指标公式
N:=5;
TJ360:=C=HHV(C,150);{黑马线}
TS360:=BArslAst(TJ360);
HHC360:=REF(C,TS360);
RHHC360:=REF(HHC360,1);
TJ1360:=H>L AND C>RHHC360 ;
CS1360:=BARSLASTCOUNT(TJ1360);
CSS:=COUNT(CS1360=1,60);
MR:=CS1360=1 AND CSS=1;
HMXTS:=BARSLAST(MR);
黑马线:CONST(REF(C,HMXTS)),COLORFFFF00,LINETHICK2;
bbi:=(ma(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4,COLORYELLOW,LINETHICK2;
大周期:=MA(C,N),COLORWHITE,LINETHICK2;
JJ:=(C+O+H+L)/4;
AQ:=EMA(JJ,10);
QB:=REF(AQ,1);
IF(AQ>QB,AQ,QB),COLORWHITE,LINETHICK2;
IF(AQ>REF(AQ,1),AQ+0.001,DRAWNULL),LINETHICK2,COLORFF05F9;
IF(AQ<REF(AQ,1),AQ,DRAWNULL),COLOR00FF00;
斜角:=ATAN((AQ/REF(AQ,1)-1)*100)*180/3.1416,NODRAW,COLOR5588FF;
开盘:=(O-REF(C,1))/REF(C,1)*100,NODRAW,COLORLIGREEN;
现价:REFDATE(C,DATE),DOTLINE,COLORLIGRAY;
MA5角度:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.1416,NODRAW,COLOR5588FF;
振幅:=(H-L)/REF(C,1)*100,NODRAW,COLORCCCCFF;
获利:=WINNER(C)*100,NODRAW,COLORRED;
高:=REF(HHV(H,72),5);
龙门:REFDATE(高,DATE),COLORWHITE,LINETHICK2;
月线:=EMA(C,21);
DRAWTEXT(CURRBARSCOUNT=1,L*0.995,EXTERNSTR(0,4)); { 涨停原因}
DRAWKLINE(H,O,L,C);
高量线:=V=HHV(V,20) AND H=HHV(H,60),NODRAW;
CYZ:=Abs(C-O)>=REF(ABS(C-O),1){价柱大于昨天};
LZF:=V/REF(V,1){量柱今昨比};
D1:=CYZ AND (C/REF(C,1)<=0.94 OR C/O<=0.94) AND (V/HHV(V,10)<=0.618 OR V<REF(V,1));
D2:=CYZ AND (C/REF(C,1)<=0.94 OR C/O<=0.94) AND BETWEEN(LZF,1,1.75) AND V>REF(V,1) AND CYZ>LZF;
长阴短柱:=D1 OR D2;
凹底:=长阴短柱 AND (MA(C,3)-LLV(L,20))/LLV(L,20)<0.08;
凹口:=长阴短柱 AND EXIST(高量线,10) AND BETWEEN(O,HHV(H,10)*0.9,HHV(H,10)*0.95);
乖离1:=H/AQ,COLORRED,NODRAW;
乖离2:=L/AQ,COLORRED,NODRAW;
DRAWTEXT(乖离1>1.35,H,’顶背’),COLORGREEN;
DRAWTEXT(乖离2<-1.35,L,’底背’),COLORRED;
TM:=1200823;
涨停:IF(DATE<TM,ZTPRICE(REF(C,1),IF(CODELIKE(‘688’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1))),ZTPRICE(REF(C,1),IF(CODELIKE(‘688’) OR CODELIKE(‘300’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1)))),NODRAW,COLORRED;
跌停:IF(DATE<TM,DTPRICE(REF(C,1),IF(CODELIKE(‘688’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1))),DTPRICE(REF(C,1),IF(CODELIKE(‘688’) OR CODELIKE(‘300’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1)))),NODRAW,COLORGREEN;
明涨停:=IF(DATE<TM,C*IF(CODELIKE(‘688’),1.2,IF(NAMEINCLUDE(‘S’),1.05,1.1)),C*(IF(CODELIKE(‘688’) OR CODELIKE(‘300’),1.2,IF(NAMEINCLUDE(‘S’),1.05,1.1)))),NODRAW,COLORLIMAGENTA;
明跌停:=IF(DATE<TM,C*IF(CODELIKE(‘688’),0.8,IF(NAMEINCLUDE(‘S’),0.45,0.9)),C*(IF(CODELIKE(‘688’) OR CODELIKE(‘300’),0.8,IF(NAMEINCLUDE(‘S’),0.45,0.9)))),NODRAW,COLORFFFF00;
半分:(O+C)/2,NODRAW,COLORWHITE;
昨半:REF((O+C)/2,1),NODRAW,COLORYELLOW;
STICKLINE(ISLASTBAR,昨半,昨半,10,2),COLORFF00FF;
P:=7000;
炸板:=H=涨停 AND H>C;
历史涨停:=COUNT((C>=涨停) AND L!=C,P),NODRAW,COLORYELLOW;
开板数:=COUNT(炸板,P);
封板率:=100*(1-(开板数/(历史涨停+开板数))),NODRAW,COLORYELLOW;
ZT1:=H>=涨停 AND PERIOD=5 AND H>C;
DT:=C<=跌停 AND PERIOD=5 AND L=C;
DT1:=L<=跌停 AND PERIOD=5 AND L<C;
ZT:=C>=涨停 AND PERIOD=5 AND H=C;
涨停周期:BARSLAST(ZT),NODRAW,COLORFF00FF;
STICKLINE((BARSLAST(MONTH!=REF(MONTH,1) OR DATETODAY(DATE)=1))+1=1,H#MONTH,L#MONTH,0,-1),COLORGREEN;
月开价:REF(O,BARSLAST(MONTH!=REF(MONTH,1))),COLORRED,NODRAW;
STICKLINE(C>月开价,月开价,月开价,5,0),COLORRED;
STICKLINE(C<月开价,月开价,月开价,5,0),COLORFFFF00;
STICKLINE(C=月开价,月开价,月开价,5,0),COLORWHITE;
LB:=REF(EVERY(ZT,3),2) AND REF(H=HHV(H,20),1) AND H<REF(H,1);
LBQ:=BARSLAST(LB);
打折:=REF(H,LBQ+1)*0.618,NODRAW,COLORWHITE;
SLB:=EVERY(ZT,3);
KK2:=SUMBARS(REFX(SLB,1),1);
STICKLINE(KK2,REF(C,KK2-1),REF(C,KK2-1),5,0),COLORFFCC99;
龙回头天数:=SUMBARS(REFX(SLB,1),1)-2,NODRAW,COLORFF00FF;
TT:=DRAWTEXT(REFX(NOT(ZT),1) AND SLB,REF(C,1),’回头线’);
STICKLINE(打折,打折,打折,5,0),COLORFFFF44;
Q3:=STRCAT(CON2STR(打折,2),’打折线’);
DRAWTEXT(ISLASTBAR,打折,VARCAT(VARCAT(‘打折价’,VAR2STR(打折,2)),’元’))COLORFFFF00;
STICKLINE(CURRBARSCOUNT=4,C,C,25,0),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=5,REF(L-0.02,1),’ ◇’),COLORWHITE;
DRAWNUMBER(CURRBARSCOUNT=4,L*0.99,C),COLORWHITE;
流通市值:(FINANCE(40)/100000000),NODRAW,COLORRED;
{涨停k线颜色设置}
STICKLINE(ZT,C,(O+C)/2,3,0),COLOR000099;
STICKLINE(ZT,C,(O+C)/2,2.2,0),COLOR0000CC;
STICKLINE(ZT,C,(O+C)/2,1.5,0),COLOR0000FF;
STICKLINE(ZT,C,(O+C)/2,0.5,0),COLORCC66FF;
STICKLINE(ZT,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(ZT,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(ZT,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(ZT,O,(O+C)/2,0.5,0),COLORFFFFFF;
STICKLINE(DT,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(DT,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(DT,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(DT,O,(O+C)/2,0.5,0),COLORFFFFFF;
STICKLINE(DT,C,(O+C)/2,3,0),COLOR009900;
STICKLINE(DT,C,(O+C)/2,2.2,0),COLOR00BB00;
STICKLINE(DT,C,(O+C)/2,1.5,0),COLOR00DD00;
STICKLINE(DT,C,(O+C)/2,0.5,0),COLOR00FF00;
{曾涨跌停打开K线颜色设置}
STICKLINE(ZT1,C,(O+C)/2,3,0),COLORFF00FF;
STICKLINE(ZT1,C,(O+C)/2,2.2,0),COLORFF00FF;
STICKLINE(ZT1,C,(O+C)/2,1.5,0),COLOR0000FF;
STICKLINE(ZT1,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(ZT1,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(ZT1,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(DT1,O,(O+C)/2,3,0),COLOR888888;
STICKLINE(DT1,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(DT1,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(DT1,C,(O+C)/2,3,0),COLOR009900;
STICKLINE(DT1,C,(O+C)/2,2.2,0),COLOR00BB00;
STICKLINE(DT1,C,(O+C)/2,1.5,0),COLOR00DD00;
STICKLINE(DT1,C,(O+C)/2,0.5,0),COLOR00FF00;
DRAWTEXT(DT1,L-0.09,’撬’),COLORCC00CC;{从涨停到跌停};
量价:=(vol/CLOSE)/3;
BB2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);
BB3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);
BB6:=BB2+BB3;DD1:=1;比:=BB2/BB3;
DB1:=YEAR AND MONTH AND DAY;
BA1:=STRCAT(CON2STR(YEAR,0),’年’);
BA2:=STRCAT(CON2STR(MONTH,0),’月’);
BA3:=STRCAT(CON2STR(DAY,0),’日’);
BA4:=STRCAT(‘周’,IF(WEEkdAY=1,’一’,IF(WEEKDAY=2,’二’,IF(WEEKDAY=3,’三’,IF(WEEKDAY=4,’四’,IF(WEEKDAY=5,’五’,IF(WEEKDAY=6,’六’,’日’)))))));
AA:=STRCAT(STRCAT(STRCAT(BA1,BA2),STRCAT(BA3,BA4)),”);
DRAWTEXT_FIX(DD1,0.895,0,0,AA),COLORLIGRAY;
JYZY:=(REF(C>=O,1) OR O>REF(H,1)) AND AMOUNT/V/100>REF(C,1) AND C<O;
假阳:=REF(C<=O,1) AND H<REF(O,1) AND C<(REF(O-C,1))/3+REF(C,1) AND AMOUNT/V/100<REF(C,1) AND C>O;
乾坤眼:=(C>O AND REF(C,1)<REF(O,1) AND REF(C,2)<REF(O,2) AND C>REF(C,2)AND V<REF(V,2)&&REF(V,1)<REF(V,2)),COLORYELLOW;
STICKLINE(乾坤眼,O,C,3,0),COLOR000099;
STICKLINE(乾坤眼,O,C,2.2,0),COLOR0000CC;
STICKLINE(乾坤眼,O,C,1.5,0),COLOR0000FF;
STICKLINE(乾坤眼,O,C,0.5,0),COLORCC66FF;
黄金阳:=EXIST(DT OR DT1,2) AND 假阳;
DRAWLINE(黄金阳,C,REF(黄金阳,1),REF(C,1),1),DOTLINE,COLOREEBB88;
均价:=(3*C+L+3*O+H)/8;
重心价:=IF(AMOUNT/V/100<L OR AMOUNT/V/100>H,均价,AMOUNT/V/100),COLORRED,POINTDOT;
A:=IF(FINANCE(3)=0 OR FINANCE(3)=13,均价,重心价);
M5:=WMA(A,5);
M10:=MA(A,10);
WM20:=WMA(A,20);
MA3:=MA(C,3);
YTSL:=(3*C+L+O+H)/6;
跟庄线:=(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211,COLORFFFFFF;
等待:=IF(MA3>跟庄线,跟庄线,MA3);
{量学理论}
金线:=1;
临界点:=0;
比系数:=1.3;
均线:=M5>REF(M5,1) AND M10<REF(M10,1) AND WM20<REF(WM20,1);
RV1:=REF(V,1);
RV2:=REF(V,2);
RV3:=REF(V,3);
RC1:=REF(C,1);
RC2:=REF(C,2);
RC3:=REF(C,3);
RC4:=REF(C,4);
RO1:=REF(O,1);
RO2:=REF(O,2);
RO3:=REF(O,3);
RO4:=REF(O,4);
不破价顶:=(C>=RC3) AND RC1>=RC3 AND RC2>=RC3;
不破价底:=L>RO3 AND REF(L,1)>RO3 AND REF(L,2)>RO3;
RJ1:=REF(均价,1);
RJ2:=REF(均价,2);
阳柱:=C>=O OR (C<O AND 均价>RC1);
三日二阳:=COUNT(阳柱,3)>=2;
基价柱阳:=RC3>RO3;
价渐升:=(均价>=RJ1 OR C>RC1) AND (RJ1>=RJ2 OR RC1>=RC2);
均价升:=(C+RC1+RC2)/3>RC3;
量渐升:=V>RV1 AND RV1>RV2;
量渐减:=V<RV1 AND RV1<=RV2;
均量减:=((V+RV1+RV2)/3)<=RV3;
日价量比:=C/V;
日价量比升:=日价量比>=REF(日价量比,1) AND REF(日价量比,1)>=REF(日价量比,2);
均价升幅:=(C+RC1+RC2)/3/RC3;
均量升幅:=(V+RV1+RV2)/3/RV3;
价量比:=比系数*均价升幅/均量升幅>1;
基前跳空:=RO3>RC4 AND RC4>RO4;
黄金柱1T:=基价柱阳 AND 价渐升 AND 量渐减 AND 不破价顶 AND 不破价底 AND 基前跳空;
BacKSET101T:=BACKSET(黄金柱1T,5);
FILTER101T:=FILTER(BACKSET101T,4);
黄金柱1:=基价柱阳 AND 价渐升 AND 量渐减 AND 不破价顶 AND 不破价底 ;
BACKSET101:=BACKSET(黄金柱1,4);
FILTER101:=FILTER(BACKSET101,3);
黄金柱11:=黄金柱1 AND REF(黄金柱1,1);
BACKSET1011:=BACKSET(黄金柱11,4);
FILTER1011:=FILTER(BACKSET1011,3);
黄金柱12:=黄金柱1 AND REF(黄金柱1,2);
BACKSET1012:=BACKSET(黄金柱12,4);
FILTER1012:=FILTER(BACKSET1012,3);
黄金柱13:=黄金柱1 AND REF(黄金柱1,3);
BACKSET1013:=BACKSET(黄金柱13,4);
FILTER1013:=FILTER(BACKSET1013,3);
黄金柱2T:=基价柱阳 AND 价渐升 AND 均量减 AND NOT(量渐升) AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱1T);
BA201T:=BACKSET(黄金柱2T,5);
FILTER201T:=FILTER(BA201T,4);
黄金柱2:=基价柱阳 AND 价渐升 AND 均量减 AND NOT(量渐升) AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱1T);
BACKSET201:=BACKSET(黄金柱2,4);
FILTER201:=FILTER(BACKSET201,3);
黄金柱21:=黄金柱2 AND REF(黄金柱2,1);
BACKSET2011:=BACKSET(黄金柱21,4);
FILTER2011:=FILTER(BACKSET2011,3);
黄金柱22:=黄金柱2 AND REF(黄金柱2,2);
BACKSET2012:=BACKSET(黄金柱22,4);
FILTER2012:=FILTER(BACKSET2012,3);
黄金柱23:=黄金柱2 AND REF(黄金柱2,3);
BACKSET2013:=BACKSET(黄金柱23,4);
FILTER2013:=FILTER(BACKSET2013,3);
黄金柱3T:=基价柱阳 AND 均价升 AND 量渐减 AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱1T) AND NOT(黄金柱2T);
BACKSET301T:=BACKSET(黄金柱3T,5);
FILTER301T:=FILTER(BACKSET301T,4);
黄金柱3:=基价柱阳 AND 均价升 AND 量渐减 AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱1T) AND NOT(黄金柱2T);
BACKSET301:=BACKSET(黄金柱3,4);
FILTER301:=FILTER(BACKSET301,3);
黄金柱31:=黄金柱3 AND REF(黄金柱3,1);
BACKSET3011:=BACKSET(黄金柱31,4);
FILTER3011:=FILTER(BACKSET3011,3);
黄金柱32:=黄金柱3 AND REF(黄金柱3,2);
BACKSET3012:=BACKSET(黄金柱32,4);
FILTER3012:=FILTER(BACKSET3012,3);
黄金柱33:=黄金柱3 AND REF(黄金柱3,3);
BACKSET3013:=BACKSET(黄金柱33,4);
FILTER3013:=FILTER(BACKSET3013,3);
黄金柱4T:=基价柱阳 AND 均价升 AND 均量减 AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱1T) AND NOT(黄金柱2) AND NOT(黄金柱2T) AND NOT(黄金柱3) AND NOT(黄金柱3T);
BACKSET401T:=BACKSET(黄金柱4T,5);
FILTER401T:=FILTER(BACKSET401T,4);
黄金柱4:=基价柱阳 AND 均价升 AND 均量减 AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T);
BACKSET401:=BACKSET(黄金柱4,4);
FILTER401:=FILTER(BACKSET401,3);
黄金柱41:=黄金柱4 AND REF(黄金柱4,1);
BACKSET4011:=BACKSET(黄金柱41,4);
FILTER4011:=FILTER(BACKSET4011,3);
黄金柱42:=黄金柱4 AND REF(黄金柱4,2);
BACKSET4012:=BACKSET(黄金柱42,4);
FILTER4012:=FILTER(BACKSET4012,3);
黄金柱43:=黄金柱4 AND REF(黄金柱4,3);
BACKSET4013:=BACKSET(黄金柱43,4);
FILTER4013:=FILTER(BACKSET4013,3);
黄金柱5T:=基价柱阳 AND 均价升 AND 价量比 AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T);
BACKSET501T:=BACKSET(黄金柱5T,5);
FILTER501T:=FILTER(BACKSET501T,4);
黄金柱5:=基价柱阳 AND 均价升 AND 价量比 AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T);
BACKSET501:=BACKSET(黄金柱5,4);
FILTER501:=FILTER(BACKSET501,3);
黄金柱51:=黄金柱5 AND REF(黄金柱5,1);
BACKSET5011:=BACKSET(黄金柱51,4);
FILTER5011:=FILTER(BACKSET5011,3);
黄金柱52:=黄金柱5 AND REF(黄金柱5,2);
BACKSET5012:=BACKSET(黄金柱52,4);
FILTER5012:=FILTER(BACKSET5012,3);
黄金柱53:=黄金柱5 AND REF(黄金柱5,3);
BASET5013:=BACKSET(黄金柱53,4);
FILTER5013:=FILTER(BASET5013,3);
黄金柱6T:=基价柱阳 AND 均价升 AND 日价量比升 AND 不破价顶 AND 不破价底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱5) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T) AND NOT(黄金柱5T);
BACKSET601T:=BACKSET(黄金柱6T,5);
FILTER601T:=FILTER(BACKSET601T,4);
黄金柱6:=基价柱阳 AND 均价升 AND 日价量比升 AND 不破价顶 AND 不破价底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱5) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T) AND NOT(黄金柱5T);
BACKSET601:=BACKSET(黄金柱6,4);
FILTER601:=FILTER(BACKSET601,3);
黄金柱61:=黄金柱6 AND REF(黄金柱6,1);
BACKSET6011:=BACKSET(黄金柱61,4);
FILTER6011:=FILTER(BACKSET6011,3);
黄金柱62:=黄金柱6 AND REF(黄金柱6,2);
BACKSET6012:=BACKSET(黄金柱62,4);
FILTER6012:=FILTER(BACKSET6012,3);
黄金柱63:=黄金柱6 AND REF(黄金柱6,3);
BACKSET6013:=BACKSET(黄金柱63,4);
FILTER6013:=FILTER(BACKSET6013,3);
FIL1:=(FILTER101 AND NOT(REF(FILTER101,4))) OR (FILTER1011 AND NOT(REF(FILTER1011,4))) OR (FILTER1012 AND NOT(REF(FILTER1012,4))) OR (FILTER1013 AND NOT(REF(FILTER1013,4)));
FIL2:=(FILTER201 AND NOT(REF(FILTER201,4))) OR (FILTER2011 AND NOT(REF(FILTER2011,4))) OR (FILTER2012 AND NOT(REF(FILTER2012,4))) OR (FILTER2013 AND NOT(REF(FILTER2013,4)));
FIL3:=(FILTER301 AND NOT(REF(FILTER301,4))) OR (FILTER3011 AND NOT(REF(FILTER3011,4))) OR (FILTER3012 AND NOT(REF(FILTER3012,4))) OR (FILTER3013 AND NOT(REF(FILTER3013,4)));
FIL4:=(FILTER401 AND NOT(REF(FILTER401,4))) OR (FILTER4011 AND NOT(REF(FILTER4011,4))) OR (FILTER4012 AND NOT(REF(FILTER4012,4))) OR (FILTER4013 AND NOT(REF(FILTER4013,4)));
FIL5:=(FILTER501 AND NOT(REF(FILTER501,4))) OR (FILTER5011 AND NOT(REF(FILTER5011,4))) OR (FILTER5012 AND NOT(REF(FILTER5012,4))) OR (FILTER5013 AND NOT(REF(FILTER5013,4)));
FIL6:=(FILTER601 AND NOT(REF(FILTER601,4))) OR (FILTER6011 AND NOT(REF(FILTER6011,4))) OR (FILTER6012 AND NOT(REF(FILTER6012,4))) OR (FILTER6013 AND NOT(REF(FILTER6013,4)));
FIL:=(FIL1 OR FIL2 OR FIL3 OR FIL4 OR FIL5 OR FIL6) AND BETWEEN(V,REF(V,1)*1.8,REF(V,1)*5),COLOR0099FF;
STICKLINE(FIL AND NOT(REF(FIL,4)),O,C,1,0),COLORYELLOW;
K1:=SUMBARS(FIL,1);
STICKLINE(K1 AND 金线=1,REF(C,K1-1),REF(C,K1-1),4,0),COLORWHITE;
FIL1T:=(FILTER101T AND NOT(REF(FILTER101T,5)));
FIL2T:=(FILTER201T AND NOT(REF(FILTER201T,5)));
FIL3T:=(FILTER301T AND NOT(REF(FILTER301T,5)));
FIL4T:=(FILTER401T AND NOT(REF(FILTER401T,5)));
FIL5T:=(FILTER501T AND NOT(REF(FILTER501T,5)));
FIL6T:=(FILTER601T AND NOT(REF(FILTER601T,5)));
FILT:FIL1T OR FIL2T OR FIL3T OR FIL4T OR FIL5T OR FIL6T,NODRAW;
STICKLINE(FILT AND NOT(REF(FILT,5)),OPEN,CLOSE,2.5,0),COLORYELLOW;
STICKLINE(FILT AND NOT(REF(FILT,5)),OPEN,CLOSE,1,0),COLORFF00FF;
DRAWTEXT (FILT AND NOT(REF(FILT,5)),MIN(C,O)*0.983,’通达信庄氏量学主图指标公式元帅柱’),COLOR0000FF;
K2:=SUMBARS(FILT AND NOT(REF(FILT,5)),1);
STICKLINE(K2 AND 金线=1,REF(C,K2-1),REF(C,K2-1),5,0),COLOR9900FF;
TZ:FIL OR FILT ,NODRAW;
{解盘}
呈阴:=C<(REF(C,1)+REF(O,1))/2;{体现阴胜阳}
DRAWICON(呈阴 AND COUNT(呈阴,5)=1,H*1.03,2),COLORGREEN;
呈阳:=C>(REF(C,1)+REF(O,1))/2;{收盘价在昨天的K线实体上半部分,体现阳胜阴}
DRAWICON(呈阳 AND COUNT(呈阳,5)=1 AND 月线>REF(月线,1),L*0.99,2),COLORRED;
上吊线:=H/MAX(O,C)>1.03;{上影线>3%}
DRAWICON(上吊线 AND H=HHV(H,5) AND H>REFX(H,1) ,H*1.02,2),COLORYELLOW;
上阻线:=H/MAX(O,C)>MAX(C,O)/MIN(C,O);{上影线长于实体线}
下阻线:=MIN(C,O)/L>MAX(C,O)/MIN(C,O);{下影线长于实体线}
STICKLINE(ISLASTBAR AND 上阻线,(H+MAX(C,O))/2,(H+MAX(C,O))/2,10,0),COLORYELLOW;
STICKLINE(ISLASTBAR AND 下阻线,(MIN(C,O)+L)/2,(MIN(C,O)+L)/2,10,0),COLORYELLOW;
人龙:=(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4;
天龙:=人龙+3*STD(人龙,10);
地龙:=人龙-3*STD(人龙,10);
DRAWTEXT(C>天龙 AND L<地龙,L*0.98,’买入’),COLORYELLOW;
STICKLINE(C>天龙 AND L<地龙,CLOSE,O,3,0),COLOR000099;
STICKLINE(C>天龙 AND L<地龙,CLOSE,O,2,0),COLOR0000CC;
STICKLINE(C>天龙 AND L<地龙,CLOSE,O,1,0),COLORBB22BB;
STICKLINE(C>天龙 AND L<地龙,H,L,0,0),COLORWHITE;
DRAWLINE(凹口,MIN(C,O),REF(凹口,1),REF(MIN(C,O),1),1),COLORGREEN,LINETHICK2;
DRAWLINE(凹底,MIN(C,O),REF(凹底,1),REF(MIN(C,O),1),1),COLORRED,LINETHICK2;
STICKLINE(JYZY,O,C,0.2,0),COLORRED;{假阴柱};
STICKLINE(假阳,O,C,0.5,0),COLORLIGREEN;{假阳柱};
DAY3:=REF(C<O,3);
DAY2:=REF(C<REF(C,1) AND C<O,2);
DAY1:=REF(C<O,1);
DAY0:=DAY1 AND DAY2 AND DAY3 AND C>REF(C,1) AND C>O AND C>REF(O,2) AND C>MA(C,10);
DRAWTEXT(DAY0,L-0.15,’3B’);
大盘:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
逆势板:=大盘<0 AND ZT;
DRAWTEXT(逆势板,L,’逆’),COLORFFFF00;
收阴:=(C<REF(C,1) OR L<REF(L,1) OR AMOUNT/V/100<REF((C+O)/2,1)) AND O<=REF(C,1);
多阴:=EVERY(收阴,2);
小阳:=O-L<=0.03 AND H>C AND C>O AND O<REF(C,1) AND C<REF(MAX(C,O),1) AND V<REF(V,1);
宝莲灯:=REF(多阴,1) AND 小阳;
STICKLINE(宝莲灯,O,C,2.5,0),COLORCC22FF;
STICKLINE(宝莲灯,(O+C)/2,(O+C)/2+0.02,1.8,0),COLORWHITE;
SY:=H/MAX(C,O);
必跌形态:=EVERY((L>REF(L,1) OR H>REF(H,1)) AND SY>1.02,4);
DRAWTEXT(必跌形态,H*0.98,’卖’),COLORCCFF00;
DFL:=L=LLV(L,10) AND L<REF(L,1) AND L<REFX(L,1) AND REFX(C,1)>REF(C,1) AND REFX(C>O,1);
DRAWTEXT(DFL,L*0.995,’底’),COLORLIRED;
DFH:=H=HHV(H,10) AND H>REF(H,1) AND H>REFX(H,1) AND REFX(C,1)<REF(C,1);
DRAWTEXT(FILTER(H>REFX(H,1) AND H=HHV(H,10),5) AND DFH,H,’顶’),COLORGREEN;
A1:=EMA(C,12)-EMA(C,25);
A2:=EMA(A1,6);
获利回吐:=(A2>=0)*A2,COLORWHITE,LINETHICK0;
大黑马:=(A2<0)*A2,COLORD4FF7F,LINETHICK0;
坚绝做空:=(A1<0)*A1,COLORB00058,LINETHICK0;
买入持股:=(A1>=0)*A1,COLORRED,LINETHICK0;
VAR8:=V>2*MA(V,30);
VARB:=C>MA(C,30) AND C<MA(C,30)*1.04;
VARC:=MA(C,30)>REF(MA(C,30),1);
VARD:=BARSLAST(crOSS(MA(C,5),MA(C,10)))<BARSLAST(CROSS(MA(C,10),MA(C,5)));
VARF:=TROUGHBARS(3,15,1)<4;
VAR10:=EMA(C,30)>REF(EMA(C,30),2);
VAR11:=IF(VARF=1,50,0);
多空:=EMA((C-MA((2*C+H+L)/4,30))/MA((2*C+H+L)/4,30)*100,3),COLORWHITE;
DRAWTEXT(FILTER(VARF=1,3),L*0.973,’黑’),COLORRED ;
AF1:=REF(obv.OBV,P)=HHV(OBV.OBV,2*P+1);
BF1:=FILTER(AF1,P);
CF1:=BACKSET(BF1,P+1);
DF1:=FILTER(CF1,P);{高点}
MA5:=MA(C,5),COLORWHITE;
MA10:=MA(C,10),COLORYELLOW;
MA20:=MA(C,20),COLORFF00FF;
MA30:=MA(C,30);
MA55:=MA(C,55);
上:=REF(OBV,BARSLAST(DF1));
M50:=EMA(OBV,50);
DRAWTEXT(M50>REF(M50,1) AND CROSS(OBV,上*1.01),MA5,’上’),COLORYELLOW;
DRAWICON((zig(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,7);
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.02,8);
低ZK:=REF(C,1)<MA5 AND REF(C,1)<MA10 AND REF(C,1)<MA20 AND REF(L,1)<MA30 AND REF(L,1)<MA55;
低K:=O<MA5 AND O<MA10 AND O<MA20 AND L<MA30 AND L<MA55;
高K:=C>MA5 AND C>MA10 AND H>MA20 AND H>MA30 AND H>MA55;
HSLZ:=V*10000/FINANCE(46);
穿多线:=C>REF(C,1)*1.02 AND H<C+0.06 AND (低K OR 低ZK) AND 高K AND V>REF(V,1) AND HSLZ>=1.5;
DRAWTEXT(穿多线,L*0.99,’通达信庄氏量学主图指标公式一穿五’),COLORYELLOW;
VASS1:=HHV(H,60);
VASS2:=LLV(L,60);
VASS3:=REF((VASS1/VASS2-1)*100<=30,1);
AHC1:=C*V;
AHC22:=EMA((expma(AHC1,23)/EXPMA(V,23)+EXPMA(AHC1,54)/EXPMA(V,54)+EXPMA(AHC1,108)/EXPMA(V,108)+EXPMA(AHC1,316)/EXPMA(V,316))/4,34);
通道:=1.0668*AHC22;
起爆:=CROSS(C,通道) AND REF(C,1)*1.05-C<0.005 AND C>O*0.5;
VARR1:=V;
VARR2:=VARR1>MA(V,89);
VARR3:=EXPMA(C,5);
VARR4:=EXPMA(C,29);
VARR5:=VARR3>VARR4;
LC:=REF(C,1);
rsi1:=SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),12,1)*100;
RSI2:=SMA(MAX(C-LC,0),56,1)/SMA(ABS(C-LC),56,1)*100;
VARR6:=RSI1>RSI2 AND VARR5 AND VARR2 AND C>REF(HHV(H,60),1);
黑马起爆:=起爆 AND VARR6 AND VASS3,COLORFF00FF,LINETHICK2;
DRAWTEXT(黑马起爆,L,’通达信庄氏量学主图指标公式黑马1号’),COLORFF00FF;
阴阳皇帝:=EXIST(L=LLV(L,10),3) AND REF(DT OR DT1,1) AND (ZT1 OR ZT);
DRAWTEXT(阴阳皇帝,L*0.97,’皇帝’),COLORFFFFFF;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 通达信 通达信庄氏量学主图指标公式 https://www.694.cn/ziliaoxiazai/tongdaxin/5429.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务