通达信 第二代极品双响炮抓牛指标

2024-04-27 0 924

拥有此套操作系统后需要你做的事情就是准备好你手中的资金,耐心等待目标的出现,当出现目标后就可大胆出击,千万不要去走私哦,否则你就会痛失机会的。
本操作系统适合做超短、短线以及波段,比较灵活,实战成功率极高

 

通达信 第二代极品双响炮抓牛指标

{公式名称: 二代双响主图
公式描述:
无参数
公式类型: 技术指标公式-其他类型
画线方法: 主图叠加
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无
参数精灵:无
用法注释:无
公式源码:}
MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,20);
MA4:MA(CLOSE,30);
MA5:MA(CLOSE,60);
强势线:MA(CLOSE,25)+MA(CLOSE,25)*20/100,COLORRED,LINETHICK2;
TC3:=REF(CLOSE,1);
涨停:=IF((CLOSE-TC3)*100/TC3>=10-0.03*100/TC3,1,0);
TDXSTEP114:STICKLINE(涨停,OPEN,CLOSE,1.5,0),COLORYELLOW;
跌停:=IF((TC3-CLOSE)*100/TC3>=10-0.03*100/TC3,1,0);
TDXSTEP115:STICKLINE(跌停,OPEN,CLOSE,1.5,0),COLORBLUE;
VAR2:=CLOSE*VOL;
VAR3:=EMA((EMA(VAR2,3)/EMA(VOL,3)+EMA(VAR2,6)/EMA(VOL,6)+EMA(VAR2,12)/EMA(VOL,12)+EMA(VAR2,24)/EMA(VOL,24))/4,13);
上:=SMA(HIGH,21,2)*1.05;
BMA:=MA(CLOSE,118);
阻挡:=SMA(HIGH,21,2)*1.05;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV12:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K12:=SMA(RSV12,3,1);
D12:=SMA(K12,3,1);
J12:=3*K12-2*D12;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
压力位:IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J)))),COLORGREEN,LINETHICK2;
DF:=BETWEEN(CLOSE/REF(CLOSE,1),1.0983,1.11);
Z:=(OPEN+HIGH)/2;
B1:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)>REF(OPEN,3);
B2:=HIGH/REF(CLOSE,1)>=1.041 AND (OPEN/REF(OPEN,3)<1.05 OR REF(OPEN,1)/REF(OPEN,3)<1.05) AND REF(CLOSE,3)/OPEN>1.02;
XG2:=B1 AND B2;
C1:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)>REF(OPEN,4);
C2:=HIGH/REF(CLOSE,1)>=1.041 AND (OPEN/REF(OPEN,4)<1.05 OR REF(OPEN,1)/REF(OPEN,4)<1.05) AND OPEN<REF(CLOSE,4);
C3:=REF(CLOSE,4)/OPEN>1.02;
XG3:=C1 AND C2 AND C3;
D1:=REF(CLOSE,5)/REF(CLOSE,6)>1.09 AND REF(CLOSE,5)>REF(OPEN,5);
D2:=HIGH/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,5),1.05,0.85);
XG4:=D1 AND D2;
E1:=REF(CLOSE,6)/REF(CLOSE,7)>1.09 AND REF(CLOSE,6)>REF(OPEN,6);
E2:=HIGH/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,6),1.05,0.85);
XG5:=E1 AND E2;
F1:=REF(CLOSE,7)/REF(CLOSE,8)>1.095 AND REF(CLOSE,7)>REF(OPEN,7);
F2:=HIGH/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,7),1.05,0.85);
XG6:=F1 AND F2;
G1:=REF(CLOSE,8)/REF(CLOSE,9)>1.095 AND REF(CLOSE,8)>REF(OPEN,8);
G2:=HIGH/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,8),1.05,0.85);
XG7:=G1 AND G2;
H1:=REF(CLOSE,9)/REF(CLOSE,10)>1.095 AND REF(CLOSE,9)>REF(OPEN,9);
H2:=CLOSE/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,9),1.05,0.92);
H3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
XG8:=H1 AND H2 AND H3;
J1:=REF(CLOSE,10)/REF(CLOSE,11)>1.095 AND REF(CLOSE,10)>REF(OPEN,10);
J2:=CLOSE/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,10),1.05,0.92);
J3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
XG9:=J1 AND J2 AND J3;
L1:=REF(CLOSE,11)/REF(CLOSE,12)>1.095 AND REF(CLOSE,11)>REF(OPEN,11);
L2:=CLOSE/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,11),1.05,0.92);
L3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
XG10:=L1 AND L2 AND L3;
M1:=REF(CLOSE,12)/REF(CLOSE,13)>1.095 AND REF(CLOSE,12)>REF(OPEN,12) AND REF(CLOSE,13)/REF(CLOSE,14)<1.09;
M2:=CLOSE/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,12),1.05,0.92);
M3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
XG11:=M1 AND M2 AND M3;
N1:=REF(CLOSE,13)/REF(CLOSE,14)>1.095 AND REF(CLOSE,13)>REF(OPEN,13);
N2:=HIGH/REF(CLOSE,1)>1.04 AND LOW<REF(CLOSE,13);
N3:=CROSS(CLOSE,MA(CLOSE,5)) AND MA(CLOSE,5)>MA(CLOSE,20) AND CLOSE>MA(CLOSE,20);
XG12:=N1 AND N2 AND N3;
ZHXG1:=XG2 OR XG3 OR XG4 OR XG5 OR XG6 OR XG7 OR XG8 OR XG9 OR XG10 OR XG11 OR XG12;
PH1:=REF(CLOSE,9)/REF(CLOSE,10)>1.095 AND REF(CLOSE,9)>REF(OPEN,9);
PH2:=HIGH/REF(CLOSE,1)>1.041 AND LOW<REF(CLOSE,9);
PH3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
PXG8:=PH1 AND PH2 AND PH3;
PJ1:=REF(CLOSE,10)/REF(CLOSE,11)>1.095 AND REF(CLOSE,10)>REF(OPEN,10);
PJ2:=HIGH/REF(CLOSE,1)>1.041 AND LOW<REF(CLOSE,10);
PJ3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
PXG9:=PJ1 AND PJ2 AND PJ3;
PL1:=REF(CLOSE,11)/REF(CLOSE,12)>1.095 AND REF(CLOSE,11)>REF(OPEN,11);
PL2:=HIGH/REF(CLOSE,1)>1.041 AND LOW<REF(CLOSE,11);
PL3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
PXG10:=PL1 AND PL2 AND PL3;
PM1:=REF(CLOSE,12)/REF(CLOSE,13)>1.095 AND REF(CLOSE,12)>REF(OPEN,12) AND REF(CLOSE,13)/REF(CLOSE,14)<1.09;
PM2:=HIGH/REF(CLOSE,1)>1.041 AND LOW<REF(CLOSE,12);
PM3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
PXG11:=PM1 AND PM2 AND PM3;
VXG:=LOW<压力位 AND CLOSE>压力位;
上轨道:=MA(CLOSE,25)+MA(CLOSE,25)*20/100;
CQSX:=CROSS(CLOSE,上轨道);
ZHXG2:=PXG8 OR PXG9 OR PXG10 OR PXG11 AND VXG AND CQSX;
PDM1:=CLOSE/REF(CLOSE,1)>1.07 AND CLOSE/OPEN>1.05 AND HIGH/CLOSE<CLOSE/OPEN;
PDM2:=BETWEEN(OPEN/REF(HIGH,1),1.01,1.08) AND CLOSE/REF(CLOSE,1)>1.041 AND REF(CLOSE,1)/REF(CLOSE,2)<1.04;
PDM3:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,10)>MA(CLOSE,30) AND MA(CLOSE,30)>MA(CLOSE,60);
PDM4:=REF(CLOSE,1)/REF(CLOSE,2)<1.09 AND REF(CLOSE,2)/REF(CLOSE,3)<1.09;
PDXG:=COUNT(REF(PDM1,1),20) AND PDM2 AND PDM3 AND PDM4;
YZB1:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)=REF(OPEN,3);
YZB2:=HIGH/REF(CLOSE,1)>=1.041 AND OPEN<REF(CLOSE,3);
YZXG2:=YZB1 AND YZB2;
YZC1:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)=REF(OPEN,4);
YZC2:=HIGH/REF(CLOSE,1)>=1.041 AND OPEN<REF(CLOSE,4);
YZXG3:=YZC1 AND YZC2;
YZZH:=YZXG2 OR YZXG3;
KM1:=CLOSE/REF(CLOSE,1)>1.095 AND CLOSE=HIGH AND OPEN<MA(CLOSE,10) AND CLOSE>MA(CLOSE,10) AND OPEN<MA(CLOSE,20) AND CLOSE>MA(CLOSE,20) AND OPEN<MA(CLOSE,30) AND CLOSE>MA(CLOSE,30);
DM1:=HIGH/REF(CLOSE,1)>1.041 AND LOW<MA(CLOSE,5) AND CLOSE>MA(CLOSE,5) AND LOW<MA(CLOSE,10) AND CLOSE>MA(CLOSE,10) AND LOW<MA(CLOSE,20) AND CLOSE>MA(CLOSE,20) AND (LOW<MA(CLOSE,60) AND CLOSE>MA(CLOSE,60) OR (LOW<MA(CLOSE,120) AND CLOSE>MA(CLOSE,120)));
KDXG:=COUNT(REF(KM1,3),12) AND DM1;
GKB1:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)>REF(OPEN,3);
GKB2:=HIGH/REF(CLOSE,1)>=1.041 AND HIGH/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,3),1.06,0.92) AND REF(VOL,1)<REF(VOL,2) AND REF(HIGH,2)/MAX(REF(OPEN,2),REF(CLOSE,2))<1.07 AND MA(CLOSE,20)/MA(CLOSE,30)<1.05 AND REF(LOW,2)<REF(CLOSE,3);
GKXG1:=GKB1 AND GKB2;
GKC1:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)>REF(OPEN,4);
GKC2:=HIGH/REF(CLOSE,1)>=1.041 AND CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,4),1.06,0.92);
GKC3:=REF(VOL,1)<REF(VOL,2) AND REF(VOL,2)<REF(VOL,3) AND REF(HIGH,3)/MAX(REF(OPEN,3),REF(CLOSE,3))<1.07 AND HIGH>MA(CLOSE,5) AND CLOSE>MA(CLOSE,10) AND CLOSE>MA(CLOSE,30) AND REF(LOW,3)<REF(CLOSE,4);
GKXG2:=GKC1 AND GKC2 AND GKC3;
GKXGXG:=GKXG1 OR GKXG2;
ZHXGXG:=ZHXG1 OR ZHXG2 OR YZZH OR KDXG OR GKXGXG;
TDXSTEP116:DRAWICON(ZHXGXG,LOW*0.96,11);
TDXSTEP117:DRAWTEXT(ZHXGXG,LOW*0.92,1),COLORYELLOW;
{公式名称: 二代双响副图
公式描述:
无参数
公式类型: 技术指标公式-其他类型
画线方法: 副图
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无
参数精灵:无
用法注释:无
公式源码:}
B1:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)>REF(OPEN,3);
B2:=HIGH/REF(CLOSE,1)>=1.041 AND (OPEN/REF(OPEN,3)<1.05 OR REF(OPEN,1)/REF(OPEN,3)<1.05) AND REF(CLOSE,3)/OPEN>1.02;
XG2:=B1 AND B2;
C1:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)>REF(OPEN,4);
C2:=HIGH/REF(CLOSE,1)>=1.041 AND (OPEN/REF(OPEN,4)<1.05 OR REF(OPEN,1)/REF(OPEN,4)<1.05) AND OPEN<REF(CLOSE,4);
C3:=REF(CLOSE,4)/OPEN>1.02;
XG3:=C1 AND C2 AND C3;
D1:=REF(CLOSE,5)/REF(CLOSE,6)>1.09 AND REF(CLOSE,5)>REF(OPEN,5);
D2:=HIGH/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,5),1.05,0.85);
XG4:=D1 AND D2;
E1:=REF(CLOSE,6)/REF(CLOSE,7)>1.09 AND REF(CLOSE,6)>REF(OPEN,6);
E2:=HIGH/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,6),1.05,0.85);
XG5:=E1 AND E2;
F1:=REF(CLOSE,7)/REF(CLOSE,8)>1.095 AND REF(CLOSE,7)>REF(OPEN,7);
F2:=HIGH/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,7),1.05,0.85);
XG6:=F1 AND F2;
G1:=REF(CLOSE,8)/REF(CLOSE,9)>1.095 AND REF(CLOSE,8)>REF(OPEN,8);
G2:=HIGH/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,8),1.05,0.85);
XG7:=G1 AND G2;
H1:=REF(CLOSE,9)/REF(CLOSE,10)>1.095 AND REF(CLOSE,9)>REF(OPEN,9);
H2:=CLOSE/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,9),1.05,0.92);
H3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
XG8:=H1 AND H2 AND H3;
J1:=REF(CLOSE,10)/REF(CLOSE,11)>1.095 AND REF(CLOSE,10)>REF(OPEN,10);
J2:=CLOSE/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,10),1.05,0.92);
J3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
XG9:=J1 AND J2 AND J3;
L1:=REF(CLOSE,11)/REF(CLOSE,12)>1.095 AND REF(CLOSE,11)>REF(OPEN,11);
L2:=CLOSE/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,11),1.05,0.92);
L3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
XG10:=L1 AND L2 AND L3;
M1:=REF(CLOSE,12)/REF(CLOSE,13)>1.095 AND REF(CLOSE,12)>REF(OPEN,12) AND REF(CLOSE,13)/REF(CLOSE,14)<1.09;
M2:=CLOSE/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,12),1.05,0.92);
M3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
XG11:=M1 AND M2 AND M3;
N1:=REF(CLOSE,13)/REF(CLOSE,14)>1.095 AND REF(CLOSE,13)>REF(OPEN,13);
N2:=HIGH/REF(CLOSE,1)>1.04 AND LOW<REF(CLOSE,13);
N3:=CROSS(CLOSE,MA(CLOSE,5)) AND MA(CLOSE,5)>MA(CLOSE,20) AND CLOSE>MA(CLOSE,20);
XG12:=N1 AND N2 AND N3;
ZHXG1:=XG2 OR XG3 OR XG4 OR XG5 OR XG6 OR XG7 OR XG8 OR XG9 OR XG10 OR XG11 OR XG12;
PH1:=REF(CLOSE,9)/REF(CLOSE,10)>1.095 AND REF(CLOSE,9)>REF(OPEN,9);
PH2:=HIGH/REF(CLOSE,1)>1.041 AND LOW<REF(CLOSE,9);
PH3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
PXG8:=PH1 AND PH2 AND PH3;
PJ1:=REF(CLOSE,10)/REF(CLOSE,11)>1.095 AND REF(CLOSE,10)>REF(OPEN,10);
PJ2:=HIGH/REF(CLOSE,1)>1.041 AND LOW<REF(CLOSE,10);
PJ3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
PXG9:=PJ1 AND PJ2 AND PJ3;
PL1:=REF(CLOSE,11)/REF(CLOSE,12)>1.095 AND REF(CLOSE,11)>REF(OPEN,11);
PL2:=HIGH/REF(CLOSE,1)>1.041 AND LOW<REF(CLOSE,11);
PL3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
PXG10:=PL1 AND PL2 AND PL3;
PM1:=REF(CLOSE,12)/REF(CLOSE,13)>1.095 AND REF(CLOSE,12)>REF(OPEN,12) AND REF(CLOSE,13)/REF(CLOSE,14)<1.09;
PM2:=HIGH/REF(CLOSE,1)>1.041 AND LOW<REF(CLOSE,12);
PM3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
PXG11:=PM1 AND PM2 AND PM3;
上:=SMA(HIGH,21,2)*1.05;
BMA:=MA(CLOSE,118);
阻挡:=SMA(HIGH,21,2)*1.05;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV12:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K12:=SMA(RSV12,3,1);
D12:=SMA(K12,3,1);
J12:=3*K12-2*D12;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
压力位:=IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J))));
VXG:=LOW<压力位 AND CLOSE>压力位;
上轨道:=MA(CLOSE,25)+MA(CLOSE,25)*20/100;
CQSX:=LOW<上轨道 AND CLOSE>上轨道;
ZHXG2:=PXG8 OR PXG9 OR PXG10 OR PXG11 AND VXG AND CQSX;
PDM1:=CLOSE/REF(CLOSE,1)>1.07 AND CLOSE/OPEN>1.05 AND HIGH/CLOSE<CLOSE/OPEN;
PDM2:=BETWEEN(OPEN/REF(HIGH,1),1.01,1.08) AND CLOSE/REF(CLOSE,1)>1.041 AND REF(CLOSE,1)/REF(CLOSE,2)<1.04;
PDM3:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,10)>MA(CLOSE,30) AND MA(CLOSE,30)>MA(CLOSE,60);
PDM4:=REF(CLOSE,1)/REF(CLOSE,2)<1.09 AND REF(CLOSE,2)/REF(CLOSE,3)<1.09;
PDXG:=COUNT(REF(PDM1,1),20) AND PDM2 AND PDM3 AND PDM4;
YZB1:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)=REF(OPEN,3);
YZB2:=HIGH/REF(CLOSE,1)>=1.041 AND OPEN<REF(CLOSE,3);
YZXG2:=YZB1 AND YZB2;
YZC1:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)=REF(OPEN,4);
YZC2:=HIGH/REF(CLOSE,1)>=1.041 AND OPEN<REF(CLOSE,4);
YZXG3:=YZC1 AND YZC2;
YZZH:=YZXG2 OR YZXG3;
KM1:=CLOSE/REF(CLOSE,1)>1.095 AND CLOSE=HIGH AND OPEN<MA(CLOSE,10) AND CLOSE>MA(CLOSE,10) AND OPEN<MA(CLOSE,20) AND CLOSE>MA(CLOSE,20) AND OPEN<MA(CLOSE,30) AND CLOSE>MA(CLOSE,30);
DM1:=HIGH/REF(CLOSE,1)>1.041 AND LOW<MA(CLOSE,5) AND CLOSE>MA(CLOSE,5) AND LOW<MA(CLOSE,10) AND CLOSE>MA(CLOSE,10) AND LOW<MA(CLOSE,20) AND CLOSE>MA(CLOSE,20) AND (LOW<MA(CLOSE,60) AND CLOSE>MA(CLOSE,60) OR (LOW<MA(CLOSE,30) AND CLOSE>MA(CLOSE,30)));
KDXG:=COUNT(REF(KM1,3),12) AND DM1;
GKB1:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)>REF(OPEN,3);
GKB2:=HIGH/REF(CLOSE,1)>=1.041 AND HIGH/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,3),1.06,0.92) AND REF(VOL,1)<REF(VOL,2) AND REF(HIGH,2)/MAX(REF(OPEN,2),REF(CLOSE,2))<1.07 AND MA(CLOSE,20)/MA(CLOSE,30)<1.05 AND REF(LOW,2)<REF(CLOSE,3);
GKXG1:=GKB1 AND GKB2;
GKC1:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)>REF(OPEN,4);
GKC2:=HIGH/REF(CLOSE,1)>=1.041 AND CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,4),1.06,0.92);
GKC3:=REF(VOL,1)<REF(VOL,2) AND REF(VOL,2)<REF(VOL,3) AND REF(HIGH,3)/MAX(REF(OPEN,3),REF(CLOSE,3))<1.07 AND HIGH>MA(CLOSE,5) AND CLOSE>MA(CLOSE,10) AND CLOSE>MA(CLOSE,30) AND REF(LOW,3)<REF(CLOSE,4);
GKXG2:=GKC1 AND GKC2 AND GKC3;
GKXGXG:=GKXG1 OR GKXG2;
ZHXGXG:ZHXG1 OR ZHXG2 OR YZZH OR KDXG OR GKXGXG;
KH1:=REF(CLOSE,1)/REF(CLOSE,2)<=0.96 OR (REF(OPEN,1)/REF(CLOSE,1)>=1.035 AND REF(CLOSE,1)/REF(CLOSE,2)<=0.965);
KH2:=HIGH/REF(CLOSE,1)>1.04 AND HIGH>REF(CLOSE,1);
XGKH1:=KH1 AND KH2;
XGKH2:=REF(CLOSE,2)/REF(CLOSE,3)<1.099;
XGKY:=XGKH1 AND XGKH2;
ABKXG:=ZHXGXG AND XGKY;
TDXSTEP118:DRAWTEXT(ABKXG,0.4,2),COLORWHITE;
AM2:=REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,3)/REF(CLOSE,4)<0.965 AND REF(CLOSE,2)/REF(CLOSE,3)<1.02 AND REF(CLOSE,1)/REF(CLOSE,2)<1.02 AND CLOSE/REF(CLOSE,1)>1.041 AND CLOSE>OPEN;
AM3:=MAX(REF(CLOSE,1),REF(OPEN,1))/MIN(REF(CLOSE,1),REF(OPEN,1))<1.02 AND MAX(REF(CLOSE,2),REF(OPEN,2))/MIN(REF(CLOSE,2),REF(OPEN,2))<1.02;
AM4:=MA(CLOSE,5)>MA(CLOSE,20);
AXGM:=AM2 AND AM3 AND AM4;
BM1:=CLOSE/REF(CLOSE,1)>1.09 AND CLOSE/OPEN>1.03;
BM2:=REF(CLOSE,2)/REF(CLOSE,3)<0.965 AND REF(CLOSE,1)/REF(CLOSE,2)<1.03 AND CLOSE/REF(CLOSE,1)>1.041 AND CLOSE>OPEN;
BM3:=MAX(REF(CLOSE,1),REF(OPEN,1))/MIN(REF(CLOSE,1),REF(OPEN,1))<1.03;
BXGM:=COUNT(REF(BM1,1),10) AND BM2 AND BM3;
ABXG:=ZHXGXG AND (AXGM OR BXGM);
TDXSTEP119:DRAWTEXT(ABXG,0.6,3),COLORRED;
TDXSTEP120:DRAWTEXT(KDXG,0.7,4),COLORYELLOW;
TPLX:=ZHXGXG AND VXG AND CQSX;
TDXSTEP121:DRAWTEXT(TPLX AND NOT(REF(TPLX,1)),0.8,5),COLORYELLOW;
TDXSTEP122:DRAWTEXT(GKXGXG,0.5,6),COLORYELLOW;
ZXMD1:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,5)>MA(CLOSE,20) AND MA(CLOSE,10)>MA(CLOSE,30) AND MA(CLOSE,30)>MA(CLOSE,60) AND HIGH>MA(CLOSE,5) AND CLOSE>MA(CLOSE,10) AND CLOSE>MA(CLOSE,30) AND MA(CLOSE,10)/MA(CLOSE,20)<1.1 AND MA(CLOSE,20)/MA(CLOSE,30)<1.1;
ZXMD2:=CLOSE>MA(CLOSE,5) AND CLOSE>MA(CLOSE,10) AND CLOSE>MA(CLOSE,30) AND VXG;
XGMDXG:=GKXGXG AND (ZXMD1 OR ZXMD2);
TDXSTEP123:DRAWTEXT(XGMDXG,0.8,7),COLORRED;
{公式名称: 二代双响选股
公式描述:
无参数
公式类型: 条件选股公式-其他类型
公式版本: 0
参数精灵:无
用法注释:无
公式源码:}
VAR2:=CLOSE*VOL;
VAR3:=EMA((EMA(VAR2,3)/EMA(VOL,3)+EMA(VAR2,6)/EMA(VOL,6)+EMA(VAR2,12)/EMA(VOL,12)+EMA(VAR2,24)/EMA(VOL,24))/4,13);
上:=SMA(HIGH,21,2)*1.05;
BMA:=MA(CLOSE,118);
阻挡:=SMA(HIGH,21,2)*1.05;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV12:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K12:=SMA(RSV12,3,1);
D12:=SMA(K12,3,1);
J12:=3*K12-2*D12;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
压力位:=IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J))));
DF:=BETWEEN(CLOSE/REF(CLOSE,1),1.0983,1.11);
Z:=(OPEN+HIGH)/2;
B1:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)>REF(OPEN,3);
B2:=HIGH/REF(CLOSE,1)>=1.041 AND (OPEN/REF(OPEN,3)<1.05 OR REF(OPEN,1)/REF(OPEN,3)<1.05) AND REF(CLOSE,3)/OPEN>1.02;
XG2:=B1 AND B2;
C1:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)>REF(OPEN,4);
C2:=HIGH/REF(CLOSE,1)>=1.041 AND (OPEN/REF(OPEN,4)<1.05 OR REF(OPEN,1)/REF(OPEN,4)<1.05) AND OPEN<REF(CLOSE,4);
C3:=REF(CLOSE,4)/OPEN>1.02;
XG3:=C1 AND C2 AND C3;
D1:=REF(CLOSE,5)/REF(CLOSE,6)>1.09 AND REF(CLOSE,5)>REF(OPEN,5);
D2:=HIGH/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,5),1.05,0.85);
XG4:=D1 AND D2;
E1:=REF(CLOSE,6)/REF(CLOSE,7)>1.09 AND REF(CLOSE,6)>REF(OPEN,6);
E2:=HIGH/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,6),1.05,0.85);
XG5:=E1 AND E2;
F1:=REF(CLOSE,7)/REF(CLOSE,8)>1.095 AND REF(CLOSE,7)>REF(OPEN,7);
F2:=HIGH/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,7),1.05,0.85);
XG6:=F1 AND F2;
G1:=REF(CLOSE,8)/REF(CLOSE,9)>1.095 AND REF(CLOSE,8)>REF(OPEN,8);
G2:=HIGH/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,8),1.05,0.85);
XG7:=G1 AND G2;
H1:=REF(CLOSE,9)/REF(CLOSE,10)>1.095 AND REF(CLOSE,9)>REF(OPEN,9);
H2:=CLOSE/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,9),1.05,0.92);
H3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
XG8:=H1 AND H2 AND H3;
J1:=REF(CLOSE,10)/REF(CLOSE,11)>1.095 AND REF(CLOSE,10)>REF(OPEN,10);
J2:=CLOSE/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,10),1.05,0.92);
J3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
XG9:=J1 AND J2 AND J3;
L1:=REF(CLOSE,11)/REF(CLOSE,12)>1.095 AND REF(CLOSE,11)>REF(OPEN,11);
L2:=CLOSE/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,11),1.05,0.92);
L3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
XG10:=L1 AND L2 AND L3;
M1:=REF(CLOSE,12)/REF(CLOSE,13)>1.095 AND REF(CLOSE,12)>REF(OPEN,12) AND REF(CLOSE,13)/REF(CLOSE,14)<1.09;
M2:=CLOSE/REF(CLOSE,1)>1.041 AND BETWEEN(OPEN/REF(OPEN,12),1.05,0.92);
M3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
XG11:=M1 AND M2 AND M3;
N1:=REF(CLOSE,13)/REF(CLOSE,14)>1.095 AND REF(CLOSE,13)>REF(OPEN,13);
N2:=HIGH/REF(CLOSE,1)>1.04 AND LOW<REF(CLOSE,13);
N3:=CROSS(CLOSE,MA(CLOSE,5)) AND MA(CLOSE,5)>MA(CLOSE,20) AND CLOSE>MA(CLOSE,20);
XG12:=N1 AND N2 AND N3;
ZHXG1:=XG2 OR XG3 OR XG4 OR XG5 OR XG6 OR XG7 OR XG8 OR XG9 OR XG10 OR XG11 OR XG12;
PH1:=REF(CLOSE,9)/REF(CLOSE,10)>1.095 AND REF(CLOSE,9)>REF(OPEN,9);
PH2:=HIGH/REF(CLOSE,1)>1.041 AND LOW<REF(CLOSE,9);
PH3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
PXG8:=PH1 AND PH2 AND PH3;
PJ1:=REF(CLOSE,10)/REF(CLOSE,11)>1.095 AND REF(CLOSE,10)>REF(OPEN,10);
PJ2:=HIGH/REF(CLOSE,1)>1.041 AND LOW<REF(CLOSE,10);
PJ3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
PXG9:=PJ1 AND PJ2 AND PJ3;
PL1:=REF(CLOSE,11)/REF(CLOSE,12)>1.095 AND REF(CLOSE,11)>REF(OPEN,11);
PL2:=HIGH/REF(CLOSE,1)>1.041 AND LOW<REF(CLOSE,11);
PL3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
PXG10:=PL1 AND PL2 AND PL3;
PM1:=REF(CLOSE,12)/REF(CLOSE,13)>1.095 AND REF(CLOSE,12)>REF(OPEN,12) AND REF(CLOSE,13)/REF(CLOSE,14)<1.09;
PM2:=HIGH/REF(CLOSE,1)>1.041 AND LOW<REF(CLOSE,12);
PM3:=CROSS(CLOSE,MA(CLOSE,5)) AND CROSS(CLOSE,MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,5)>MA(CLOSE,20);
PXG11:=PM1 AND PM2 AND PM3;
VXG:=LOW<压力位 AND CLOSE>压力位;
上轨道:=MA(CLOSE,25)+MA(CLOSE,25)*20/100;
CQSX:=CROSS(CLOSE,上轨道);
ZHXG2:=PXG8 OR PXG9 OR PXG10 OR PXG11 AND VXG AND CQSX;
PDM1:=CLOSE/REF(CLOSE,1)>1.07 AND CLOSE/OPEN>1.05 AND HIGH/CLOSE<CLOSE/OPEN;
PDM2:=BETWEEN(OPEN/REF(HIGH,1),1.01,1.08) AND CLOSE/REF(CLOSE,1)>1.041 AND REF(CLOSE,1)/REF(CLOSE,2)<1.04;
PDM3:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,10)>MA(CLOSE,30) AND MA(CLOSE,30)>MA(CLOSE,60);
PDM4:=REF(CLOSE,1)/REF(CLOSE,2)<1.09 AND REF(CLOSE,2)/REF(CLOSE,3)<1.09;
PDXG:=COUNT(REF(PDM1,1),20) AND PDM2 AND PDM3 AND PDM4;
YZB1:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)=REF(OPEN,3);
YZB2:=HIGH/REF(CLOSE,1)>=1.041 AND OPEN<REF(CLOSE,3);
YZXG2:=YZB1 AND YZB2;
YZC1:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)=REF(OPEN,4);
YZC2:=HIGH/REF(CLOSE,1)>=1.041 AND OPEN<REF(CLOSE,4);
YZXG3:=YZC1 AND YZC2;
YZZH:=YZXG2 OR YZXG3;
KM1:=CLOSE/REF(CLOSE,1)>1.095 AND CLOSE=HIGH AND OPEN<MA(CLOSE,10) AND CLOSE>MA(CLOSE,10) AND OPEN<MA(CLOSE,20) AND CLOSE>MA(CLOSE,20) AND OPEN<MA(CLOSE,30) AND CLOSE>MA(CLOSE,30);
DM1:=HIGH/REF(CLOSE,1)>1.041 AND LOW<MA(CLOSE,5) AND CLOSE>MA(CLOSE,5) AND LOW<MA(CLOSE,10) AND CLOSE>MA(CLOSE,10) AND LOW<MA(CLOSE,20) AND CLOSE>MA(CLOSE,20) AND (LOW<MA(CLOSE,60) AND CLOSE>MA(CLOSE,60) OR (LOW<MA(CLOSE,120) AND CLOSE>MA(CLOSE,120)));
KDXG:=COUNT(REF(KM1,3),12) AND DM1;
GKB1:=REF(CLOSE,3)/REF(CLOSE,4)>1.09 AND REF(CLOSE,3)>REF(OPEN,3);
GKB2:=HIGH/REF(CLOSE,1)>=1.041 AND HIGH/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,3),1.06,0.92) AND REF(VOL,1)<REF(VOL,2) AND REF(HIGH,2)/MAX(REF(OPEN,2),REF(CLOSE,2))<1.07 AND MA(CLOSE,20)/MA(CLOSE,30)<1.05 AND REF(LOW,2)<REF(CLOSE,3);
GKXG1:=GKB1 AND GKB2;
GKC1:=REF(CLOSE,4)/REF(CLOSE,5)>1.09 AND REF(CLOSE,4)>REF(OPEN,4);
GKC2:=HIGH/REF(CLOSE,1)>=1.041 AND CLOSE/REF(CLOSE,1)>=1.031 AND BETWEEN(OPEN/REF(OPEN,4),1.06,0.92);
GKC3:=REF(VOL,1)<REF(VOL,2) AND REF(VOL,2)<REF(VOL,3) AND REF(HIGH,3)/MAX(REF(OPEN,3),REF(CLOSE,3))<1.07 AND HIGH>MA(CLOSE,5) AND CLOSE>MA(CLOSE,10) AND CLOSE>MA(CLOSE,30) AND REF(LOW,3)<REF(CLOSE,4);
GKXG2:=GKC1 AND GKC2 AND GKC3;
GKXGXG:=GKXG1 OR GKXG2;
ZHXGXG:ZHXG1 OR ZHXG2 OR YZZH OR KDXG OR GKXGXG;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 套装公式 通达信 第二代极品双响炮抓牛指标 https://www.694.cn/ziliaoxiazai/tongdaxin/5498.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务