通达信 跟庄器指标 二踢脚大嘴巴交易系统源码 公式源码

2024-04-27 0 421

通达信 跟庄器指标 二踢脚大嘴巴交易系统源码 公式源码

AAA1:49;
BBB2:52;
B1:=REF(CLOSE,1);
B2:=REF(CLOSE,2);
B3:=REF(CLOSE,3);
B4:=REF(CLOSE,4);
CMAX:=MAX(MAX(MAX(CLOSE,B1),B2),B3);
CMIN:=MIN(MIN(MIN(CLOSE,B1),B2),B3);
BT:=REF(VOL,1);
BB1:=IF(O=REF(C,1),O,REF(C,1));
多建:=IF((C>CMIN)*(VOL>BT) OR (C>CMAX)*(VOL>BT),VOL-BT,0);
空平:=IF((C>CMIN)*(VOL<BT) OR (C>CMAX)*(VOL<BT),VOL-BT,0);
空建:=IF((C<CMAX)*(VOL>BT) OR (C<CMIN)*(VOL>BT),VOL-BT,0);
多平:=IF((C<CMAX)*(VOL<BT) OR (C<CMIN)*(VOL<BT),VOL-BT,0);
AAA:=多建+多平;
BBB:=空建+空平;
多头持单:=SUM(AAA,0);
AAT1:=多头持单>REF(多头持单,1);
AAT2:=多头持单<REF(多头持单,1);
AAT3:=多头持单=REF(多头持单,1);
空头持单:=SUM(BBB,0);
BBT1:=空头持单>REF(空头持单,1);
BBT2:=空头持单<REF(空头持单,1);
BBT3:=空头持单=REF(空头持单,1);
当日主力买入量:=(BUYVOL*0.5+SELLVOL
*0.1)/2;
庄家持仓量:=SUM(VOL,100)*0.20;
HOLD:=庄家持仓量;
B5:=SUM(VOL,5)/5;
B6:=SUM(HOLD,5)/5;
VAR1:=(VOL/ (((HIGH – LOW) * 2) – ABS((CLOSE – OPEN))));
VAR2:=(HIGH-LOW);
VAR3:=ABS((OPEN-CLOSE));
VAR4:=(HIGH-IF((CLOSE>OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE>OPEN),OPEN,CLOSE)-LOW);
VAR6:=((VAR3/VAR2)*VOL);
VAR7:=((VAR4/VAR2)*VOL);
VAR8:=((VAR5/VAR2)*VOL);
多头:=((CLOSE=CMAX)*(B1=CMIN))*((HOLD>B6)*(VOL>B5)) OR ((CLOSE=CMAX)*(B1>=B2 OR B1>=B3)
OR ((B1=CMAX)*(B2=CMIN OR B3=CMIN)*(CLOSE>=B2)) OR (B2=CMAX)*(B3=CMIN)*(CLOSE>=B1)
OR (B3=CMAX)*(CLOSE>=B1)*(CLOSE>=B2))*((HOLD>B6)*(VOL>B5)) OR ((B1=CMIN)*(CLOSE>=B2)
OR (B2=CMIN)*(B1<=B3) OR (B3=CMIN)*(B1<=B2)*(B2<B4)*(CLOSE>=B1))*((HOLD>B6)*(VOL>B5));
多头3:=((CLOSE=CMAX)*(B1=CMIN))*((HOLD>B6)*(VOL<B5)) OR ((CLOSE=CMAX)*(B1>=B2 OR B1>=B3)
OR ((B1=CMAX)*(B2=CMIN OR B3=CMIN)*(CLOSE>=B2)) OR (B2=CMAX)*(B3=CMIN)*(CLOSE>=B1)
OR (B3=CMAX)*(CLOSE>=B1)*(CLOSE>=B2))*((HOLD>B6)*(VOL<B5)) OR ((B1=CMIN)*(CLOSE>=B2)
OR (B2=CMIN)*(B1<=B3) OR (B3=CMIN)*(B1<=B2)*(B2<B4)*(CLOSE>=B1))*((HOLD>B6)*(VOL<B5));
多衰:=((CLOSE=CMAX)*(B1=CMIN))*((HOLD<B6)*(VOL<B5)) OR ((CLOSE=CMAX)*(B1>=B2 OR B1>=B3)
OR ((B1=CMAX)*(B2=CMIN OR B3=CMIN)*(CLOSE>=B2)) OR (B2=CMAX)*(B3=CMIN)*(CLOSE>=B1)
OR (B3=CMAX)*(CLOSE>=B1)*(CLOSE>=B2))*((HOLD<B6)*(VOL<B5)) OR ((B1=CMIN)*(CLOSE>=B2)
OR (B2=CMIN)*(B1<=B3) OR (B3=CMIN)*(B1<=B2)*(B2<B4)*(CLOSE>=B1))*((HOLD<B6)*(VOL<B5));
多平1:=((HOLD<B6)*(VOL>B5))*((B1=CMAX)*(CLOSE=CMIN)) OR ((HOLD<B6)*(VOL>B5))*
((CLOSE=CMIN)*(B1<B2 OR B1<B3) OR (B1=CMIN)*(B2=CMAX OR B3=CMAX)*(CLOSE<B2) OR
(B2=CMIN)*(B3=CMAX)*(CLOSE<B1) OR (B3=CMIN)*(CLOSE<B1)*(CLOSE<B2));
空头:=((HOLD>B6)*(VOL>B5))*((B1=CMAX)*(CLOSE=CMIN)) OR ((HOLD>B6)*(VOL>B5))*
((CLOSE=CMIN)*(B1<B2 OR B1<B3) OR (B1=CMIN)*(B2=CMAX OR B3=CMAX)*(CLOSE<B2) OR
(B2=CMIN)*(B3=CMAX)*(CLOSE<B1) OR (B3=CMIN)*(CLOSE<B1)*(CLOSE<B2));
空头3:=((HOLD>B6)*(VOL<B5))*((B1=CMAX)*(CLOSE=CMIN)) OR ((HOLD>B6)*(VOL<B5))*
((CLOSE=CMIN)*(B1<B2 OR B1<B3) OR (B1=CMIN)*(B2=CMAX OR B3=CMAX)*(CLOSE<B2) OR
(B2=CMIN)*(B3=CMAX)*(CLOSE<B1) OR (B3=CMIN)*(CLOSE<B1)*(CLOSE<B2));
空衰:=((HOLD<B6)*(VOL<B5))*((B1=CMAX)*(CLOSE=CMIN)) OR ((HOLD<B6)*(VOL<B5))*
((CLOSE=CMIN)*(B1<B2 OR B1<B3) OR (B1=CMIN)*(B2=CMAX OR B3=CMAX)*(CLOSE<B2) OR
(B2=CMIN)*(B3=CMAX)*(CLOSE<B1) OR (B3=CMIN)*(CLOSE<B1)*(CLOSE<B2));
空平1:=((CLOSE=CMAX)*(B1=CMIN))*((HOLD<B6)*(VOL>B5)) OR ((CLOSE=CMAX)*(B1>=B2 OR B1>=B3)
OR ((B1=CMAX)*(B2=CMIN OR B3=CMIN)*(CLOSE>=B2)) OR (B2=CMAX)*(B3=CMIN)*(CLOSE>=B1)
OR (B3=CMAX)*(CLOSE>=B1)*(CLOSE>=B2))*((HOLD<B6)*(VOL>B5)) OR ((B1=CMIN)*(CLOSE>=B2)
OR (B2=CMIN)*(B1<=B3) OR (B3=CMIN)*(B1<=B2)*(B2<B4)*(CLOSE>=B1))*((HOLD<B6)*(VOL>B5));
STICKLINE(多头 OR 多头3,0,ABS(HOLD-REF(HOLD,1)),2,0),COLORRED;
STICKLINE(多衰,0,ABS(HOLD-REF(HOLD,1)),2,0),COLORWHITE;
STICKLINE(多平1,0,ABS(HOLD-REF(HOLD,1)),2,1),COLORRED;
STICKLINE(空头 OR 空头3,0,-ABS(HOLD-REF(HOLD,1)),2,0),COLORGREEN;
STICKLINE(空衰,0,-ABS(HOLD-REF(HOLD,1)),2,0),COLORWHITE;
STICKLINE(空平1,0,-ABS(HOLD-REF(HOLD,1)),2,1),COLORGREEN;

通达信赵轩二踢脚大嘴巴交易系统源码

『二踢脚』形态3大要点:
①个股处于上升趋势中。5、10、20和60日均线一定是多头排列,K线上方不能有长期均线的压力;
②连续上涨后大幅回落,单日跌幅超过4%;
③次日快速收复失地,涨幅超过5%。
一、流畅趋势中的『二踢脚』
{二踢脚主图}
MA5: MA(CLOSE,5),COLORFFFFFF;
MA10: MA(CLOSE,10),COLORYELLOW;
MA20: MA(CLOSE,20),COLORFF99FF;
MA60: MA(CLOSE,60),COLORGREEN;
MA120:= MA(CLOSE,90),COLOR99CCFF;
MA250: MA(CLOSE,120),COLORRED;
DRAWTEXT( MA(C,5)>=REF(MA(C,5),1) AND MA(C,10)>=REF(MA(C,10),1)
AND MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20)  AND MA(C,20)>MA(C,60)
AND REF(C,1)/REF(C,2)<0.96 AND C/REF(C,1)>1.05 AND H/C<=1.01
AND (MIN(C,O)/L<=1.025 OR C/MA(C,60)<1.3) AND  C/MA(C,60)<1.3
AND MA(C,5)/MA(C,10)<1.1  AND MA(C,10)/MA(C,20)<1.1
AND MA(C,20)/MA(C,60)<1.15 AND MA(C,5)/MA(C,20)<1.1  AND
MA(C,60)/MA(C,120)<1.3,L-0.33 ,’←2T脚++’),,COLORFFFFBF;
{二踢脚副图}
TT:MA(C,5)>=REF(MA(C,5),1) AND MA(C,10)>=REF(MA(C,10),1)
AND MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20)  AND MA(C,20)>MA(C,60)
AND REF(C,1)/REF(C,2)<0.96 AND C/REF(C,1)>1.05 AND H/C<=1.01
AND (MIN(C,O)/L<=1.025 OR C/MA(C,60)<1.3) AND  C/MA(C,60)<1.3
AND MA(C,5)/MA(C,10)<1.1  AND MA(C,10)/MA(C,20)<1.1
AND MA(C,20)/MA(C,60)<1.15 AND MA(C,5)/MA(C,20)<1.1  AND
MA(C,60)/MA(C,120)<1.3;
DRAWTEXT( TT,1-0.33 ,’←2T脚++’),,COLORFFFFBF;

{大型股票公式,股票编程,股票技术教程投稿平台-你就是股神,网址:694.cn 备注:如果正文内容没有显示完全的,说明在附件中,请点击‘立即下载’下载该附件!}
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

你就是股神 套装公式 通达信 跟庄器指标 二踢脚大嘴巴交易系统源码 公式源码 https://www.694.cn/ziliaoxiazai/tongdaxin/5471.html

常见问题
  • 售后问题,如果是单独付费的部分,请联系发布者。如果是免费部分包括VIP免费部分,请参考网站帮助中心。
查看详情
  • 因为是虚拟内容,本站只审核真实性,只供学习之用。不保证收益,所以,不接受无效无用的退款理由。
查看详情

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务